Cronjob, Apache und logrotate

  • Hallo zusammen,


    ich habe bei mir auf dem PI die ssmtp.conf angepasst, damit ich E-Mails verschicken kann.


    Seit einiger Zeit bekomme ich in meinen Postfach dafür folgende E-Mails, bei denen ich nicht weis warum. (ca. 1x pro Woche)


    Betreff:
    [font="Courier"]Cron <root@raspberrypi> test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )[/font]


    Message:
    [font="Courier"] /etc/cron.daily/logrotate:
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName[/font]


    Was hat es damit auf sich? An was könnte dies liegen?
    Hat jemand eine Idee?


    P. S. Bin mir nicht sicher ob ich im Bereich den Post erstellt habe.

    • Official Post

    Hey Dodo1988,


    Quote

    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName


    Das Problem hatte ich auch schonmal. Dies liegt daran das du keine IP hinter deinem Apache Server Namen gemappt hast.
    In der /etc/hosts Datei kannst du deinem Servernamen einer IP zuordnen - wie des mit einer dynamischen IP fluppt müsstest du allerdings selbst mal nachschlagen ;)



    Gruß,
    Turael

    Ich bin ein gefallener Engel namens Turael.

    Einst vor langer Zeit rebelierte ich im Himmel bis Gott mich auf die Erde verbannte.

    Doch meine taten werden kein ende finden....

  • Hallo Turael,


    danke für deine Antwort. Jedoch verstehe ich das "Problem" noch nicht wirklich.


    In meiner /etc/Hosts ist ein Eintrag "127.0.1.1 raspberrypi" zu finden.


    In meiner /etc/apache2/apache2.conf finde ich keine Konfig mit dem Identifier "ServerName".


    Was muss ich noch (um-)konfigurieren? Und wie meinst du das mit der dynamischen IP?


    So ganz durchschaue ich die Fehlermeldung und deine Antwort noch nicht.

    • Official Post

    Du hast in deiner /etc/apache2/site-available/(default?) einen Servernamen gesetzt und dieser Servernamen braucht eine IP ;)
    Wobei ich gerade sehe das ich meinen Servernamen auf localhost gemappt habe...


    Nachdem du nun deinen Servernamen in erfahrung gebracht hast muss dieser auch in der /etc/hosts vorkommen.
    So in etwa sieht meine hosts aus:

    Code
    127.0.0.1   localhost
    deineDomain.de  localhost
    127.0.0.1   deineDomain.de


    Die 3te Zeile muss vielleicht nicht sein - trotzdem steht sie da ;)

    Ich bin ein gefallener Engel namens Turael.

    Einst vor langer Zeit rebelierte ich im Himmel bis Gott mich auf die Erde verbannte.

    Doch meine taten werden kein ende finden....

    Edited once, last by Turael ().

  • In meiner "/etc/apache2/sites-available/Default" gibt es nur einen "<VirtualHost *:80>"-Eintrag, bei dem ich aber keinen Servername sehe.


    Mich verwirrt das Ganze jetzt noch mehr :(