Keine Ausgabe auf Webpage mit Linux

  • Hallo,


    ich habe erst seit kurzen meinen Raspberry Pi und wollte diesen benutzen um meinen Webserver zu ersetzen, weil dieser doch einiges mehr an Strom braucht als der Pi.
    Nun habe ich die TUTs zu Apache, PHP, MySQL durchgearbeitet, meine alte Datenbank importiert und einen Cronjob erstellt, der auch funktioniert und regelmäßig Werte in die Tabelle schreibt.
    Die PHP-Skripte von dem Windows-Rechner mit Xampp wollte ich einfach übernehmen, und habe sie in /var/www/avrweb im Raspberry kopiert und wollte die Webseite mit ip-adresse/avrweb aufrufen, aber es werden mir keine jpgraph-Diagramme mehr angezeigt.
    Das Komische ist, das er mir die Tabelle über den Diagrammen mit Werten füllt und auch diese aktuell immer abruft.
    Zur Verdeutlichung wie es normal ausschaut, füge ich noch ein Screenshot ein.


    Hier der Code für das Diagramm unter der Tabelle:




    [Blocked Image: http://img13.imageshack.us/img13/8712/capture20130215153944.png]

  • Hallo Obi,


    nachdem du dein PHP-Skript jetzt auf einem Linux-System einsetzt, solltest du bei den folgenen Includes auch einen Slash (/) anstelle eines Backslashs (\) verwenden.


    Code
    include ("src\jpgraph.php");
    include ("src\jpgraph_line.php");
    require_once("src\jpgraph_date.php");


    Vermutlich kann das PHP-Skript dadurch benötigte Funktionen nicht laden, welche aber für die korrekte Funktion benötigt werden.


    Gruß Georg

  • Normalerweise machen die / oder \ bei PHP nichts aus da PHP das kompensieren kann. Schalte einfach mal in der php.ini die Option Display Errors ein.


    Auf der Kommandozeile folgendes eingeben:

    Code
    sudo nano /etc/php5/apache2/php.ini


    Dann öffnet sich die Textdatei mit der du die PHP Laufzeitumgebung einstellen kannst, gehe runter bis zur Option "display_errors" und setze den Wert "On", das gleiche bei "html_errors". Dann Speicherst du die Datei mit STRG und O und schliest den Editor mit STRG und X. Dannach startest du mit folgendem Befehl den Apache Server neu.


    Code
    sudo /etc/init.d/apache2 restart


    Dannach sind die neuen Einstellungen in PHP übernommen und dir werden die Fehlermeldungen die dein Skript erzeugt angezeigt. Diese kannst du dann hier nochmal poasten.

  • Danke für die Tips.


    Zuerst habe ich die display_errors aktiviert, aber keine Fehleranzeige.
    Das ersetzen der Backslash durch Slash hat dann funktioniert.


    Vielleicht sollte ich wieder zu Linux wechseln anstatt Windows

    Edited once, last by Obi ().