Fernbedienung mit irrecord anlernen - irrecord lässt sich nicht starten

  • hallo, wie bereits im Topic beschrieben, würde ich eien lircd.conf gerne mit irrecord selbst neu erstellen. ich weis nicht obs an den kernels oder lirc oder sonst was liegt, aber die keycodes/kernelevents sind bei ubuntu und debian verschieden. bevor ich nun meine ganze configs im xbmc ändern muss ( Lircmap/remote.xml ) etc. wollte ich eine neue Lircmap mit irrecord erstellen.


    auf dem server kann ich mit < sudo /etc/init.d/lirc stop > lirc beenden und mit einem < sudo irrecord -H atilibusb testing.conf > eine neue config erstellen. die keycodes sind ebenfalls mit XEV auslesbar ( es gibt noch 1.2 anderen möglichkeiten mit scancode -parameter irgentwas, alledings liefern die tools falsche hexwerte für die lircd.conf). Auf dem raspbmc kann ich ich lirc zwar beenden aber lt. ps aux » grep lirc laufen immer noch einige lirc prozesse, pkill, killall funktioniert alles nicht um die lirc prozesse zu beenden.


    Code
    ps -aux | grep lirc
    warning: bad ps syntax, perhaps a bogus '-'?
    See http://gitorious.org/procps/procps/blobs/master/Documentation/FAQ
    root       782  0.0  0.2   2108   804 ?        Ss   17:02   0:00 eventlircd --evmap=/etc/eventlircd.d --socket=/var/run/lirc/lircd --repeat-filter --release=_UP -f
    root       845  0.0  0.4   3776  1572 ?        S    17:02   0:00 su - pi -c export XBMC_HOME=/opt/xbmc-bcm'/xbmc-bin/share/xbmc' ; LD_PRELOAD=/usr/lib/libcofi_rpi.so /home/pi/.xbmc-current/xbmc-bin/lib/xbmc/xbmc.bin --standalone -fs --lircdev /var/run/lirc/lircd 2>&1 | logger -t xbmc
    pi        1045  0.0  0.3   5044  1444 ?        Ss   17:02   0:00 -su -c export XBMC_HOME=/opt/xbmc-bcm'/xbmc-bin/share/xbmc' ; LD_PRELOAD=/usr/lib/libcofi_rpi.so /home/pi/.xbmc-current/xbmc-bin/lib/xbmc/xbmc.bin --standalone -fs --lircdev /var/run/lirc/lircd 2>&1 | logger -t xbmc
    pi        1075 15.7 13.1 354140 50612 ?        Sl   17:02   3:30 /home/pi/.xbmc-current/xbmc-bin/lib/xbmc/xbmc.bin --standalone -fs --lircdev /var/run/lirc/lircd
    pi        1904  0.0  0.1   1984   708 pts/0    S+   17:24   0:00 grep --color=auto lirc


    hat jmd vllt ein tipp wie lirc komplett beenden kann damit ich mir irrecord eine neue lircd.conf erstellen kann ?


    ich hatte schon ein tutorial für ubuntu geschrieben und dachte es sei für debian basierte system nutzbar. war wohl nix - lirc ist und bleibt einfach der horror. ist fast wie roullette spielen. zum kotzen ! und immer andere probleme die voher nie welche waren ... :wallbash::wallbash::wallbash:

  • Hast Du vorher im XBMC bei Programme->RasPi-Setting->IR-Remote den GPIO TSOP IR Receiver disabled (wenn Du natürlich über GPIO gehst..)??
    Danach reboot und dann folgende Befehle:


    sudo modprobe lirc_rpi
    sudo kill $(pidof lircd)
    ls
    irrecord -d /dev/lirc0 /home/pi/lircd.conf


    Vllt. hilfts ja... ;) Bei mir hats so geklappt....

  • Hi, hab ich letzte Woche noch selbst gemacht, wenn auch mit nem normalen raspbian ;)


    Zuerst musst du in /etc/modules


    Code
    lirc_dev
    lirc_rpi gpio_in_pin=**Deine Wahl** gpio_out_pin=**Deine Wahl, falls vorhanden**


    eintragen, falls noch nicht geschehen. Pin Nummern müssen noch an deinen Aufbau angepasst werden. "gpio_out_pin" kann weggelassen werden wenn du wirklich nur einen Empfänger hast.


    Reboot nicht vergessen.


    Danach müsste ein Device /dev/lirc0 entstanden sein.


    Du kannst mal mit

    Code
    sudo /etc/init.d/lirc stop
    mode2 -d /dev/lirc0


    probieren, ob dein Empfänger richtig arbeitet. Es sollte immer Pulse und Space abwechselnd auftreten.


    Danach kannst du mal mit

    Code
    sudo irrecord -n -H default -d /dev/lirc0 **Remotedateiname**


    eine neue Datei erzeugen.


    Mit

    Code
    sudo chmod 600 **Remotedateiname**


    solltest du noch die Berechtigung so setzen, wie lirc das gerne hätte.


    Die entandene Datei kannst du dann nach /etc/lirc/lircd.conf kopieren. Direktes Schreiben der lircd.conf wird nicht gehen, da sie normalerweise Berechtigung 600 hat.


    Danach noch den Service neustarten

    Code
    sudo service lirc restart


    Fertig.


    Ich hab persönlich noch irexec für mein Hyperion (über Lan) am laufen, das spar ich mir aber erstmal ;)