LED Matrix mit PI steuern


  • Kann mir einer weiterhelfen, welches Netzteil passt?


    mal ehrlich soll man den ganzen Thread noch mal lesen um die Leistungsdaten rauszubekommen ?


    passen tun irgendwie alle


    das 2te ist am niedlichsten für integrieren
    das erste wäre normalerweise meine Wahl und an der selbstgebauten Elektronik würde ich gleich die richtige DC Buchse verbauen


    ich suche mir immer Steckerschaltnetzteile mit DC 5,5/2,1mm Stecker weil die am gebräuchlichsten sind. Nur Fritz muss 5,5/2,5 wählen :wallbash:

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Sorry.


    Hier noch mal für alle die Daten der LED Stripes:
    48 leds/Meter (5 Meter = 240 LEDs)
    DC 5V
    72 W


    fehlt noch was?


    Wenn ich jetzt richtig gerechnet habe, müsste folgendes Netzteil passen (wenn es von den Werten passt, würde ich mich auch für dieses entscheiden):
    http://www.amazon.de/gp/product/B00G8B4OHU/ref=oh_details_o03_s00_i00?ie=UTF8&psc=1&tag=httpwwwforumr-21 (Affiliate-Link)
    Liege ich damit richtig?


    Edit:
    Übrigens, LEDs sind bereits bei mir eingetroffen. Habe jetzt als nächstes vor, den kompletten LED Stripe an PI anzuschließen um zu kucken, ob dieser überhaupt funktioniert bzw. ich ein bisschen üben kann, bevor ich mich an das werkeln mache.
    Ich möchte mich schon mal hier an dieser Stelle für eure Hilfe bedanken. Vor allem bei dir JAR. :danke_ATDE::danke_ATDE:
    Vielen Dank für deine Geduld und Hilfsbereitschaft.:bravo2::bravo2:

    Edited once, last by zazzles ().

  • und warum hast du weiter vorher ein 2A Netzteil gezeigt ?



    woher soll ich wissen wieviele LEDs du verbauen willst ?


    aber gibt dir das hier nich was zu denken ?


    48 leds/Meter (5 Meter = 240 LEDs) DC 5V 72 W


    wenn ich 72W / 5V teile komme ich auf 14,4A !
    diese geteilt durch 240 LEDs -> 60mA pro LED maximal, das passt schon mal und ist ein bekannter Wert für weiss alle Farben volle Helligkeit !


    aber wie kommst du dann auf dieses Netzteil ?
    5V 12A 60W wenn oben schon 72W steht und hier 60W


    aber wenn du weniger LED verbaust kann das passen, aber du bist ja nicht so der Informationslieferant ....und das ist echt mühsam ......


    nächstes mal rechnest du selber, habs ja vorgerechnet :D

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Ja das 2A Netzteil ka. wie das da rein kommt ;)
    Stimmt. Jetzt wo du es sagst. Habe das heute Mittag in der Pause schnell versucht zu berechnen und hier zu posten. Alles schief gegangen. :(
    Aber danke, dass du mir quasi einen kleinen klops auf den Hinterkopf gegeben hast.
    Habe mir außerdem zum Verbinden folgende Kabel besorgt:
    http://www.amazon.de/gp/product/B00DI4ZTN8/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1 (Affiliate-Link)


    Jetzt fürn Anfang, quasi als Funktionstest, möchte ich erst mal alle LEDs in Betrieb nehmen. Also brauche ich sehr wahrscheinlcih ein Netzteil mit 72 W. Mit den oben genannten Steckern, kann ich dann die LEDs an den PI anschließen so der Plan.
    Danach kann ich erstmal versuchen das komplette Stripe zum Leuchten zu bringen.
    Das heißt ich habe dann Netzteil, LED Stripe, Steckverbindungen und natürlich nicht zu vergessen einen Pi. Habe ich jetzt noch was vergessen, was ich aus Hardware-Sicht noch vergessen habe?


  • Aber danke, dass du mir quasi einen kleinen klops auf den Hinterkopf gegeben hast.


    soll ja helfen, hat aber noch nicht gereicht :lol:


    nun muss ich wieder suchen welchen Stripe du hast ?



    Habe mir außerdem zum Verbinden folgende Kabel besorgt:
    http://www.amazon.de/gp/product/B00DI4ZTN8/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1 (Affiliate-Link)


    Jetzt fürn Anfang, quasi als Funktionstest, möchte ich erst mal alle LEDs in Betrieb nehmen.


    was willst du mit diesen dünnen Strippen ? wenn deine Power 14,4 A Strom braucht ?
    willst du jede 2er LED Gruppe einzeln mit diesen dünnen Strippen verkabeln ?


    zum Testen einige dicke Leitungen 1,5mm² vorne hinten und Mitte an +5 und GND zum Netzteil


    Also brauche ich sehr wahrscheinlcih ein Netzteil mit 72 W.


    ja brauchst du


    Habe ich jetzt noch was vergessen, was ich aus Hardware-Sicht noch vergessen habe?


    ja dicke Leitungen hochflexibel 1,5mm² Silikonleitung wäre toll
    http://www.xxl-modellbau.de/15…T-SCHWARZ-15qmm-15-qmm-mm


    rot ist schwarz und plus ist minus oder so :D ach ne


    rot ist +5V und schwarz ist GND, so war das doch :angel:

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • So jetzt aber.
    Habe jetzt folgendes Netzteil (80 W, 16 A, 5V):
    http://www.reichelt.de/Schaltnetzteile-Case-geschlossen/SNT-RS-100-5/3/index.html?&ACTION=3&LA=3&ARTICLE=137106&GROUPID=4959


    Alle anderen die ich gefunden habe, lieferten nicht mal ansatzweise 10 A.


    Versuche jetzt noch einmal alle Daten für meine LED-Stripes zu nennen. Falls dir noch etwas fehlt, sagt bitte konkret was euch fehlt.
    Technische Daten:
    48 leds/Meter (5 Meter = 240 LEDs)
    DC 5V
    72 W
    SMD5050
    LPD8806


    Habe folgendes gemeint. Bevor ich jetzt meine Matrix beginne, möchte ich erst einmal alle LEDs (komplette Stripe) in Betrieb nehmen. Deshalb die einzelnen Kabel. Für die Matrix selbst, nehme ich selbstverständlich andere Kabel und dann auch keine einzelnen.


  • passt denke aber bitte an die Sicherheit, ich weiss nicht wie sauber du arbeitest an 230V, denke an Berührungsschutz, Abdeckungen und Aderendhülsen zum anklemmen !



    da wäre es doch am einfachsten die Kette ungeschnitten zu lassen, am Anfang und Mitte und Ende die 5V + GND mit 3x 2 dicken 1,5mm² zum Netzteil zu führen.


    Beachte die Signalrichtung für Data, Clock in den Stripe und vergesse GND zum PI nicht.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Danke für den Hinweis. Bei so einer Spannung kann man das nicht oft genug sagen. Ist mir aber bewusst.


    Quote

    da wäre es doch am einfachsten die Kette ungeschnitten zu lassen, am Anfang und Mitte und Ende die 5V + GND mit 3x 2 dicken 1,5mm² zum Netzteil zu führen.


    Erst einmal um zu sehen ob es geht, habe ich auch vor den Stripe ungeschnitten zu lassen. Was meinst du nur dann mit Anfang und Mitte und Ende? Der Stripe ist doch ungeschnitten.

    Edited once, last by zazzles ().


  • ....Was meinst du nur dann mit Anfang und Mitte und Ende? Der Stripe ist doch ungeschnitten.


    Trotzdem kann ich doch am Anfang und Ende und auch in der Mitte +5V und GND anlöten und zum Netzteil führen :s jedenfalls bei meinem LED Stripe ging das, die Kupferflächen sind ja eindeutig zu erkennen!

    Images

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Achso. Jetzt verstehe ich was du meinst. Kannst du mir kurz auf die Sprünge helfen, warum das sinnvoll ist?



    Hier noch mal kurz ein Link zu meinen Stripes: http://de.aliexpress.com/item/…-48LEDs-m/1869711166.html
    Kurz noch mal zum Verbinden des ganzen. Habe es noch nicht so mit Fachausdrücken. Versuche das möglichst detailiert zu beschreiben.
    Aus dem "Anfang" des Stripes gehen einmal 2 Kabel und einmal 4 Kabel raus. Die 2 (schwarz und rot, quasi + und -) sind für das Netzteil. Die anderen 4 schwarz blau grün rot sind für den pi.
    Der schwarze (GND) muss an den PI ebenfalls an den GND vom PI (2. Reihe senkrecht, 3. von oben). richtig? Der blaue müsste DI sein und muss am PI an den "MOSI" (1. Reihe senkrecht, 4. von unten) und der grüne CI muss an den PI an SCLK (1. Reihe senkrecht 2. von unten). Der rote, wenn ich mich jetzt richtig informiert habe muss nicht an den PI angeschlossen werden. Richtig?
    Stimmt das so bzw. versteht ihr was ich meine?


    Falls das unverständlich ist, muss ich halt mal eine Zeichnung anfertigen.

    Edited once, last by zazzles ().


  • ....Kannst du mir kurz auf die Sprünge helfen, warum das sinnvoll ist?


    weil im ganzen Stripe 14,4A fliessen bei maximaler Helligkeit und weil ich bezweifel das am Ende noch 5V ankommen, deswegen unterstützen wir den Stromfluß mit dicken Kabeln weil nur dann die richtige Funktion gewährleistet ist.



    Aus dem "Anfang" des Stripes gehen einmal 2 Kabel und einmal 4 Kabel raus. Die 2 (schwarz und rot, quasi + und -) sind für das Netzteil. Die anderen 4 schwarz blau grün rot sind für den pi.
    Der schwarze (GND) muss an den PI ebenfalls an den GND vom PI (2. Reihe senkrecht, 3. von oben). richtig? Der blaue müsste DI sein und muss am PI an den "MOSI" (1. Reihe senkrecht, 4. von unten) und der grüne CI muss an den PI an SCLK (1. Reihe senkrecht 2. von unten). Der rote, wenn ich mich jetzt richtig informiert habe muss nicht an den PI angeschlossen werden.


    woher sollen wir wissen welche Farben wie wo gelten ?


    vergiss einfach die Farben, nehme dein Messgerät und messe mit Prüfspitzen an dem bedrucktem Kupfer, +5V GND, das ist an jeder Stelle zu den Kabeln möglich !


    Nur Din und Clock kannst du nur am Eingang Din -> Signalrichtung beachten -> wo die Kabel sind messen !


    und klar die Stripes wollen Din aus PI Mosi weil MOSI os für output signal steht !
    Für den PI ist es out, für die LEDs in

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Mach ich mit dem Messgerät.
    Kurz nur für mich zur Bestätigung. Wenn die Farben so sind wie ich es beschrieben habe. Würde meine "Schaltung" funktionieren/stimmen?


  • Mach ich mit dem Messgerät.
    Kurz nur für mich zur Bestätigung. Wenn die Farben so sind wie ich es beschrieben habe. Würde meine "Schaltung" funktionieren/stimmen?


    auf wörtliche Beschreibung reagiere ich nicht (ist kein böser Wille, es ist nur zu missverständlich !)
    http://projectcartoon.com/create/


    dazu gibt es Schaltbilder wo alles eindeutig ist!
    Ich mag eagle, ist für deinen Plan gratis zu haben
    http://www.cadsoft.de/download-eagle/#v6 !

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().

  • Ich weiß du willst einen Schaltplan, hatte bis jetzt noch keine Zeit hierfür. Habe nun ein Bild gefunden, dass fast das darstellt, was ich gemeint habe.
    http://serhan.in/wp-content/up…are_ws2801_connection.png


    Einzigster Unterschied. Aus meinen Stripes gehen extra zwei Kabel (+/-, schwarz, rot) für den DC raus. Diese würde ich direkt an mein Netzteil anschließen. Aus dem Anfang der Stripes gehen vier Kabel raus. (GND, DI, CI, +5v). Von denen muss ich nur folgende drei Kabel an den PI anschließen: GND, DI, CI. Richtig? Würdest du zumindest das ohne Schaltplan beantworten? Natürlich unter Berücksichtigung der Signalrichtung.


    Vielen Dank!


  • ....Ich weiß du willst einen Schaltplan, hatte bis jetzt noch keine Zeit hierfür. Habe nun ein Bild gefunden, dass fast das darstellt, was ich gemeint habe.


    fast ist nicht genug, aber nun gut ;)


    .....Von denen muss ich nur folgende drei Kabel an den PI anschließen: GND, DI, CI. Richtig?


    richtig, so ist der Plan !



    Würdest du zumindest das ohne Schaltplan beantworten? Natürlich unter Berücksichtigung der Signalrichtung.


    unmöglich, ich weiss nicht ob die Chinesen richtig verkabelt haben, ich weiss nicht ob du dann richtig verkabelst, was soll ich dazu sagen ?

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Habe jetzt meine LEDs zum Laufen gebracht. Endlich mal wieder für mein Projekt Zeit gefunden. LEDs leuchten!
    Habe dies mit Hyperion getestet.
    So nun funktioniert die Hardware, jetzt kommt der zweite Teile -> Die Software!
    Mit welcher Programmiersprache geht dies am besten eurer Erfahrung nach?

  • ich würde C nehmen, andere halt Phyton.....

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Habe mich nun für Python entschieden. Hierfür gibt es schon eine tolle Library:
    https://github.com/adammhaile/RPi-LPD8806


    Allerdings habe ich gerade andere Probleme. Habe es gestern zum Laufen gebracht. Habe das "example" durchlaufen lassen und habe schon mal selbst ein paar Kleinigkeiten ausprobiert. Noch nichts Weltbewegendes.
    Jetzt habe ich allerdings gerade das Problem, das gar nichts mehr geht. Pi startet nicht mehr. Raspbian auch neu aufgesetzt. Am Anfang wieder Pfeil schnell. WLAN eingerichtet. Etwas langsamer. Python installiert und die Bibliothek heruntergeladen. Ganz langsam. Verbindung zum Pi raucht ab oder er startet gar nicht. Nach mehreren versuchen erst. Habe nach dem erneuten aufsetzen von Raspbian noch nichts, kein Programm durchlaufen lassen um die LEDs anzusprechen. Also an irgendeinem falschen Programm von mir kann es nicht liegen. Kann mir einer weiterhelfen? Woran kann es liegen?


    edit: Ich habe die Vermutung, dass die SD-Karte defekt ist. Habe das ganze mal mit meiner zweiten SD-Karte ausprobiert, allerdings ohne WLAN Dongle, und mit ihr funktioniert alles einwandfrei und schnell. Die scheinbar defekte SD-Karte lässt sich aber einwandfrei formatieren, ich kann auf diese schreibend und lesend zugreifen. Was kann also an dieser defekt sein?
    Bin gerade noch ein bisschen am ausprobieren. Habe schon mal Knight Rider-Licht nachgestellt. Funktioniert alles bisher einwandfrei. Zurzeit sieht mein Plan vor, dass ich in meinem Weihnachtsurlaub meine Matrix anfange, also LED-Stripes trennen und entsprechend zu einer Matrix zusammenbauen/-löten. Kann ja dann mal ein paar Bilder posten.

    Edited once, last by zazzles ().

  • Meine Matrix ist fast fertig. Warte jetzt nur noch auf die Lieferung der Plexiglasscheiben. Danach kann ich alles fertig zusammenbauen. Sobald das ganze Konstrukt fertig ist, liefere ich ein paar Bilder.
    Habe auch schon ein Paar Animationen implementiert.
    Mittlerweile gibt es auch von adammhaile eine neue Version seiner Bibliothek (diese kann ich nur empfehlen):
    https://github.com/ManiacalLabs/BiblioPixel


    Das Problem was ich erwähnt hatte, lag wohl doch nicht an der SD-Karte, sondern viel mehr an dem Wifi-Dongle. Habe mir nun einen neuen Wifi-Dongle gekauft. Mit dem ist es etwas besser.
    Habt ihr mit Wifi-Dongles auch solche Verbindungsprobleme? Muss mich des öfteren neu anmelden (per SSH). Meine Vermutung, es liegt vllt an der Stromversorgung. Dies muss ich aber noch genauer spezifizieren. Mein Netzteil hat 2,1 A. Das sollte doch für den Pi einem Wifi-Dongle reicen, oder?
    Der nächste Schritt ist, ein aktiven USB-Hub zu verwenden.


    Vielen Dank noch mal an dieser Stelle an jar! Vielen Dank für deine Geduld und freundliche Unterstützung!