USB Soundkarte kein Ton bei Film

  • Hallo,


    ich bin ganz neu in der Raspberry-Pi-Welt. Ich hatte mir zuerst OpenElec auf den Pi geladen, dann aber schnell gemerkt, dass mir der analoge Soundausgang nicht genügt (zu leise, zu flach). Also eine USB-Soundkarte gekauft (ja, ne billige Speedlink Vigo..., ob die besseren Sound macht, wird sich zeigen) und angeschlossen. Unter OpenElec nicht zum Laufen bekommen.
    Als nächsten Schritt RaspBMB installiert, jetzt lief die USB-Soundkarte. Sie ist auch lauter und ich habe den Eindruck, dass sie auch etwas satter klingt. Ich habe etwas Radio gehört und ein paar MP3s abgespielt. Dann kam die Überraschung, als ich den ersten Film abspielen wollte: Kein Ton. (Unter OpenElec hatten die aber welchen auf dem analogen Ausgang). Selbst alte Filme mit MP3-Ton machen keinen Mucks (es liegt also nicht am Audioformat AAC). Witzigerweise sind die Töne der Oberfläche durchaus parallel zu hören. Wenn ich also während des Films ein Menü aufrufen, dann kommt das Zischgeräusch des aufpoppenden Menüs.
    Ich habe jetzt schon ein bisschen herumgesucht, aber noch keine echte Lösung meines Problems gefunden. Und bevor ich wieder alle Einstellungen verfrickele, dachte ich, frage ich lieber mal die Experten.


    Hat irgendjemand eine gute Idee?

  • Benutzt du HDMI und hat dein TC Boxen eingebaut? Wenn ja dann wird der Sound standardmäßig über HDMI ausgegeben, wenn nicht dann wird Audio über den 3,5" Klinke ausgegeben.


    Generell ist notwendig, die USB-Sound-Karte erst an den RaspberryPi anzuschließen und ihn erst dann zu booten.


    Es ist nun nötig die Konfiguration des Linux-Systems geringfügig anzupassen, damit statt des integrierten Audioausgangs der neue USB-Audioausgang bevorzugt wird.
    Öffne dazu mit dem Befehl

    Code
    sudo nano /etc/modprobe.d/alsabase.conf


    die Alsa-Konfigurationsdatei, die auf Raspbian und anderen Linux-Systemen für die Klangausgabe von Programmen zuständig ist.


    Gehe in der Datei zur Zeile options snd-usbaudio index=-2 und änder diese auf options snd-usb-audio index=0 - Speicher die Datei und reboote das System.


    Für einen schnellen Test mit Rauschen auf beiden Kanälen führe in der Kommandozeile einfach

    Code
    speaker-test -c2 -D hw:0,0


    aus, woraufhin weißes Rauschen über die angeschlossene USB-Soundkarte ertönt.


    Kompatible Soundkarten sind hier aufgelistet: http://elinux.org/RPi_VerifiedPeripherals#USB_Sound_Cards


  • Benutzt du HDMI und hat dein TC Boxen eingebaut? Wenn ja dann wird der Sound standardmäßig über HDMI ausgegeben, wenn nicht dann wird Audio über den 3,5" Klinke ausgegeben.


    HDMI-Ausgang für den Bildschirm (PC-Bildschirm ohne Lautsprecher). Habe in den Einstellungen schon die USB-Soundkarte als Standard gesetzt.

    Quote


    Generell ist notwendig, die USB-Sound-Karte erst an den RaspberryPi anzuschließen und ihn erst dann zu booten.


    Klar, sie läuft ja auch: bei MP3, Webradio und den Soundeffekten der Bedienoberfläche. Nur eben nicht bei Filmen.

    Quote

    Es ist nun nötig die Konfiguration des Linux-Systems geringfügig anzupassen, damit statt des integrierten Audioausgangs der neue USB-Audioausgang bevorzugt wird.
    Öffne dazu mit dem Befehl

    Code
    sudo nano /etc/modprobe.d/alsabase.conf


    die Alsa-Konfigurationsdatei, die auf Raspbian und anderen Linux-Systemen für die Klangausgabe von Programmen zuständig ist.


    Die Datei existiert bei mir nicht. Ich habe jetzt mal alsa-base nachinstalliert mit

    Code
    sudo apt-get install alsa-base


    Die Datei erscheint aber noch immer nicht :(

    Quote

    Gehe in der Datei zur Zeile options snd-usbaudio index=-2 und änder diese auf options snd-usb-audio index=0 - Speicher die Datei und reboote das System.


    Was mache ich, wenn es die Datei nicht gibt?

    Quote


    Für einen schnellen Test mit Rauschen auf beiden Kanälen führe in der Kommandozeile einfach

    Code
    speaker-test -c2 -D hw:0,0


    aus, woraufhin weißes Rauschen über die angeschlossene USB-Soundkarte ertönt.


    Funktioniert einwandfrei. Tat es vorher aber auch schon. Ich kann Radio hören, Musik hören, aber bei Videos kommt kein Ton.

    Quote


    Kompatible Soundkarten sind hier aufgelistet: http://elinux.org/RPi_VerifiedPeripherals#USB_Sound_Cards


    Die Speedlink Vido wurde in diversen Foren als kompatibel genannt.


    Ich bin leider keinen Schritt weiter.
    [hr]
    Korrektur: alsa-base.conf gibt es jetzt schon, aber sie ist leer.

    Edited once, last by bobhund ().

  • Wir die Karte denn überhaupt vom System erkannt?


    Hast du in den Einstellungen von RaspBMC eingestellt dass eine externe Soundkarten genutzt werden soll?


    Die USB-Soundkarten-Unterstützung ist in XBMC eben noch experimenteller Natur.


    Worum es bei dir keine alsa.conf gibt weiß ich nicht, so wird das jedenfalls auf etlichen Seiten beschrieben wie zB auch hier:
    http://www.marcuslausch.de/201…undkarte-am-raspberry-pi/
    http://raspberrypi.stackexchan…-card-found-but-no-output
    http://raspberrypi4dummies.wor…-sound-on-a-raspberry-pi/


    ggf musst du auch nur die Firmware + Kernel updaten...


  • Wir die Karte denn überhaupt vom System erkannt?


    lsusb:

    Code
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
    Bus 001 Device 004: ID 0d8c:000e C-Media Electronics, Inc. Audio Adapter (Planet UP-100, Genius G-Talk)


    Außerdem höre ich ja Radio und Mp3 über die Soundkarte. Dazu muss sie ja wohl erkannt werden. Das einzige, was ich nicht hören kann, ist der Ton von Filmen.

    Quote


    Hast du in den Einstellungen von RaspBMC eingestellt dass eine externe Soundkarten genutzt werden soll?


    ja.

    Quote


    ggf musst du auch nur die Firmware + Kernel updaten...


    Nur. Ok :) Wie?

  • Hab jetzt alsa-utils nachinstalliert. Jetzt gibt's die alsa-base.conf. Habe sie nach den Vorgaben bearbeitet.


    Ein manuelles Firmware-Update wird für RaspBMC nicht empfohlen, es gibt auch an, dass die Distribution nicht kompatibel ist. Ich nehme mal an, das Update ist für Raspian?


    Dies war mein nächster Versuch:
    http://raspberrypi4dummies.wor…-a-raspberry-pi/#comments


    Aber auch leider kein Erfolg.
    [hr]
    Habe jetzt gerade gemerkt, dass Musik & Menütöne über die externe Soundkarte ausgegeben werden, der Ton von Filmen aber weiterhin über die interne Klinkenbuchse des Pi (habe meinen Kopfhörer dort angeschlossen und kann dort jetzt den Ton hören). Sehr seltsam. Wie stelle ich das denn um?

    Edited once, last by bobhund ().

  • Weiß jmd auswendig welcher Player bei RaspBMC verwendet wird? Hab grad kein RaspBMC-Image da.


    Es ist sicher nicht VLC aber ich weiß, das VLC die Systemeinstellungen zur Soundkarte ignoriert und seine eigenen verwendet.
    Vll ist das beim RaspBMC auch so. Würde aufjedenfall dazu passen, dass Musik über die ext. läuft


    Gibts unter Viedoeinstellungen vll nochmal "Ton"?

    Edited once, last by tmaex ().

  • Ich hab mal Debug-Log eingeschaltet und nachher durchgeschaut. Dort wird ein OMX-Player erwähnt. Offenbar ist das der Player?


    Ich habe auch noch dies hier versucht, aber keine Änderung im Verhalten:


    http://www.forum-raspberrypi.d…undkarte-installation-wie


    Nach einer weiteren Möglichkeit, die Tonausgabe für Videos zu beeinflussen habe ich auch schon gesucht, aber noch nicht gefunden. Vielleicht muss man das manuell in der config.txt tun, aber für sowas habe ich echt zu wenig Ahnung von der Materie :(
    [hr]
    Sieht so aus, als würde das ganze generell nicht gehen. Schade:


    http://www.forum-raspberrypi.d…-soundkarte-und-omxplayer

    Edited once, last by bobhund ().

  • Besser spät als nie hier die Lösung:
    Der OMX-Player (wird sowohl bei OpenElec als auch bei RaspBMC als Standard-Player benutzt) unterstützt kein ALSA, weswegen die meisten USB-Soundkarten nicht damit funktionieren können.
    Man kann glaube ich zumindest bei OpenElec im Menü irgendwo auf "play using dvdplayer" umstellen, oder alternativ kann man auf jeden Fall via SSH in der advancedsettings.xml den "omxplayer" auf "dvdplayer" als Standard verändern. Der Player macht allerdings Probleme mit HDMI-Passthrough für Merhkanal, weshalb dieser im Optionsmenü (Einstellungen/System/Audio) deakiviert sein muss. Wie's das bei RASPMC geht weiß ich nicht, aber vielleicht genau so.


    EDIT: Ich habe gerade gelesen, dass man alternativ auch eine "advancedsettings.xml" dem Userdata-Ordner anlegen kann (bequem von Windows via SMB-Netzwerk zugreifbar, also ohne SSH)
    Die Datei muss nur folgenden Inhalt haben
    "


    <advancedsettings>
    <video>
    <defaultplayer>dvdplayer</defaultplayer>
    <defaultdvdplayer>dvdplayer</defaultdvdplayer>
    </video>
    </advancedsettings>


    "
    Hier kann man die Datei auch schon fertig runterladen: http://pastebin.com/sJFS0NJ1

  • Ich bin inzwischen auf einen anderen Verstärker umgestiegen und greife das Audiosignal über HDMI ab. Das läuft gut. Deswegen brauche ich die Anleitung jetzt nicht mehr auszuprobieren. Aber dennoch danke!