Automatischer Wechsel der HDMI Quelle durch CEC deaktivieren!

  • Hey Leute,


    ich habe den Rasp an einem Samsung TV. Wenn ich den Rasp anmache, gibt der Rasp dem TV den Befehl auf die HDMI Quelle vom Rasp umzuschalten. Dieses läuft meiner Meinung nach durch CEC.


    Und genau dieses möchte ich deaktivieren.


    Hintergrund: Ich möchte den Rasp per USP an den TV anschließen, damit er nur läuft, wenn der TV auch an ist. Wenn ich jetzt aber normales Fernsehen gucken will, schaltet der Rasp beim Hochfahren den TV immer auf den HDMI Eingang vom Rasp.


    Bei meinem Fernseher gibt es zwei Einstellungsmöglichkeiten:


    CEC deaktivieren
    TV nicht durch CEC ausschalten


    Auf CEC möchte ich nicht ganz verzeichneten. Die Steuerung über die normale Fernbedienung finde ich gut.


    Gibt es bei Open Elen eine Einstellungsmöglichkeit?


    Vielen Dank vorab!


    Gruß René

  • Quote


    hdmi_ignore_cec_init=1

    in der config.txt sollte das sein was du suchst.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Hey,


    vielen Dank für die schnelle Antwort. Den Befehl den du aufgeführt hast, ist das der Befehl für nicht umschalten?

  • Jupp

    Quote

    Doesn't sent initial active source message. Avoids bringing (CEC enabled) TV out of standby and channel switch when rebooting.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Sorry, stehe auf dem Schlauch. Bin bisher einfacher Anwender und kenne mich mit der Config nicht aus. Grundsätzlich habe ich verstanden was du meinst.


    Folgendes steht in meiner Config. Wie muss ich sie verändern?


    # Force HDMI even if unplugged or powered off
    # hdmi_force_hotplug=1


    # Doesn't sent initial active source message.
    # Avoids bringing CEC (enabled TV) out of standby and channel switch when
    # rebooting.
    hdmi_ignore_cec_init=1

  • sieht doch gut aus. Da OE ein Readonly filesystem hat, rate ich dir, dich hier lang zu hangeln (alles ab Punkt 9 ignorieren).
    Aber ansonsten hast du es richtig gemacht. einfach einfügen, speichern, neustarten.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

    Edited once, last by dbv ().

  • Guten Morgen dbv,


    wir haben uns missverstanden. Das steht schon genau so in meiner config. Geändert habe ich noch nichts. Trotzdem schaltet er den HDMI Eingang automatisch um.

  • Ich weiss grad nicht au dem Kopf, wie es sich verhält wenn da Noobs noch mit rumpfuscht. Hast du ne Karte zum testen rum liegen wo du mal ein reines OE drauf installieren kannst.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • :( Jetzt habe ich das mit Noobs erst verstanden. Habe Openelec ohne Noobs installiert. Die Config habe ich nicht über ssh sondern über einen Editor mir angesehen. SD in den Mac und Config öffnen.

  • Ich hab grad einen alten Thread gefunden (aus meinen Anfangszeiten hier :) ). Da hatte der User das gleiche Problem...OE scheint diese einstellung nicht zu fressen. Probier doch mal bitte den Weg über ssh...nur um es getestet zu haben.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Hallo,


    das ist zwar schon ein wenig älter, hatte aber das gleiche Problem wie ReneWegner.


    Mein Samsung TV sollte nicht über CEC eingeschaltet werden, wenn mein Raspberry PI 2 mit Openelec eingeschaltet wird.


    Nach langer Suche hatte ich durch Zufall die Lösung gefunden.


    Der Samsung TV startet nicht nur durch den CEC Startbefehl (hdmi_ignore_cec_init) sondern auch über die Meldung "Aktive HDMI-Quelle".


    Zudem muss man in diesem Fall nicht über ssh/config.txt gehen.


    Es geht viel einfacher:
    Einstellungen > System > Eingabegeräte > Geräte > CEC Adapter
    hier kann man so einiges einstellen. Wichtige Einstellungen für meinen Samsung TV:


    "Beim Starten Kodi als aktive HDMI-Quelle melden" deaktiviert
    "Beim Start von Kodi einzuschaltende Geräte" keine


    Viel Spaß damit

  • Hallo Zusammen,
    ich möchte diesen in die Jahre gekommenen Thread nochmal aufgreifen.
    Leider gibt es bei mir seit dem Wechsel von Openelec 6.03 auf Libreelec 7.03 Probleme mit dem CEC.
    Hardware: Raspberry Pi 3 (Strom über USB Samsung TV)
    Unter Openelec hatte ich unter Einstellungen > System > Eingabegeräte > Geräte > CEC Adapter folgende Einstellungen aktiv
    "Beim Starten Kodi als aktive HDMI-Quelle melden" deaktiviert
    "Beim Start von Kodi einzuschaltende Geräte" keine
    Dadurch wurde beim starten nicht automatisch auf den HDMI Port vom Rasp umgeschalten. Bei manuellem HDMI Port wechsel stand die CEC Funktion vollständig zur Verfügung.


    Nach dem Wechsel auf Libreelec funktioniert dies nun nicht mehr. Einstellungen sind die selben wie bei Openelec, allerdings wird nun beim Starten trotz der deaktivierten aktiven HDMI Quelle auf den HDMI Port des Rasp umgeschalten. Zudem funktioniert mit diesen Einstellungen das steuern über die TV Fernbedienung nicht (alle Tasten). Wenn ich die Option auf aktiv stelle funktioniert die TV Fernbedienung für das Steuern am Rasp wieder.


    CEC Gerätefirmware ist unter Libreelec 7.03 -> 3.0.1 v1 ... war diese evtl bei Openelec anders?
    Ich habe zusätzlich mal auf Libreelec 7.95.2 -> 4.0.1 v1 ... leider gleiches Problem wie oben beschrieben


    Kann mir hier evtl jmd weiterhelfen?


    Vielen Dank im Voraus
    Foradh

    Edited once, last by Foradh ().

  • Hallo zusammen,


    selbe Problem wie Foradh...
    Hat jemand eine Lösung?


    Gruß
    Paolo


  • Selbes Problem bei mir. Dachte erst es liegt an meinem LG TV. Wenn ich meinen TV einschalte wird erst das TV Bild eingeschalten und nach ca. 10 Sek. wird automatisch auf KODI HDMI umgeschalten. Ist auch erst seit dem Wechsel von Openelec 6 auf Librelec 8 so.
    Ich habe jetzt CEC deaktiviert und steuere über die Yatse App. Hätte aber schon gerne meine Fernbedienung wieder...

  • Da scheint sich ein Bug eingeschlichen zu haben...weiß jemand wie man einen Bug-Report an das Libre-elec Team schicken kann?

  • gleiche Problem auch bei mir, Fernseher bekommt Strom, meine VU Solo geht an, sendet CEC Befehl an Samsung TV, Fernseher geht an, erst paar Sekunden bild vom Receiver und plötzlich umschalten auf den Pi.