ownCloud 7 auf dem RasPi?

  • Hallo Freunde!


    Auf einem meiner drei RasPi läuft meine ownCloud. Das ist ja nix Besonderes ... . Ich nutze nur CalDAV und CardDAV.
    Jetzt ist die Version 7 freigegeben worden und ich weiß noch nicht so recht, ob ich das Update machen soll. Mir geht es dabei ausschließlich um die Performance dieser Version auf unserem Spielzeug, nicht um die beworbenen neuen Funktionen. Besser oder schlechter?
    Meine Frage ist, hat da jemand schon praktische ("fühlbare") Erfahrungen?


    Bevor hier "nicht hilfreiche" Antworten kommen:
    - Ja, ich weiß, wie man updated. Habe schließlich mittlerweile die dritte Version drauf. 5.? > 6.0.3 > 6.0.4. Bin also nicht "zu faul" um zu updaten und selber zu testen.
    - Ja, ich weiß, wie man ein Image zieht und wieder zurückspielt. Aber ich respektiere auch die Erfahrungen anderer. (*)
    - Ja, ich weiß, dass man Software immer aktuell halten sollte. Aber meine RasPi und weitere Technik (NAS) sind hinter einem VPN und somit vom bösen Netz abgeschottet. Also nicht das wichtigste Argument.
    - Und wie wohl jeder von euch weiß ich auch, dass eine neue Software-Version auf gleicher HW sowohl schneller (weil optimaler programmiert) als auch langsamer (weil mit Funktionen überfrachtet) sein kann => deswegen meine Frage!


    (*) Im Synology-Forum habe ich gerade gelesen, dass sie dort gute Erfahrungen mit OC7 gemacht haben => performanter! Kann, muss aber für unsere HW nichts bedeuten.


    Vielen Dank im Voraus!



    MfG Peter

  • hallo,


    das update ging problemlos, ich benutze die paketquellen für debian
    von opensuse.
    bei der ersten anmeldung läuft eine automatische installation ab.
    alle daten waren danach noch vorhanden.


    die geschwindigkeit der weboberfläche ist jetzt deutlich besser,
    und jetzt auch für den raspi gut nutzbar.


    die e-mail einstellungen kann man jetzt auf der admin seite machen statt in der config.php
    und es funktioniert auch problemlos mit meinem provider.
    mit 6.0.4 hatte ich probleme mit der "mail_from_address", die muss wohl bei den meisten
    providern gleich der e-mail adresse sein.
    bei problemen in die config.php "mail_smtpdebug" => true, einfügen.


    die interne "tasks" app hat nicht funktioniert, "tasks enhanced" v0.40 funktioniert.
    die version 0.41 geht bei mir nicht.
    ich verwende als webserver "lighttpd", der aber in den raspianquellen eine ältere version
    hat, als owncoud empfiehlt. das könnte ein grund sein


    die vorschaugrafiken für dateien habe ich deaktiviert.
    die werden zwar nur einmalig erzeugt, das dauert aber sehr lange.
    in der config.php "enable_previews" => false,


    die datei- und verzeichnisrechte für den owncloud ordner kann man mal überprüfen.
    siehe im admin manual unter "manual install"


    hardware:
    raspi version b mit einem upis basic modul (firmware v1.08 !) als notstromversorgung
    40 gb ssd von intel, die stromversorgung über usb reicht gerade so.
    gibt es momentan bei reichelt und pollin für ca. 30 eur.

  • Hallo,


    ich habe ein Auto-Upgrade ([font="Courier"]apt-get upgrade[/font]) gemacht, ebenfalls mit den Paketquellen von OpenSUSE für Debian. Das Auto-Upgrade ging bei mir schief; Owncloud blieb im Status 'Updating' hängen. Ich weiß nicht, ob das ein generisches Problem ist.


    Letztendlich bin ich dann mit [font="Courier"]apt-get purge owncloud <CR> apt-get install owncloud[/font] wieder zu einem laufenden System (mit Owncloud 7) gekommen, allerdings mit totalem Datenverlust in der DB. Da ich Owncloud praktisch nur für CardDAV verwende, konnte ich die verloren gegangene Daten (praktisch nur das Adressbuch) wieder mittels vcf-Datei (früher weggesichert) restaurieren.


    Ich kann bestätigen, dass sich die Performance der Web-GUI spürbar verbessert hat; sie ist jetzt erträglicher geworden. Allerdings scheint mir das 'Kontakte'-GUI ziemlich herumzuspinnen: Änderungen einer Telefonnummer oder Adresse von z. B. 'Zuhause' auf 'Arbeit' werden schlichtweg ignoriert. So habe ich bei einem neuen Kontakt jetzt halt zwei 'Zuhause'-Telefonnummern und zwei 'Arbeit'-Adressen. Es bestätigt sich mir wieder der schlechte Zustand der GUI, den ich schon in manchen früheren Versionen von Owncloud bekommen habe. Wahrscheinlich muss ich wieder bis Version 7.0x warten, bis die schlimmsten Bugs aus der neuen Hauptversion raus sind...


    Ich hoffe, das hilft ein bisschen.


    Ciao, Michael

  • Hallo Michael, pianist und Ralph!


    Und vielen Dank für eure Informationen.
    Diese machen mir Mut und ich werde heute mein drittes Update meiner OC machen.


    Ich habe heute mal mehrere Funktionen (Aufruf der Anmeldeseite, Anmeldung bis die Seite des Nutzers angezeigt wird, Aufruf Kalender und Aufruf Adressbuch) gestartet und die jeweilige Zeit gemessen. Morgen werde ich mal die gleichen "Messungen" mit der Version 7 durchführen und die Messwerte hier posten.


    MfG Peter


    edit ein paar Stunden später:
    Update auf V.7 gemacht (owncloud-7.0.0.tar.bz2), lief wie immer problemlos und war in ein paar Minuten durch. Die GUI ist gefühlt etwas schneller (=> Zeitmessungen morgen, ich will wegen der identischen Bedingungen ebenfalls übers VPN gehen). Die GUI sieht IMHO etwas besser aus - und es funktioniert alles wie gewohnt.

  • Guten Morgen!
    (Bewusst einen neuen Beitrag erzeugt.)


    Ich habe mir soeben die Mühe (nein: den Spaß!) gemacht, und noch einmal die Zeiten gestoppt, welche die GUI braucht, um die jeweils aufgerufene Seite anzuzeigen. Es handelt sich also lediglich um die fühlbare "Schwupdizität" der GUI, welche ich sonst so gut wie nie aufrufe. Die eigentliche, für mich wichtige Funktion meiner OC, also das Bereitstellen und Synchronisieren von Kalendern und Adressbüchern in meinen vier Thunderbirdinstallationen (Linux) und auf meinem Androiden, funktioniert weiterhin sehr schnell (2-3 gefühlte Sekunden), und da das alles im Hintergrund passiert, bemerke ich davon überhaupt nichts. Da gibt es also keine gefühlten Unterschiede zwischen den Versionen 6 und 7.
    Vor der "Messung" wurde der Cache des Firefox geleert. Ein zweiter Aufruf der Seite ist wie zu erwarten, meistens deutlich schneller. Gestoppt wurde die Zeit, bis die Seite komplett angezeigt wird. Verbunden wurde über ein IPsec-VPN über UMTS.
    (Ich hoffe mal, dass die "Tabelle" einigermaßen rüberkommt. Kann man hier eine richtige Tabelle generieren?)


    Aktion / Zeit bei V. 6.0.4 / Zeit bei V. 7.0.0
    ==============================
    Start bis Anmeldebildschirm: 25s / 13 s
    Anmeldung bis angemeldet: 39s / 21s
    Anzeige Kalender (15 Kal.!): 24s / 34s (der zweite Start je 14s bei beiden Versionen)
    Anzeige Adressbuch (128DS): 19s / 17s


    Also, einer Installation der 7er Version auf dem RasPi steht IMHO nichts entgegen.



    MfG Peter

  • hallo /dev/null,


    danke, es ist interessant mal vergleichswerte zu haben.
    ich komme bei direkter netzwerkverbindung
    bei der startseite auf ca. 5 sek.
    bei der anmeldung sind es ca.12 sek.


    verwendest du sqlite oder mysql als datenbank ?