WLan bricht zusammen wenn der Fernseher eingeschaltet wird.

  • Hallo zusammen,


    ich versuche meinen Raspberry mit RaspBmc über WLAN zum Laufen zu kriegen.
    Ich habe folgende Geräte im Einsatz.


    Internetrouter: FritzBox 7270
    WLAN-Repeater: FritzBox 7270
    RaspBerry Model B 512MB mit Edimax WLAN Adapter 150Mbit


    Die FB sind für WLAN 300MBit optimiert. Der RaspBerry ist mit ca. 81MBit im Netz.
    Wenn ich nun den Fernseher einschalte oder das HDMI Kabel vom laufenden Fernseher in den RaspBerry stecke, fliegt der RaspBerry aus dem Netz. Ich sehe nach einem Netzscan zwar noch die Netze in der Umgebung, bekomme aber keine IP mehr.
    Wenn ich die 300MBit Optmierung ausschalte bleibt der RaspBerry zwar im Netz, ist aber nur mit 13 - 39 MBit angebunden. Filme kann ich dann leider nicht mehr streamen.


    Kann mir da jemand den entscheidenden Tip geben wie ich den RaspBerry auch mit 300MBit Optimierung im Netz halten kann?


    Vielen Dank
    Pagaban

  • Hallo Pagaban,


    das erste was mir einfällt: HDMI ist kein Plug & Play, das heißt: Du verbindest alle Geräte über ihre Schnittstellen mit entsprechenden Kabeln, BEVOR Du die Geräte einschaltest. Im laufenden Betrieb irgendwas mit HDMI zu verstöpseln, führt zu Effekten, die den unbedarften Anwender irritieren.


    Der Rest klingt nach unserem "Mysterium" - nutze mal die Foren-Suche, um zu erfahren, was sich dahinter versteckt (nämlich Probleme mit der Stromversorgung).


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Andreas
    Ich habe auch probiert alles vorher anzuschließen.
    Alle Kabel rein, RaspBerry einschalten, Fernseher einschalten.


    Es ist auch so, wenn ich im Laufenden Betrieb den HDMI Stecker ziehe, oder den Fernseher ausschalte, bekommt der RaspBerry sofort eine IP Adresse

  • Hallo Pagaban,


    was hast Du denn alles am Raspberry Pi angeschlossen? Insbesondere: Was steckt in den USB-Schnittstellen?


    Nutzt Du einen aktiven oder einen passiven USB-Hub?


    Und wie gesagt: Im laufenden Betrieb werden keine HDMI-Kabel gezogen oder gesteckt,.


    Lies Dir mal durch, was Zentris, ich und ein paar andere bedeutende Zeitgenossen in den Beiträgen zum "Mysterium" geschrieben haben. Danach bist Du schlauer!


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo Andreas,
    habe den Thread überflogen. Leider beschreibt er mein Problem, so denke ich, nicht wirklich.
    Bei mir ist es ja zu 100% reproduzierbar? Vieles habe ich dort auch nicht verstanden, es ist für mich zu technisch.
    Nun zu Deinen Fragen. Am Pi ist nur der WLAN Adapter angeschlossen, direkt ohne Hub. Ich habe es mit einem 5V, 1A und einem 5V, 2,1A Netzteil versucht.
    Das man HDMI und sonstige Kabel nicht im laufenden Betrieb ziehen soll ist mir natürlich klar. Warum sollte man das auch tun wenn alles läuft.
    Zum Testen fand ich es in diesem Fall allerdings sehr hilfreich.
    So weiß ich zumindest, dass das Netzwerk zusammenbricht wenn 1. die FB auf 300MBit optimiert sind und 2. auf irgendeine Art und Weise die HDMI Buchse angesprochen wird.
    Die Frage ist nur warum.

    Edited once, last by Pagaban ().

  • Hallo Pagaban,


    wenn Du den WLAN-Stick direkt (ohne aktiven USB-Hub) in die USB-Schnittstelle des Raspberry Pi betreibst, dann fehlt dem Teil in der Tat der Strom.


    Es ist vollkommen egal, wieviel Strom Dein Netzteil liefern kann. Bei Versorgung über die Mikro-USB-Schnittstelle wird nur ca. 1000 mA durchgelassen. Der Raspbetrry Pi benötigt ungefähr 700 mA. Für alles andere (HDMI, USB, GPIO) stehen dann nur noch max. 300 mA zur Verfügung. Wenn ein Verbraucher im Bereich 300 mA liegt (und das tun viele direkt nach dem Einstecken), wird dem Raspberry Pi der Strom knapp. Der Raspberry Pi erlaubt es sich nämlich, irgendwelche Geräte abzuschalten, wenn der Saft auszugehen droht. Bei USB "berappelt" er sich wieder, bei LAN / WLAN liegt es im Verantwortungsbereich des Anwenders (bzw. Zusatzsoftware), alles wieder zum Laufen zu bringen. Du entdeckst dann irgendwelche Störungen:
    - Monitorbild ist mal kurz schwarz - geht dann aber bald wieder
    - Monitorbild ist kurz schwarz - Raspberry Pi rebootet (hier fängt es an gefährlich werden zu können, bis hin zum Unbrauchbarwerden des Dateisystems auf der SD-Karte)
    - IP-Adresse geht verloren - hier bemerkt man erst wirklich eine Störung, da etwas (LAN / WLAN) nicht mehr funktioniert. Wie in Deinem Fall, dass die IP-Adresse verschwunden ist.


    Hier im Forum werden Netzteile mit 1,2 A empfohlen,. damit die 1000 mA auch immer hinreichend sicher geliefert werden können. Das Netzteil mit 1 A unterliegt ebenfalls Schwankungen, so dass die 300 mA für USB und Co. schon mal gar nicht immer zur Verfügung stehen.


    Da man HDMI abschalten kann, vermute ich, dass der Raspberry Pi HDMI ebenfalls bei Bedarf abschaltet, um Strom zu sparen, wenn dieser für andere Zwecke (wie WLAN-Adapter direkt eingestöpselt) gebracuht wird.



    Mein Tipp:


    Besorge Dir einen aktiven Hub (mein aktueller Favorit: LogiLink mit 10 USB-Ports, 4A-Stromversorgung), schließe alle USB-Geräte dort an und verbinde den mit dem Pi. Dann dürfte auch für HDMI immer genügend Strom vorhanden sein.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Wow, das war der entscheidende Tip.
    Vielen Dank dafür.
    Eine Frage hätte ich da aber noch.
    Der Pi fährt jetzt schon hoch, wenn ich nur die Verbindung vom USB Hub einstecke. Muss ich trotzdem noch das normale Netzkabel verwenden oder wird der Pi jetzt komplett über den USB Port versorgt?


    Tausend Dank nochmal.

  • Nicht einen Ausgang des Hubs mit dem PI verbinden, denn sonst bekommt der PI Strom vom Hub geliefert. Die musst den Eingang des Hubs mit einem USB-Port des PIs verbinden.

  • Hallo Pagaban,


    Gratulation!


    Es gibt drei verschiedene Möglichkeiten, den Raspberry Pi mit Strom zu versorgen:
    1. Mikro-USB
    2. USB-Buchse
    3. GPIO


    Jetzt hast Du die 2. Methode für Dich entdeckt... :bravo2:


    Wenn Du zu diesem Thema mehr wissen möchtest, dann schau doch mal in einen Beitrag von Dreamshader herein (ein Klassiker in diesem Forum!).


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hab ich genauso gemacht.
    Ich habe einen Hub gekauft, der 4 USB Ausgänge hat. Zusätzlich hat er noch den Stromanschluss und ein ca. 1m langes Kabel mit einem USB Stecker, dieses habe ich den Pi gesteckt.

  • Hallo Pagaban,


    das USB-Kabel, das in den Raspberry Pi führt, steckt wo im USB-Hub:
    In einem der 4 USB-Ports (USB-A) oder woanders (z.B. USB-B - auf jeden Fall gesondert gekennzeichnet)?


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo Pagaban,


    dann hast Du den USB-Hub "richtig" mit dem Raspberry Pi verbunden. (Es wäre aber auch mit den USB-Ports des USB-Hubs möglich.)


    Dann kannst Du nur noch den Thread von Dreamshader zum Thema Stromversorgung lesen.


    Viel Spaß mit Deinem Raspberry Pi!



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • So,
    Der RPI wird jetzt über ein Y-USB-Kabel mit Strom versorgt, der W-Lan-Stick hängt im USB-Hub.
    Die W-Lan Anbindung schwankt allerdings zwischen 40-81 MBit. Die meisten Filme, sowohl von der Festplatte im heimischen Netz als auch gestreamt aus dem Internet laufen flüssig durch. Ab und zu jedoch friert das Bild ein un der Pi muss "nachladen".


    Eine Frage hätte ich da noch:
    Warum reicht eigentlich eine 25Mbit Internetverbindung um am PC alles Ruckelfrei anzusehen, während es mit einer 40-81MBit W-Lan Verbindung am Fernseher doch ab und zu mal ruckelt?


    Noch mal Vielen Dank für die ganzen Tips.