Transmission-Daemon Web-IF lässt mich nicht rein

  • Hallo!


    Ich habe irgendwie eine ganze Reihe Probleme mit Transmission-Daemon und das Ding will mich einfach nicht...


    Aber gut, hatte Transmission-Daemon drauf (sudo apt-get....) dann:

    Code
    1. sudo service transmission-daemon stop


    danach die settings.json bearbeitet und wieder

    Code
    1. sudo service transmission-daemon start


    Aber da die Downloads nicht starten wollten, bzw. nach ein paar Sekunden abgebrochen haben, habe ich erst mal alles Deinstalliert und auch restliche Dateien (u.a. die service.json) manuell gelöscht.


    Danach wieder mit

    Code
    1. sudo apt-get install transmission-daemon


    alles drauf (dachte ich).


    Nur war die service.json leer.


    Dann habe ich das hier reinkopiert:


    Nun meine Probleme:
    -ich kann mich via WebIF nicht einloggen
    -das Web-IF-Passwort wird nicht in HEX-Werte umgewandelt


    Was mache ich falsch?


    Vielen Dank für eure Hilfe!


    Gruß Michael861

  • Hallo,


    ich kenne den Daemon zwar nicht, aber sieht interessant aus. Daher habe ich einfach mal auf Deine Config geschaut.


    Code
    1. "rpc-whitelist": "*.*.*.*", #auch mit 192.168.2.122 (meine IP) getestet
    2. "rpc-whitelist-enabled": false,


    Du trägst zwar *.*.*.* und Deine IP da ein, aber eine Zeile drunter steht das es gar nicht aktiviert ist.
    Ausserdem bist Du Dir sicher das dort *.*.*.* eingetragen werden soll/kann? Bei den meisten Diensten wird 0.0.0.0 eingetragen für so einen Fall.


    So und jetzt gucke ich mir mal an was das überhaupt ist/macht. :-)

  • Hallo!


    Danke für deine Antwort.
    Geändert, restart hat leider nichts geholfen (hatte ich glaube ich schon probiert...).


    Ach ja, transmission-daemon ist ein Torrent-Client der auf dem Raspberry läuft und sich via WebIF bedienen lassen sollte.
    Somit kann man z.B. das Gerät als "Download-Maschine" laufen lassen und man muss keinen anderen Rechner laufen lassen...


    Gruß Michael861


    @edit
    sieht jetzt so aus:

  • Was bedeutet denn "-ich kann mich via WebIF nicht einloggen" Wird denn ein WebIf angezeigt? Erscheint eine Fehlermeldung?

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Wenn ich mich via

    Code
    1. 192.168.2.2:9091

    auf das Web-IF schalten möchte, dann kommt diese Meldung:


    Aber in der Whitelist ist meine IP-Adresse mit der ich mich aufschalten möchte hinterlegt.

  • ok. eben gechecked.


    Also transmission-daemon nicht stoppen.
    Settings bearbeiten und rpc-whitelist-enabled auf false setzen, oder die IP bei rpc-whitelist eintragen.


    Dann keinen restart oder stop und start machen. service transmission-daemon reload

  • Hilft leider nicht.


    Also, den Transmission-Daemon garz normal gestartet.


    Dann mit sudo nano in die service.json


    Sowohl die IP-Adresse eingetragen wie du geschrieben, als auch die Whitelist ausgeschaltet.


    Dann:

    Code
    1. sudo service transmission-daemon reload


    hier kommt eine Fehlermeldung, dass er den Befehl nicht kennt.
    Aber dieser geht:

    Code
    1. sudo service transmission-daemon force-reload


    und wieder versucht via Web-IF darauf zu zugreifen.


    Keine Veränderung, gleiches Problem wie zuvor...

  • Kannst du jetzt mal beide Configs abchecken?


    Code
    1. sudo grep rpc-whitelist /var/lib/transmission-daemon/info/settings.json
    2. sudo grep rpc-whitelist /etc/transmission-daemon/settings.json


    Ausgabe:

    Code
    1. root@pi01:~# grep rpc-whitelist /var/lib/transmission-daemon/info/settings.json
    2. "rpc-whitelist": "127.0.0.1",
    3. "rpc-whitelist-enabled": false,
    4. root@pi01:~# grep rpc-whitelist /etc/transmission-daemon/settings.json
    5. "rpc-whitelist": "127.0.0.1",
    6. "rpc-whitelist-enabled": false,
    7. root@pi01:~#
  • Leider keine Veränderung.


    Aber hier die Ausgabe:

    Code
    1. pi@raspberrypi ~ $ sudo grep rpc-whitelist /var/lib/transmission-daemon/info/settings.json
    2. "rpc-whitelist": "127.0.0.1",
    3. "rpc-whitelist-enabled": false,
    4. pi@raspberrypi ~ $ sudo grep rpc-whitelist /etc/transmission-daemon/settings.json
    5. "rpc-whitelist": "127.0.0.1",
    6. "rpc-whitelist-enabled": false,
    7. pi@raspberrypi ~ $


    @edit
    Gerade noch neu gestartet, also

    Code
    1. sudo reboot


    Auch das hat nichts geholfen.


    Was mich etwas stutzig macht, warum wandelt der transmission-daemon nicht das Passwort des Users im Web-IF in der Config in HASH?

  • Hi,


    Es ist zwar schon ein sehr alter Beitrag, aber ich habe das selbe Problem.

    Wenn ich mich im Browser mit meiner IP 192....... einloggen will kommt immer der 403: forbidden error

    rpc-whitelist habe ich meine IP eingetragen

    rpc-whitelist enabled ist auf true


    Frage muss ich im Router für Port 9091 ein Portforwarding einrichten? Und wenn ja welches Protokoll TCP, UDP usw...?


    Ich habe auch versucht

    rpc-whitelist enabled auf false und

    rpc-whitelist 127.0.0.... zu lassen


    und dann im Browser mit raspberrypi.local:9091 dann kommt aber folgender error: Diese Webseite ist nicht erreichbar.


    Ich wäre über jede Hilfe sehr Dankbar