WLAN Problem

  • Hallo zusammen,


    vorab: ich habe bereits viel in diesem Forum und bei Google gesucht, aber keine Lösung für mein Problem gefunden.


    Ziel meines Raspberrys: XBMC mit WLAN in einem Zimmer nutzen das keine LAN-Schnittstelle besitzt.


    Zu meinen Komponenten
    - Model B
    - EDIMAX WLAN Dongle
    - Trust Wireless Tastatur
    - mitgelieferte Noobs SD-Karte
    - Original Samsung Ladekabel (das von meinem Handy)



    Ich habe ein Model B und dort via Noobs vorerst Raspmc installiert. Über LAN funktioniert alles problemlos. Allerdings funktioniert WLAN nicht. Ich habe es mal nach vielen Fehlversuchen zum Laufen gebracht, aber nach einem Neustart ging es wieder nicht mehr...


    Also habe ich Openelec (erneut über Noobs) installiert und auch dort habe ich dasselbe Problem. Nach vielen Versuchen ging es dann irgenwann auch nach einigen Neustarts. Einen Tag später wieder offline.


    Der EDIMAX funktioniert auf meinem Desktop einwandfrei. Ich habe viel gelesen, dass es an der Stromversorgung liegen kann. Allerdings habe ich auch gelesen, dass eine externer, aktiver USB-Hub helfen kann (wenn ja, welcher).


    Allerdings finde ich es komisch, dass es ja zeitweise auch so funktionierte. Also muss das Gerät ja iwie dazu in der Lage sein.


    Was meint Ihr?


    Liegt es an der Distribution?
    Brauche ich ein anderes Netzteil?
    Brauche ich ein USB Hub?



    Bitte um Rücksicht, da ich Newbie bin. Ich habe echt versucht eigenständig Lösungen zu finden online. Allerdings wird überall was anderes geschrieben und die Beiträge sind teilweise sehr alt.


    Danke im Voraus für Eure Antworten!

  • Hallo tongue23,


    herzlich Willkommen hier in unserem Forum.


    Das mit der USB-Schnittstelle am Raspberry Pi ist so eine Sache. Je nach dem, wie Du das Teil mit Strom versorgst, steht Dir für die USB-Schnittstelle unterschiedlich viel Strom zur Verfügung.


    Nutze einmal in diesem Forum die Suchhilfe und suche nach Stromversorgung. Du findest einen interessanten Vergleich von Dreamshader über die verschiedenen Möglichkeiten.


    Für den Fall, dass Du Deinen Raspberry Pi über die Standard-Mikro-USB-Schnittstelle mit Strom versorgst, kann man den Fall relativ schnell beschreiben.


    Der Raspberry Pi benötigt rund 700 mA. Die Polyfuse lässt 1000 mA durch. Die Differenz von 300 mA muss alles andere am GPIO und an der USB-Schnittstelle mit Strom versorgen.


    Besonders beim Einstecken / Erkennen wird sehr viel Strom verbraucht.


    Dann gibt es Untersuchungen von Zentris (Stichwort Mysterium), wonach der Stromverbrauch unabhängig von eingesteckten Verbrauchern regelmässig sprunghaft ansteigt.
    Wird in solch einem Fall der Strom mal knapp, schaltet der Raspberry Pi die Verbraucher kurzfristig ab
    - HDMI: Bildschirm wird mal kurz schwarz, mit ein wenig Glück geht es danach ohne Reboot weiter,
    - USB: Vielleicht hast Du schon einmal kurze Aussetzer festgestellt, in denen die Tastatur / Maus zu hängen scheint
    - LAN / WLAN: Verbindungen werden plötzlich unterbrichen, Seiten werden nicht mehr aufgerufen, weil die IP-Adresse des Raspberry Pi verlorengegangen ist


    Jetzt ist es so, dass HDMI und USB sich wieder berappeln und Du danach störungsfrei weitermachen kannst.
    Bei LAN/WLAN bleibt die IP-Adresse verschwunden. Du musst hier manuell ein paar Dateien nachbessern - oder ein Programm macht das (nochmals Stichwort Mysterium, siehe meinen Thread mit einer Programmlösung dazu)



    Zu Deinen Problemen:
    Es liegt bestimmt nicht an der Distribution, die Du einsetzt.


    Sofern Du ein Netzteil hast, dass mindestens 1,2 A liefern kann, sollten die 1000 mA (von oben) dauerhaft sichergestellt sein. Ein deutlich grösseres Netzteil bringt Dir zumindest für den Raspberry Pi B nichts.


    Was Dir etwas bringen kann, ist eine andere Art der Stromversorgung (s. den oben empfohlenen Beitrag von Dreamshader).


    Mein Tip:
    Besorge Dir einen AKTIVEN USB-Hub (mein Favorit derzeit: LogiLink mit 10 USB-Ports, 4 A Netzteil) und betreibe ALLE USB-Geräte darüber. Ich kann Dir garantieren, dass alle Deine Probleme der Vergangenheit angehören.


    So war es bei mir schliesslich auch. Mysterium adè!


    Beste Grüsse


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hallo Andreas,


    besten Dank für Deine ausführliche Antwort. Ich habe auch schon viel in dem Forum gesucht/gelesen, allerdings bin ich nicht so der Technik-Freak :blush:


    Ich möchte einfach nur das Teil zum Streamen nutzen ohne viel basteln zu müssen.


    Darüber hinaus möchte ich nicht viel Geld investieren. Wäre dieser HUB hier in Ordnung:
    http://www.amazon.de/LogiLink-4-Port-Hub-Netzteil-schwarz/dp/B003ECC6O4/ref=sr_1_2?ie=UTF8&qid=1407312092&sr=8-2&keywords=LogiLink USB-Ports, 4 A


    Er ist leider nicht gut bewertet, aber relativ günstig. Oder kannst Du mir ein Alternativprodukt empfehlen. Ich brauche auf jeden Fall keine 10 Ports. 2-4 reichen mir vollkommen aus.


    Zu meinem Netzteil: wie oben beschrieben handelt es sich um ein stink normales SAMSUNG Handyladekabel. Wieviel V und oder mAh es liefert weiß ich leider nicht.


    Wäre vllt auch eine Option das Gerät mittels USB Schnittstelle von dem Fernseher zu versorgen? Das habe ich bisher noch nicht getestet. Was ich bisher gelesen habe geht es bei manchen und bei anderen widerum nicht... wie immer wenn ich nach raspberry Themen suche... :s


    Danke und Grüße

  • Hallo Tongue23,


    der von Dir gefundene 4_Port USB-Hub wird Dir auf Dauer nicht reichen:
    - Tastatur
    - Maus
    - WLAN
    - bestimmt USB-Stick
    - bestimmt irgendwann USB-Festplatte (die braucht eher 2 USB-Ports als einen)
    - vielleicht USB-Sound-Karte


    Wenn Du in dieser Richtung aktiv werden möchtest, dann reicht der der 4-Port-USB-Hub schon nach kurzer Zeit gar nicht mehr.


    Schau mal hier: http://www.amazon.de/LogiLink-10-Port-Hub-Netzteil-schwarz/dp/B003ECC702/ref=sr_1_3?ie=UTF8&qid=1407312936&sr=8-3&keywords=LogiLink 10-Port USB 2.0 mit Netzteil


    Ich kaufe mir die Komponenten, die auch möglichst allen zukünftigen Einsatzgebieten gerecht werden können.


    Bei einem 4-Port-USB hast Du Grenzen ganz schnell erreicht.


    Quote


    Zu meinem Netzteil: wie oben beschrieben handelt es sich um ein stink normales SAMSUNG Handyladekabel. Wieviel V und oder mAh es liefert weiß ich leider nicht.


    Wäre vllt auch eine Option das Gerät mittels USB Schnittstelle von dem Fernseher zu versorgen? Das habe ich bisher noch nicht getestet. Was ich bisher gelesen habe geht es bei manchen und bei anderen widerum nicht... wie immer wenn ich nach raspberry Themen suche...


    Schau doch mal an dem Ladegerät nach. Dort steht irgendwas von 5V und irgendwas mit 0,7 A / 700 mA oder 1 A / 1000 mA oder 1,2 A / 1200 mA etc. drauf.


    Hast Du die Variante mit 700 mA, dann kann es prinzipiell nicht ohne USB-Hub funktionieren. Hier würde ich dann gleich zu einem besseren Netzteil raten. Ladegeräte sind nicht die beste Wahl...


    Wenn Du etwas Sinnvolles mit dem Raspberry anfangen willst, dann solltest Du nicht am Anfang die preiswerteste Zusatzhardware erwerben - wenn denn klar ist, das diese nicht reichen wird.


    Beste Grüsse


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hallo,


    da ich den Pi echt nur zum Streamen mit WLAN nutzen will ohne Festplatten etc. brauche ich keine 10 Ports...


    Habe den jetzt aber trotzdem bestellt, da er ja bei Dir wohl läuft. Die Rezessionen sind allerdings alles andere als gut.


    Kannst Du mir zudem ggf. noch ein Netzteil empfehlen?


    Danke!
    [hr]
    Was hälst Du von dieser Option? Versorgt der TV den Pi ggf. mit mehr Power?



    Wäre vllt auch eine Option das Gerät mittels USB Schnittstelle von dem Fernseher zu versorgen? Das habe ich bisher noch nicht getestet. Was ich bisher gelesen habe geht es bei manchen und bei anderen widerum nicht... wie immer wenn ich nach raspberry Themen suche... :s

    Edited once, last by tongue23 ().

  • Hallo tongue23,


    Quote


    Was hälst Du von dieser Option? Versorgt der TV den Pi ggf. mit mehr Power?



    (Heute 10:09)tongue23 schrieb:
    Wäre vllt auch eine Option das Gerät mittels USB Schnittstelle von dem Fernseher zu versorgen? Das habe ich bisher noch nicht getestet. Was ich bisher gelesen habe geht es bei manchen und bei anderen widerum nicht... wie immer wenn ich nach raspberry Themen suche...


    Darauf bin ich nicht eingegangen, weil dies keines Deiner Probleme löst. Die USB-Schnittstelle vom TV liefert nur 500 mA (USB 2.0-Standard). USB 3.0-Standard würde max. 900 mA liefern. Welchen USB-Standard Dein TV hat spielt keine Rolle, da beides weniger als 1000 mA ist.


    Wenn Deine aktuelle Stromversorgung nicht ausreicht, dann hilft Dir der TV auch nicht weiter.


    Ich kann mich an eine Reihe an Problemen erinnern, die dadurch zustande kamen, dass der TV sich nachts einschaltet, um irgendwas zu synchroniseren. Dann geht der Raspberry an. Der TV geht aber nicht mehr aus, weil der Raspberry Pi eingeschaltet wurde und freiwillig nicht herunterfährt.


    Löse erst einmal ein Problem sauber, bevor Du dir mit etwas anderem neue Problemursachen züchtest.


    Gutes Gelingen!


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hallo Andreas,
    in froher Erwartung bin ich heute zur Packstation und habe den von dir empfohlenen HUB geholt. Allerdings hat es keinerlei Verbesserung gebracht.WLAN wird angezeigt und sobald ich verbinden will erscheint network error.


    Mir erscheint der hub auch nicht sehr hochwertig. Das Stromkabel ist sehr locker und ich kann gar nicht sagen ob überhaupt Strom in dem Hub ankommt da er erst leuchtet sobald er USB Zugang vom pi bekommt. Das tut er allerdings auch ohne angeschlossenes Stromkabel. Wie ist das bei dir? Leuchtet es auch nicht ohne USB Anschluss obwohl er in der Steckdose steckt?


    Einziger Vorteil aktuell ist dass das pi nicht mehr abstürzt wenn ich ein USB gerät hinzufüge im hub. Das macht es aber unabhängig davon ob der hub am Strom ist oder nur via USB läuft. Kann man iwie prüfen ob überhaupt Strom im hub ankommt vom Netzteil?


    Ich weiss nun leider nicht mehr weiter :s


  • Hallo Tongue23,


    die LEDs an den Ports leuchten nur, wenn eine Kommunikation mit dem Raspberry Pi (PC, ...) stattfindet,. Ohne angeschlossenen Computer und nur an das Stromnetz angeschlossen leuchten die LEDs nicht.


    Du solltest den USB-Hub auch nioenmals ohne eigenes Netzzteil betreiben. Denn der Strom, der er vom Raspberry Pi zieht, wirkt kontraproduktiv.


    Code
    1. Einziger Vorteil aktuell ist dass das pi nicht mehr abstürzt wenn ich ein USB gerät hinzufüge im hub.


    Dann funktioniert der USB-Hub zu 100%!


    Quote

    Das macht es aber unabhängig davon ob der hub am Strom ist oder nur via USB läuft.


    Das kann ich mir jetzt weniger vorstellen. Widerspricht auch allem Gängigen...


    Quote

    Kann man iwie prüfen ob überhaupt Strom im hub ankommt vom Netzteil?


    Z.B. mit einem Multimeter - auf Gleichstrom und 10A eingestellt.



    Quote

    Allerdings hat es keinerlei Verbesserung gebracht.WLAN wird angezeigt und sobald ich verbinden will erscheint network error


    Wie hast Du den WLAN-Stick konfiguriert? Kannst Du mal die Konfigurationsdateien posten?



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Quote


    Wie hast Du den WLAN-Stick konfiguriert? Kannst Du mal die Konfigurationsdateien posten?


    Den Stick habe ich im Openelec konfiguriert und verschieden WLAN's getestet.
    Wie finde ich die Konfigurationsdatei?



    Nachdem es nicht funktionierte habe ich Openelec via Noobs neu installiert, was leider nichts gebracht hat. Danach mit Raspmbc getestet, was auch scheiterte. Also erneut Openelec via LAN direkt aus dem Netz mit Noobs installiert und auch das hat nicht geholfen. :-/


    Darüber hinaus trat ein neues Problem mit dem HUB auf. Sobald ich einen USB-Stick in den HUB steckte kam die Meldung in Openelec, dass er den stick erkennt und kurz drauf kam die Meldung, dass das Gerät entfernt wurde (obwohl es noch steckte) und ich konnte nichts mehr machen - scheint immer abzustürzen. Dies habe ich mit 4 verschiedenen Sticks getestet, um einen Stickfehler auszuschließen. =(


    Nach weiterer Verzweiflung bin ich auf folgenden Link gestoßen:
    http://www.raspberrypi.org/forums/viewtopic.php?f=28&t=59315


    Also habe ich ein neues WLAN aufgemacht und dieses mit TKIP verschlüsselt, da es dort angeraten wurde: Tadaaaaa... ich war online via WLAN. :bravo2:


    Nun habe ich das Ganze nochmal ohne den HUB versucht und in den Pi wieder meine Wireless Tastatur an den einen USB Port und den EDIMAX an den anderen angeschlossen und weiterhin funktioniert Openelec mit dem WLAN, was nun TKIP nutzt.


    Persönliches FAZIT: Der Kauf des USB-HUB's war sinnlos. Eine Umstellung der WLAN-Sicherheit auf TKIP löst das gesamte Problem, was wohl doch nichts mit der Stromversorgung zu tun hat.


    Ich verstehe nun Garnichts mehr....

  • Ich betreibe die meisten meiner RPi's mit den üblichen WLAN Sticks und direkt (ohne Hub). Die Stromaufnahme eines Sticks liegt bei Belastung bei ca. 200 mA. Wenn sonst nichts mehr an USB hängt, reicht die normale Stromversorgung völlig aus.


    Gruß, mmi