Arduino Nano Treiber richtig installieren


  • Weiß nicht, ob das deine Frage beantwortet....
    Habe dieses Board hier:
    http://www.ebay.de/itm/3906460…_trksid=p3984.m1497.l2649


    ich meinte schon den windoofsrechner ! nicht das x86 Treiber nicht klappen weil du einen Amd hast .....

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Dein Win 7 kenne ich nicht.
    Aber mein liebes XP.
    Das macht auch ab und an Sorgen mit USB und Serielladaptern.


    XP merkt sich alle je angeschlossenen USB Dinger.
    Und alle je benutzten COMs.


    Bei mir hilft es, wenn es denn mal wieder Sorgen macht, alle angesammelte Leichen aus dem Gerätemanager zu entfernen. Dazu muss man den Gerätemanager aber erstmal überreden, denn freiwillig zeigt er keine unbenutzten Geräte an.


    Dazu nutze ich eine Gerätemanager.bat

    Code
    set devmgr_show_details=1
    set devmgr_show_nonpresent_devices=1
    start devmgmt.msc


    Ansicht -->> ausgeblendete Geräte anzeigen
    Die Leichen erscheinen blasser.
    Anklicken und Entfernen Taste


  • Demnach ist bei der Arduino-IDE bereits ein passender Treiber dabei: \Program Files\Arduino\drivers\
    Siehe dazu auch hier: http://www.hobbyist.co.nz/?q=uno_driver_installation


    nur zur Info, bei China Arduino nano v3 sind CH340 USB-seriell Adapter verbaut, da liefert die Arduino IDE nix mit !


    Ich musste auch etwas suchen bis ich den CH340 Treiber fand ;)

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)


  • Verdammt....Ich dachte, das könnte die Lösung bringen...
    Leider Fehlanzeige. =(=(=(


    Muss ich mir ein neues Board anschaffen?

  • Servus,


    na, ob du damit Dein Schnittstellen-Problem löst, wage ich zu bezweifeln.
    Der Nano ist ein richtiger Arduino.
    Wenn es blöd läuft, hat der Arduino, den Du jetzt für 20 Euro bestellt hast, genau den selben Konverter drauf ...
    Wie gesagt ... das ist wohl eher ein Windows-Problem ...


    cu,
    -ds-


  • Der Billige läuft aber auch auf anderen Rechnern nicht...

  • Das hat nix mit dem "billigen" zu tun ...
    Die Treiber für den rs232 Konverter sind das Problem, wenn ich das richtig verfolgt habe.


    Hast Du mal auf der Arduino-Seite z.B. die FAQ durchforstet, ob und welche Treiber es gibt bzw. welche bei Dir funktionieren könnten?


    Was für einen Arduino hast Du Dir denn jetzt da bei Reichelt geordert?
    Wenn ich einen solchen hier habe, könnte ich mal schauen, ob ich den Konverter rausbekomme.
    cu,
    -ds-


  • http://i.imgur.com/AXMQ34U.jpg


    Jetzt ist der Neue angeschlossen.
    Sieht schon ganz anders aus. :) :)


    Wie finde ich heraus, welcher serielle Port der richtige ist?
    Edit: Habe es schon herausgefunden! :)

  • Jetzt bekomme den Arduino Mico nicht in bzw. auf mein Breadboard gesteckt. o.O
    Habe Angst, dass ich das Neue kaputt mache, wenn ich zu doll drücke. :D :D

  • Solange du nix verkantest geht da nix kaputt. Das Teil hat dicke Stiftleisten die fest verlötet sind...


    Also ich hab hier ziemlich viele kleine Arduino's:
    Mini
    Nano
    Pro Mini
    Pro Micro (ein Pro Mini aber mit ATmega32U4 anstatt ATmega168)


    Da is mir bisher noch keiner von kaputt gegangen wenn ich die auf nen Steckbrett gesteckt hab




    PS: bevor jemand fragt oder sagt den Micro Pro gäbs nicht: The Pro Micro is similar to the Pro Mini except with an ATmega32U4 on board.


  • Jetzt ist der Neue angeschlossen.
    Sieht schon ganz anders aus. :) :)


    :s:s:s


    stimmt sieht wirklich anders aus.......


    früher wurde immer gesungen "eines von diesen Dingen passt nicht zu den anderen"


    Überschrift nano (im Text noch V3) im Bild Arduino micro


    OK beide benutzen den m328p aber de rMicro kommt ohne USB Interface daher, jedenfalls meine und ich habe mir extra die USB Ports nachbestellt.


    Trotzdem frage ich mich ob du systematisch vorgegangen bist,


    erste Versuche möglicherweise falsche Treiber, aber egal auch wenn du den richtigen Treiber installierst musst du erst mal das gelbe Ausrufezeichen rauswerfen, Frau Win merkt sich nämlich Unfug !


    Angenommen der richtige Treiber wäre installiert, so wählt man das gelbe Ausrufezeichen und sagt entfernen oder deaktivieren.


    Zieht dann den USB Stecker (evtl. startet man den Rechner neu) und nach dem hochfahren steckt man den USB, dann wird wieder Treiber gesucht, wer 2 zur Auswahl hat wählt Nr.1


    klappt das nicht auf ein Neues, rauswerfen, abziehen, Neustart, einstecken Nr. 2 wählen


    klappt das nicht auf ein Neues,
    vielleicht stand FTI ja noch aus einem vorigen Versuch ? also FTI löschen mit dem Tool oder rauswerfen oder Sysclean und spasseshalber mal den CH340 Treiber installieren, wenn der Chip nicht völlig kaputt ist muss eines doch klappen.


    Ich weiss schon warum ich alle Teile mindestens doppelt bestelle, die Chance das beide Gelieferten nicht gehen oder kaputt sind ist geringer. (obwohl die Mastmatiker das anders sehen, hat irgendwas mit Wahrscheinlichkeit zu tun, 2 Teile heisst doppelte Fehlermöglichkeit nicht doppelte Funktions-chance)

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

    Edited once, last by jar ().


  • Das mit dem alten Treiber hat bei mir nicht geklappt. :wallbash::wallbash::wallbash::wallbash::wallbash:


    vielleicht ist es genau das Problem
    http://www.forum-raspberrypi.d…rdware-unbrauchbar-machen


    gefälschte FTDI Chips


    aber möglicherweise kann man die wiederbeleben


    Ziel am PI ein Tool finden welches die USB ID liest, ist die 0000 dann war es das Ziel 6001 wiederherstellen und alten FTDI Treiber nehmen


    auch hier nachzulesen


    http://www.mikrocontroller.net/topic/347724#new


    und hier


    http://www.heise.de/newsticker…-Chip-Abwehr-2430780.html

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)