[Projekt] jukebox4kids (Jukebox für Kinder)

  • Andco zu Punkt 3: Ich habe ein ähnliches Setup und habe die hab Boxen letztendlich zur Sicherheit an ein separates USB Netzteil gehängt, das in meiner Box an einer 2fach Steckdose neben dem Pi Netzteil steckt. Wenn die Boxen über den Pi USB versorgt wurden, hatte ich beim booten mit Bildschirm teils das Blitzsymbol zu sehen bekommen, auch ohne Tonausgabe. Hätte man vielleicht aber auch ignorieren können...


    Evtl. könnte man die Boxen auch über den 5v Pin des raspi versorgen, der hängt offenbar direkt hinter der onboard Sicherung. Kann aber sein dass das äquivalent zum USB 5V Pin ist(?)

  • Ich wurde gebeten einen zweiten Player zu bauen, diesmal sind die Anforderungen unbedingte Mobilität und Kopfhöreranschluss :rolleyes:


    Einen passenden DAC hab ich schon ausfindig gemacht: https://www.osaelectronics.com…us-for-raspberry-pi-zero/

    Geordi : ich überlege ebenfalls einen Kopfhöreranschluss zu realisieren. Vor Allem auf längeren Auto- und Zugfahrten wenn der Kleine etwas anderes hören mag als ich wäre das praktisch. Meine Idee ist es, die Klinkenbuchse vom Pi dafür zu verwenden.

    1. Idee: Der Pi bemerkt, dass ein Kopfhörer angeschlossen wurde und schaltet von selbst um. Dazu müsste es einen Sensor geben, der bestimmt ob ein Kopfhörer angeschlossen ist oder nicht. Werde das noch recherchieren.


    2. Idee: Per Button (GPIO) wird umgeschaltet. Wie z.B. hier.


    3. Idee: Per RFID-Karte wird umgeschaltet.


    Gerne halte ich dich auf dem Laufenden wie ich die Anforderung gelöst bekomme.


    tobi79 : Danke für deine Hinweise.

    Ich habe mir mal deine Bilder angeschaut. Mit "ähnliche Konfiguration" meinst du dann, dass dein Netzteil ebenfalls 2,1A lieferte und das zu besagter Problematik mit der Warnung (Blitz) führte?

    Werde die Powerbank auf jedenfalls ausprobieren, da ich sie eh hier habe und dann im Forum meine Erfahrungen posten. Im Zweifel muss ich mir eine PowerBank mit höherer Ausgangsleistung kaufen.


    Danke und Gruß,

    Andi

    5 Mal editiert, zuletzt von Andco () aus folgendem Grund: Unterwegs am Handy dauerts ein bisschen bis alle Inhalte zusammengefügt sind.

  • Andco : mein Netzteil liefert angeblich sogar 3.0A, ist aber kein raspi original sondern GoodBye, äh GoodBay.

    Die Blitzwarnung wird aber nicht bei zu geringem Strom sondern bei einbrechender Spannung aktiviert, glaube bei unter 4,5 V. Soweit ich gelesen habe muss man schon mit den Kabeln auf hohe Qualität und kurze Länge achten, da sonst schon zwischen Netzteil/Powerbank und Raspi ohne weitere Verbraucher mehrere 100 mV abfallen können...

  • In der aktuellen geek steht auch viel zur Stromversorgung mit einem Netzteil und ein extra Thema ist mit Akku. Bin noch nicht dazu gekommen das zu richtig zu lesen sondern habe es nur kurz überflogen und das war schon interessant.

  • Andco

    Es gibt Klinkenbuchsen mit integriertem Schalter, die könnten sicherlich den erforderlichen Input für die GPIO-Steuerung geben.

    Aber kann man "on-the-fly" den Audio-Ausgang umschalten?


    Der von mir gefundene OSA-DAC ist übrigens nicht wirklich empfehlenswert. Irgendwie haben die da meiner Meinung nach bei der Schaltung gemurkst. Das Ding läßt sich nur sehr grob lautstärkenmäßig steuern. Außerdem gibt es ziemliche Störgeräusche. Da klingt der Audio-Ausgang vom Pi nicht schlechter. Vielleicht hab ich auch nur eine Montagsproduktion erwischt.

    Mit dem ähnlich gebauten Hifiberry-Miniamp hatte ich keine solchen Probleme.


    Ich versuch die Woche mal ein Setup mit dem Verstärkerteil der empfohlenen USB-Lautsprecher. Das Audio-Kabel geht von der Soundkarte an die Klinkenbuchse und weiter zum Verstärker. Der Schalter in der Klinkenbuchse schaltet dann den Strom für den Verstärker ab wenn ein Kopfhörer eingesteckt wird. Bin nur nicht sicher, ob das sauber ohne Störeinflüsse funktioniert.


    Ich würde mich über andere Lösungsansätze freuen.


    Die weiter oben von harryliebteuch angesprochene Kombination von Volumio und RFID würde mich auch interessieren.

    Der zweite Player läuft nämlich mit Volumio, das ein Display gefordert wurde. Wenn man da zusätzlich noch RFID-Karten benutzen könnte wäre das ziemlich schick.

  • Geordie

    Habe den Ansatz mit der Klinkenbuchse etwas weiter verfolgt und bin dabei auf folgende Schaltung gestoßen:

    https://s8.postimg.cc/dfddqsyh…HEADPHONES_simplified.jpg


    Da ich alle Bauteile zu Hause habe werde ich das Ausprobieren wenn ich wieder vom Urlaub zurück bin. Natürlich ist die Frage berechtigt ob die Ausgabe on-the-fly geändert werden kann.


    Zur Versorgung per Powerbank: Den Artikel in der Geek fand ich nicht weiter hilfreich. Aber in C't Heft 20/2017 gab es einen Artikel, der die Spannungsabfall-Thematik behandelt und die Lösung mit Elko und Spule vorschlägt. In Heft 17/2017 gibt es einen Artikel, der Powerbanks als Stromversorgung für verschiedene Devices behandelt. Leider habe ich das Heft bisher nicht auftreiben können. Werde mir ggf. den Artikel online kaufen um ihn zu lesen.

  • Zur Stromversorgung

    Mein Hinweis mit der Spule und dem Kondensator stammt aus einer der Zeitschriften.

    In der aktuellen geek geht es um eine USV, welche man sich aufbauen kann. Der Schaltplan ist allerdings sehr aufwendig.


    Zum Thema klinkenstecker schlage ich vor einen Schalter zu nehmen. Wechselschalter

    Dieser schaltet zwischen dem Weg zu den Boxen oder zum Kopfhörer Anschluss. Muss man halt ein Kabel auseinander nehmen und etwas basteln oder man legt es direkt auf eine Platine.

  • Hallo zusammen,


    bin in der Zwischenzeit mit der Box fertig geworden. Hier noch ein paar Erfahrungen und Fragen ;)


    Brummschleife

    Verwende RPi mit USB Soundkarte und Aktivboxen. Stecke ich RPi und die Boxen paralell in die Powerbank ein, kommt es zu einem nicht zu überhörenden Brummen. Deutlich besser ist es, wenn ich die Boxen direkt im RPi einstecke. Hab damit auch bei voller Lautstärke noch keine Probleme gehabt, aber optimal ist das was die Stromversorgung angeht wohl nicht... Irgendwelche Ideen? Hat jemand Erfahrungen mit Entstörfiltern? (z.B.: Ground Loop Noise Isolator, https://www.amazon.de/gp/product/B01IETQQQK)


    Stromversorgung:

    Verwende als Powerbank die EasyAcc 20000mAh (https://www.amazon.de/gp/product/B01422TC14). Bei mir gibt es keine Probleme mit dem Spannungsabfall beim Abstecken, RPi läuft ohne Probleme weiter. Geordie , evtl. auch bei Dir einen Versuch wert...


    Der RPi meldet jedoch immer "undervoltage detected" (auch bei anderen Powerbanks, unabhängig davon ob Boxen direkt angeschlossen sind, an der Powerbank oder eigenem Netzteil). Wie schaut das bei Euch aus? Probleme habe ich keine bislang. Einfach ignorieren?


  • Brummschleife

    Verwende RPi mit USB Soundkarte und Aktivboxen. Stecke ich RPi und die Boxen paralell in die Powerbank ein, kommt es zu einem nicht zu überhörenden Brummen. Deutlich besser ist es, wenn ich die Boxen direkt im RPi einstecke. Hab damit auch bei voller Lautstärke noch keine Probleme gehabt, aber optimal ist das was die Stromversorgung angeht wohl nicht... Irgendwelche Ideen? Hat jemand Erfahrungen mit Entstörfiltern? (z.B.: Ground Loop Noise Isolator, https://www.amazon.de/gp/product/B01IETQQQK)





    Das Brummen hab ich auch, morgen kommt der Entstörfilter, ich berichte... :thumbup:


    Stromversorgung:


    Verwende als Powerbank die EasyAcc 20000mAh (https://www.amazon.de/gp/product/B01422TC14). Bei mir gibt es keine Probleme mit dem Spannungsabfall beim Abstecken, RPi läuft ohne Probleme weiter. Geordie, evtl. auch bei Dir einen Versuch wert...


    Danke für den Tipp! :danke_ATDE:

    Der RPi meldet jedoch immer "undervoltage detected" (auch bei anderen Powerbanks, unabhängig davon ob Boxen direkt angeschlossen sind, an der Powerbank oder eigenem Netzteil). Wie schaut das bei Euch aus? Probleme habe ich keine bislang. Einfach ignorieren?


    Hast du vielleicht ein kürzeres Kabel für die Verbindung Powerbank -> RPi?

    Probier mal aus, was du da rumfliegen hast. Kabel von zweifelhafter Qualität sorgen für solche Fehlermeldungen. Hab das gerade wieder selber gemerkt. :conf:

  • Kabel von zweifelhafter Qualität sorgen für solche Fehlermeldungen. Hab das gerade wieder selber gemerkt. :conf:

    Eben, schrieb ich ja gerade oben auf dieser Seite:

    Soweit ich gelesen habe muss man schon mit den Kabeln auf hohe Qualität und kurze Länge achten, da sonst schon zwischen Netzteil/Powerbank und Raspi ohne weitere Verbraucher mehrere 100 mV abfallen können...

  • Carax und Geordie

    Zum Thema Stromversorgung kann ich nun folgendes berichten: Ich verwende eine Xiaomi 10400mAh Powerbank. Per Multimeter habe ich gemessen, dass während dem Boot und Betrieb mit angeschlossenen USB-Soundkarte (die CSL), Boxen (Trust Leto) und RFID-Reader (Neuftech) die Spannung nicht unter 4,95V fällt. Das Setup funktioniert also soweit. Wie viel Strom das Setup verbraucht werde ich die Tage auch noch messen und nachtragen. Leider gibt es bei der Powerbank ebenfalls einen Spannungseinbruch beim anstöpseln der Powerbank an das Netzteil. Ich werde mal die Schaltung per Kondensator und Spule ausprobieren.


    wolfdopd

    Ich habe das Stretch-Desktop-Image installiert und habe das neue Installscript mit dem MPD als Player verwendet. Bootzeiten liegen zwischen 7 und 10 Sekunden :thumbup:



    Mit meinem Test-Setup habe ich jedoch aktuell noch ein paar Probleme. Die Boxen knacken beim Anschalten des Pi (laufen über die USB-Soundkarte). Außerdem kommt es, wenn die USB-Stromversorgung der Boxen am Pi angeschlossen wird zu einem Rauschen beim Boot des Pi. Hat jemand damit Erfahrung und kann berichten?

    Ich muss sagen aktuell bin ich von der USB-Soundkarte noch nicht besonders angetan. :/

  • Ich hatte auch zwischendurch mit einer USB-Soundkarte experimentiert, mit ähnlichen Ergebnissen wie du. Da gibt es wohl ziemliche Qualitätsunterschiede. Momentan präferiere ich den Audioausgang vom Pi mit einem kleinen Verstärker aus billigen USB-Lautsprechern. Ich hab noch einen Massetrennfilter zwischengesetzt und somit fast alle Störgeräusche eliminiert. Nur wenn man den Verstärker voll aufdreht rauscht es etwas. Da der aber im Gehäuse verschwindet, ist man auch flexibel was die maximale Lautstärke angeht.

  • Beitrag von ddbkva ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • Beitrag von ddbkva ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • Hallo zusammen,


    Erst einmal Respekt für das Projekt. Ich bin erst vor ein paar Tagen darauf gestossen. Mein Bastler-Herz ist natürlich sofort aufgeblüht und meine Tochter soll nun so einen Player zu Weihnachten bekommen.


    Die Software läuft auch so weit schon einmal perfekt auf dem Raspberry. Ich bin mir aber noch etwas unschlüssig, wie man die Steuerung (Knöpfe) lösen sollte. Meine Idee wäre nun: Warum nicht mit einer Fernbedienung? Meine Tochter ist dann 4 und würde das schon hinbekommen. Bei AliExpress habe ich folgende Lösung gesehen, die auch für den Rasp gemacht ist.


    https://www.aliexpress.com/ite…ouble-IR/32585353356.html


    sourceforge.net/projects/u-geek/files/HATs/Raspi_IR/


    Was meint ihr dazu? Würde sich das ohne grossen aufwand einbinden lassen? Im Moment wartet das Script ja auf die Eingabe per GPIO. Da sollte es doch möglich sein, dass auch per IR-Code ansteuern zu lassen?


    Vielen Dank schon einmal für das Mithirnen...


    Gruss, Thomas

  • Beitrag von ddbkva ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • ich komme nicht auf die web app hat jemand eine idee ?

    Verwendest Du die richtige IP-Adresse? Kommst Du mit der gleichen IP-Adresse per SSH, SMB oder ähnliches zum Raspi verbinden? Hast Du den Raspi ansonsten vielleicht mit dem (abgeschotteten) Gastnetz verbunden?

    `

    Wie äußert sich das Problem? Fehler 404? Oder kommt gar keine Verbindung zum Webserver zustande?

  • Beitrag von ddbkva ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • Hallo ddbkva,


    bitte bearbeite Deine Beiträge und poste nicht mehrere Beiträge nacheinander, solange noch keiner darauf geantwortet hat! ;)


    //Nachtrag: Und für Code oder Ausgaben bitte den Code-Button (</>) des Editors verwenden.


    //Edit2: Ich habe Deine Beiträge mal zusammengefasst und die Ausgabe als Code formatiert. :cool:

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

    Einmal editiert, zuletzt von hyle ()

  • Hallo,


    Ich habe Heute einen RFID Reader bekommen vom Hersteller Parallax und grundsätzlich wird er vom Raspberry erkannt als /dev/ttyUSB0


    mit : "screen /dev/ttyUSB0 2400" sehe ich auch im Terminal das die RFID Chips korrekt ausgelesen werden. Leider wir er aber nicht als USB Device vom RegisterDevice.py erkannt. Weiss jemand wie ich den Reader trotzdem einbinden kann?


    Gruss, Thomas