[Projekt] jukebox4kids (Jukebox für Kinder)

  • Hallo ihr Beerchen,

    ich habe mir Anfang der Woche mal alle 36 Seite zu diesem Thema durchgelesen und war direkt begeistert. Beim RetroPie die Karte raus, neue Karte geflasht, Powerbank, Reader und Logitech V20 Speaker bestellt. Abgesehen von den Speakern kam auch bereits alles.Habe mich für die Onlineinstallation von GitHub entschieden, schien mir der einfachste Weg zu sein. Und siehe da, hat alles auf Anhieb funktioniert. Also habe ich noch etwas im Raspberrian rumgespielt, ein paar Sachen insalliert, dies das. Die "Phoniebox" lief problemlos. YT Downloader getestet, alles lief. Dann habe ich mir heute, wieso auch immer gedacht, dir Box neu aufsetzen zu müssen. Karte formatiert, neu geflasht, Onlineinstaller genutzt und konfiguriert. Keine Chance, bekomme die Box einfach nicht zum Laufen. Habe es inzwischen bestimmt 5 mal versucht.

    folgende Unregelmäßigkeiten konnte ich feststellen:

    sudo systemctl status rfid-reader

    Display Spoiler

    ● rfid-reader.service - RFID-Reader Service

    Loaded: loaded (/etc/systemd/system/rfid-reader.service; enabled; vendor pres

    Active: active (running) since Fri 2018-10-19 20:21:33 CEST; 9min ago

    Main PID: 409 (python2)

    CGroup: /system.slice/rfid-reader.service

    └─409 /usr/bin/python2 /home/pi/RPi-Jukebox-RFID/scripts/daemon_rfid_

    Okt 19 20:23:20 raspberrypi sudo[2301]: pam_unix(sudo:session): session opened f

    Okt 19 20:23:20 raspberrypi sudo[2301]: pam_unix(sudo:session): session closed f

    Okt 19 20:23:20 raspberrypi python2[409]: mpd error: No such playlist

    Okt 19 20:23:20 raspberrypi python2[409]: loading: Lieblingsmusik

    Okt 19 20:23:20 raspberrypi sudo[2310]: pi : TTY=unknown ; PWD=/home/pi/RP

    Okt 19 20:23:20 raspberrypi sudo[2310]: pam_unix(sudo:session): session opened f

    Okt 19 20:23:20 raspberrypi sudo[2310]: pam_unix(sudo:session): session closed f

    Okt 19 20:23:20 raspberrypi sudo[2318]: pi : TTY=unknown ; PWD=/home/pi/RP

    Okt 19 20:23:20 raspberrypi sudo[2318]: pam_unix(sudo:session): session opened f

    Okt 19 20:23:20 raspberrypi sudo[2318]: pam_unix(sudo:session): session closed f

    lines 1-17/17 (END)...skipping...

    ● rfid-reader.service - RFID-Reader Service

    Loaded: loaded (/etc/systemd/system/rfid-reader.service; enabled; vendor preset: enabled)

    Active: active (running) since Fri 2018-10-19 20:21:33 CEST; 9min ago

    Main PID: 409 (python2)

    CGroup: /system.slice/rfid-reader.service

    └─409 /usr/bin/python2 /home/pi/RPi-Jukebox-RFID/scripts/daemon_rfid_reader.py

    Okt 19 20:23:20 raspberrypi sudo[2301]: pam_unix(sudo:session): session opened for user root by (uid=0)

    Okt 19 20:23:20 raspberrypi sudo[2301]: pam_unix(sudo:session): session closed for user root

    Okt 19 20:23:20 raspberrypi python2[409]: mpd error: No such playlist

    Okt 19 20:23:20 raspberrypi python2[409]: loading: Lieblingsmusik

    Okt 19 20:23:20 raspberrypi sudo[2310]: pi : TTY=unknown ; PWD=/home/pi/RPi-Jukebox-RFID ; USER=root ; COMMAND=/bin/echo Lieblingsmusik

    Okt 19 20:23:20 raspberrypi sudo[2310]: pam_unix(sudo:session): session opened for user root by (uid=0)

    Okt 19 20:23:20 raspberrypi sudo[2310]: pam_unix(sudo:session): session closed for user root

    Okt 19 20:23:20 raspberrypi sudo[2318]: pi : TTY=unknown ; PWD=/home/pi/RPi-Jukebox-RFID ; USER=root ; COMMAND=/bin/chmod 777 /home/pi/RPi-Jukebox-RFID/scripts/../settings/Latest_Playlis

    Okt 19 20:23:20 raspberrypi sudo[2318]: pam_unix(sudo:session): session opened for user root by (uid=0)

    Okt 19 20:23:20 raspberrypi sudo[2318]: pam_unix(sudo:session): session closed for user root


    Weis evtl. jemand was ich falsch gemacht habe? Habe kaum erfahrung mit so etwas. Habe auch die Einstellungen vom MPD geprüft, schie alles Ok zu sein.

    Danke im voraus.

  • Hallo trevelsi,

    willkommen im Forum!

    Keine Chance, bekomme die Box einfach nicht zum Laufen.

    Ist keine Fehlermeldung. ;)

    No such playlist

    Sagt dagegen alles. Wo liegt die Datei Lieblingsmusik.m3u und was steht in der /etc/mpd.conf in der Zeile bei playlist_directory?

  • Hallo Ihr,

    nachdem ich hier Eure genialen MusikBoxen gefunden habe, sollte unser Jüngster (7J) auch eine PhoneBox bekommen (leider habe ich mit ihm schon ein passendes Video angeschaut und jetzt bin ich erheblich in Zugzwang...).

    Nachdem die Trust-Boxen beim mir einen grauenvollen Klang aus dem Raspi verbreiten, habe ich einen HiFiBerry Amp2 auf den Raspberry Pi 3 B+ gesteckt.

    Ich bekomme jedoch nur den PhonieBox-Anmelde-Sound auf einem angeschlossenen Lautsprecher ausgegeben.

    Ansonsten herrscht eisernes Schweigen.

    Ich habe seit 2 Tagen alle möglichen (und ich vermute auch ein paar unmögliche) Einstellungen durchprobiert, aber es klappt einfach nicht :(

    (Meine letzte Idee war max2play auf dem Raspi zu installieren. Über den hauseigenen Logitech Media Server spielt der Amp2 auch schöne Musik auf dem angeschlossenen Lautsprecher - PhonieBox spielt dagegen tapfer auf dem Klinkenausgang - wenn auch sehr leise...)

    Deshalb meine Frage:

    Hat jemand hier schon PhonieBox mit einem HiFiBerry Amp2 zusammen gebracht und kann mir helfen?

    Ich bin für jeden Tipp dankbar....

    Viele Grüße

    Florian

  • #ddbkva

    Danke für Deine Antwort. Immer gut zu wissen, dass man nicht alleine da sitzt :)

    Unter raspi-config gibt es HDMI und den Klinkenausgang. Ich vermute, dass ich hier HDMI wählen sollte, weil der HiFiBerry die Signale Digital bekommt.

    Danke auch für den Link zu den Erklärungen des alsa-mixers! Ich arbeite mich da mal durch.

    Wie beschreibt der Autor das? "sound on Linux is fiendishly complicated"

    Viele Grüße

    Florian

  • Laut Bewertung ist es kein Taster sondern ein Schalter der eingedrückt/aktiv bleibt.

    Nicht nur laut Bewertung...sogar mit: Light ring Laempchens Colour;)

    Product description

    Pressure Switch 16 mm 12 V 3 A Red Metal

    Light ring Laempchens Colour: Red

    Snap button: press the button – On, Release – on, press the button again – off

  • Hallo,

    solange Eure Fehlermeldungen undetailiert sind, ist es sinnlos.

    Wenn das aplay Kommando, ohne device-Angabe, einen Sound ausgibt, heißt das nur, daß das alsa-default-device funktoniert (wie auch immer dieses konfiguriert ist) und die Lautstärke über der Hörschwelle liegt.

    Schönen Gruß, kle

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!