Website (Apache) mit .htaccess gesichert, aber kein Login-Fenster

  • Hallo,
    nutze Apache als Webserver und habe mein www-Root jetzt mittels .htaccess gesichert.
    Bei einem Zugriff über einen Browser erscheint jetzt auch, das ich kein Zugriff drauf habe.


    Es kommt aber kein Fenster, wo ich mich "einloggen" könnte, also Login/Passwort eingegeben könnte.


    Was muss ich denn noch definieren/konfigurieren?

  • In sites-enabled/000-default:
    AllowOverride ALL


    .htusers angelegt, hpasswd Passwort vergeben.


    .htaccess in Document-Root angelegt:
    AuthType Basic
    AuthName"Bitte einloggen ..."
    AuthUserFile /etc/.htusers
    allow from all
    require valid-user



    Wie geschrieben, Kontrolle greift ja auch, aber es kommt kein "Fenster" wenn ich per Webbrowser zugreife.
    Denkfehler?

  • Bitte ausführlicher beschreiben wie du was gemacht hast.


    * .htaccess funktioniert nur mit dem apache2 Webserver.
    * Code oder Configs bitte im CODE tag posten. Weil bei deinem oben hingeklatschten Post sehe ich nämlich kein Leerzeichen wo aber eins sein müsste, nach AuthName. Vielleicht sehe ich das aber auch nur falsch... Aber solche Kleinigkeiten können bereits Grund genug sein.
    * Nachdem du die Konfiguration vom apache2 änderst musst du zumindest anweisen die config zu reloaden, oder den Prozess neu starten.
    * Die .htaccess relevanten Dateien benötigt spezielle Dateirechte: chmod 600
    * Der Webserver benötigt zumindest Leserechte auf den .htaccess relevanten Dateien.
    * Im /var/log/apache2/error.log stehen sehr oft auch entsprechende Hinweise


    Ich bevorzuge aber eher ein eigenes Loginsystem via PHP, damit ist man dann auch unabhängig vom apache2 und kann zB nginx o.ä. nutzen.

  • So,
    danke für deine Hilfe!


    Hier die "Daten", ich hoffe, es hilft weiter ....
    - Apache2 ist im Einsatz.
    Restart des Apaches nach Config-Änderung wird/wurde durchgeführt.


    Passwort-Datei:
    -rw-r--r-- 1 www-data www-data 45 Nov 25 22:38 /etc/.htusers


    Code
    cat /etc/.htusers
    energy:$apr1$bzaGxxxxxxxTuoq4P2R1j.aN/


    ls -l .htaccess
    -rw------- 1 root root 169 Nov 25 23:12 .htaccess

    Code
    cat .htaccess
    # .htaccess-Datei
    AuthType Basic
    AuthName "Zugriff verweigert - Bitte User und Passwort eingeben"
    AuthUserFile /etc/.htusers
    allow from all
    require valid-user



    ls -al /etc/apache2/sites-enabled/000-default
    lrwxrwxrwx 1 root root 26 Nov 3 13:44 /etc/apache2/sites-enabled/000-default -> ../sites-available/default
    Inhalt:


    Was mich wundert, das der Apache immer gleich gesprächig ist, egal welchen LogLevel ich einstelle!
    Trotz "debug" erscheint beim Aufruf nur:
    192.168.65.112 - - [27/Nov/2014:22:49:55 +0100] "GET / HTTP/1.1" 403 498 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.65 Safari/537.36"
    => "403 Forbidden - You don't have permission to access / on this server."



    Dann noch die apache 2.conf (ohne Kommentare ...):



    Puhhh,
    ich hoffe, es hilft ....
    Danke!


  • ls -l .htaccess
    -rw------- 1 root root 169 Nov 25 23:12 .htaccess



    root:root ?
    Die kann www-data nicht lesen.

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • ARRGHHHHHH!


    Danke :-(
    Manchmal sind es die einfachsten Dinge ....



    Aber zum Logfile, sollten bei z.B. "LogLevel crit" nicht nur "Fehler" ins Logfile geschrieben werden? Jeder Aufruf der Seite erscheint jedoch im Logfile (Apache wurde nach neu gestartet).
    "LogLevel crit" steht in /etc/apache2/apache2.conf und auch in /etc/apache2/sites-enabled/000-default

  • Wo ? Im Apache Logfile error.log oder im Access.log ?

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

    Edited once, last by Der_Imperator ().

  • Ja, aktuell ...
    Das war um den "Fehler" mit der fehlenden Logn-Maske zu finden (hat aber auch keine anderen Einträge erzeugt wie zur (warn oder critical).


    Aktuell stehts auf "crit" und wie geschrieben, jedes einloggen erscheint im Logfile ...


    Code
    root@raspberrypi:~# grep -i loglevel /etc/apache2/apache2.conf /etc/apache2/sites-enabled/000-default
    /etc/apache2/apache2.conf:LogLevel crit
    /etc/apache2/sites-enabled/000-default: LogLevel crit


    ==>

    Code
    xxx.125.zzz.132 - energy [28/Nov/2014:14:50:16 +0100] "GET / HTTP/1.1" 200 905 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
    xxx.125.zzz.132 - energy [28/Nov/2014:14:50:17 +0100] "GET /fine.jpg HTTP/1.1" 200 11470 "http://... "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
    xxx.125.zzz.132 - energy [28/Nov/2014:14:50:17 +0100] "GET /1week.jpg HTTP/1.1" 304 186 "http://...." "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
    xxx.125.zzz.132 - energy [28/Nov/2014:14:50:17 +0100] "GET /1month.jpg HTTP/1.1" 304 186 "http://..." "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
    xxx.125.zzz.132 - energy [28/Nov/2014:14:50:17 +0100] "GET /24hour.jpg HTTP/1.1" 304 186 "http://...." "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
    xxx.125.zzz.132 - energy [28/Nov/2014:14:50:17 +0100] "GET /SmilyYellow.png HTTP/1.1" 304 190 "http://..." "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"


    [hr]



    UPDATE, Postings/Rüclfrage hat sich überschnitten:
    Im access-log ..... und "loglevel xx" bezieht sich auf das error.log, vermute ich dann mal fast, lorrekt?



    heißt, das man diese Anzahl der logeinträge in access.log nicht reduzieren kann?

  • Quote


    Remember that if you decide to set the log level to crit, the messages for more important levels will be logged as well (in this case, alert and emerg).


    NOTE Notice level messages are always logged, regardless of the LogLevel setting.

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.