miniDLNA will keine mkv streamen

  • Hallo,


    mein erste Frage wo ich mal nicht mit Tuts und so weiterkomme.


    Ich habe einen Pi rev B als Server laufen. Samba und FTP läuft gut, aber bei miniDLNA habe ich ein problem: er streamt keine .mkv. mit bestimmt 20 dateien getestet: .avi laufen top, .mkv werde nzwar angezeigt, lassen sich aber nicht abspielen.
    als client habe ich einen Samsung TV, da kommt dann netzwerk überprüfen und einen PC mit PowerDVD und VLC, da bleibt das bild einfach schwarz.


    Komischerweise funktioniert es, wenn ich den integrierten minidlna von DD-WRT auf dem router nehme. also liegt es nicht am Abspielgerät und nicht an den dateien und nicht an minidlna an sich. aber woran das liegt habe ich keine ahnung.


    installiert ahbe ich über apt-get und
    zum verwalten nehme ich Webmin, was ganz gut klappt für mich als linuxanfänger.


    habe mich auch mit der config von minidlna befasst, aber soviel gibts ja gar nicht da. und erst recht nicht was das problem auslösen könnte.


    die avi und mkv sind alle auf dem gleichen weg (samba) auf den pi gekommen, daher tippe ich mal an den rechten liegt es nicht. per samba und ftp kann ich auf die dateien zugreifen.


    leider scheint das ein seltenes problem zu sein, weil ich nicht wirklich was im netz dazu finde.


    Betriebssystem in Raspbian.


    Falls ihr irgendwelche configs braucht liefere ich diese dann auch :)


    bin für jede hilfe dankbar!

    Edited once, last by Katze ().


  • Falls ihr irgendwelche configs braucht liefere ich diese dann auch :)


    Genau die wären gut. Am besten von dem Raspi und auch dem Dd-wrt.
    Dazu bitte noch die Versionen der Minidlna Pakete auf beiden Systemen.


    Hast du ein Android Gerät? Dort könntest du das ganze mal noch mit BubbleUPnP testen. Eventuell siehst du dort dann per Logcat einen genaueren Fehler am Client.


    Steht im Log von Minidlna auf dem Raspi etwas?

    Linux - Für das Leben nach dem Absturz!

  • Hi!
    also der log sagt folgendes:


    Code
    [2014/12/03 22:21:03] minidlna.c:898: warn: Starting MiniDLNA version 1.0.24 [SQLite 3.7.13].
    [2014/12/03 22:21:03] sql.c:41: error: SQL ERROR 8 [attempt to write a readonly database]
    pragma default_cache_size = 8192;
    [2014/12/03 22:21:03] minidlna.c:1006: warn: HTTP listening on port 8200
    [2014/12/03 22:21:03] inotify.c:195: warn: WARNING: Inotify max_user_watches [8192] is low or close to the number of used watches [7] and I do not have permission to increase this limit.  Please do so manually by writing a higher value into /proc/sys/fs/inotify/max_user_watches.
    [2014/12/03 22:22:15] upnphttp.c:1907: error: Error opening /media/USB/NAS/videos/1080p.mkv
    [2014/12/03 22:22:17] upnphttp.c:1907: error: Error opening /media/USB/NAS/videos/1080p.mkv


    rechte habe ich nochmal geprüft, sind bei den funktionieren avis und den mkvs gleich.


    config wäre:


    da fällt mir ein, könnte es was mit den speziellen Audio/Pictures/Video ordenr sein? dass er mkv nicht als Video einstuft und dann mist baut?

  • Mit welcher Frequenz läuft dein PI?


    Ich empfehle 950 MHZ (Overlockmenu HIGH)


    und mache folgendes:


    cd proc/sys/fs/inotify/
    sudo nano max_user_watches


    oder wenn das nicht geht: sudo nano /etc/sysctl.conf


    dort:


    # Increase inotify max watchs per user for local minidlna
    fs.inotify.max_user_watches = 100000


    ändern.


    In der minidlna config:


    enable_tivo=yes


    dann:


    sudo chown -R minidlna:minidlna /var/lib/minidlna


    sudo /etc/init.d/minidlna restart

    Edited once, last by Logai ().

  • Er läuft auf High.


    ich habe das gemacht was du sagtest, habe auch mal die DB von der Festplatte auf die SD geändert, also var/lib/minidlna.


    irgendwas war falsch, jetzt gehts. Sauber!


    AAAAch na klar, also es lag en der DB, die nicht schreibbar war, ich habe zwischenzeitlich die HD filme in einen Ordner HD gepackt um die übersicht zu behalten.


    die DB hatte aber einen alten stand, wo die noch nicht in dem HD Unterordner waren. somit konnt er die natürlich nicht öffnen, weil die nicht mehr da lagen.


    so einfach und doch so schwer! warum die DB plötzlich nicht mehr schreibbar war, wundert mich aber schon. naja jetzt geht alles, nachdem die DB auf var/lib/ geändert wurde.