Ambilight-Projekt für HDMI Quellen RaspberryPi+Raspbian+Hyperion_TV/Beamer

  • Mein ambilight stand ein Jahr still, hab jetzt auf apa102 60led/meter umgebaut mit kurze Leitungen, funktioniert super.


    Nur startet hyperion nicht automatisch wenn ich mein raspberry 2 einschalte, starte es immer über hypercon manuell.

    Gibt es da eine Lösung ? Befehl sonstiges?


    Wenn man sich einen Screenshot vom Grabber anzeigen lässt, sind ja grüne Streifen auf dem Bild zu sehen.

    Daraufhin flackern die leds ganz leicht grün bei schwarzem Bild. Gibts da Erfahrung?


    Und kann ich einen Yeelight mit am ambilight anschließen?

    Gruss

    Einmal editiert, zuletzt von Chriss255 ()

  • Hi,

    poste doch mal den log von HyperCon, nachdem Du den Pi gestartet hast.

    Die Grünen Streifen im Screenshot sind eigentlich normal.

    Deine jetzige Config wäre auch mal interessant.

    hier mein log aus hypercon

    hier meine config, habe ich was falsch gemacht?

    danke

  • Das selbe Verhalten habe ich bei meinem Pi1. Der scheint defekt zu sein.

    Da kommt auch die Meldung "Failed to open device('/dev/spidev0.0')" beim ersten Start.

    Wenn ich in HyperCon unter SSH Stoppe und wieder Starte läuft es dann.


    Habe alles mögliche schon probiert, keine Chance bis jetzt.

  • Das selbe verhalten habe ich bei meinem Pi1. Der scheint defekt zu sein.

    Da kommt auch die Meldung "Failed to open device('/dev/spidev0.0')" beim ersten Start.

    Wenn ich in HyperCon unter SSH Stoppe und wieder Starte läuft es dann.

    meinste mein pi2 ist defekt? der ist ja schon fast wie neu :D

    genau ich muss es manuell in hypercon oder ssh starten, obwohl es damals mit deiner alten image funktioniert hat

  • Ich habe es mit dem gleichen Image auf anderen Raspberrys getestet und da läuft es.

    Ich kann mir das auch nicht erklären, also ich denke das mein Pi1 irgend ein Problem am GPIO hat.

    Ein Softwareproblem schließe ich aus, habe es mehrmals mit einem Pi2 und Pi3 gegengetestet unter gleichen Voraussetzungen. (Gleiches Netzteil, LEDs und Image.)

  • Hallo Sigi,


    was für einen Kabelquerschnitt hast du in deinem aktuellen Setup an den einzelnen Stellen genommen? Insbesondere an den XT60 Steckern und im Pi an 5V und GND?

  • Ich bin zwar nicht sigi28 , dennoch antworte ich mal.. Ich benutze an den XT60 gerne 0.75mm2. An den ecken kann ich es dir nicht sagen, das ist immer unterschiedlich was ich gerade so bereit habe..

    Wenn's brennt 112 hilft weiter!

  • Super Danke, 0,75er hab ich noch einiges hier, fürs Netzteil hab ich 1,5er genommen. Warte jetzt noch auf das RemotePi Board und dann kanns los gehen. Die zusätzlichen beiden Einspeisungen an meinen Apa102 nehm ich die direkt vom Netzteil oder auch aus dem Pi? Und für die Datenleitung will ich ein Cat7 nehmen, verbinde ich da nur die Daten oder geh ich da auch mit jeweils 2 an 5V und GND?

  • Wenn das Ambilight schon seit einiger Zeit sauber läuft (einige Jahre/Monate), lohnt es sich dann ständig auf ein neues Image zu wechseln?

    Gibt es da einen Mehrwert?

  • Puh, ich glaube seit meinem letzten Update sind wieder 3-4 Images raus von dir.

    Ich hab auf jeden Fall schon diesen Umbruch mit diesem Java Hyperion Geraffel mitgemacht.

  • Kann man den grabber noch irgendwie farblich beeinflussen? Ich finde das Bild sehr dunkel und wenig farbenfroh.

    Ich habe den Weißwert für meine Wand ziemlich passend zur Darstellung vom TV, aber schwache Farben kommen fast gar nicht und problematisch sind z.B. Brauntöne. Irgendwie sieht das etwas blass aus.

    Läuft alles prima und das blaue Blitzen ist komplett behoben. Hab viele Monde gesucht, getüftelt, Kabel getauscht, ganzen Aufbau optimiert (Stromversorgung, etc.).

    Nachdem dann irgendwann ein kompletter Bereich dauerhaft blau leuchtete, habe ich das letzte funktionierende und das erste blaue Segment rausgeschnitten und durch andere (Reste von diesem Stripe) ersetzt. Herrlich! Diese Stelle war anscheinend von Beginn an defekt. Erst nur wenig und dann ganz.

    Jetzt hab ich doch wieder Motivation für Feintuning. :)