Raspbian schmeißt mich unmittelbar nach dem Login aus SSH raus

  • Hallo Uwe,


    vermutlich liegt die Ursache in dem Script, das Du programmiert hast. Je nachdem, ob es automatisdch gestartet wird, immer im Hintergrunbd läuft etc., kann es diesen Effekt hervorrufen.


    Da wir das Skript nicht kennen, verbietet sich eine weitere Spekulation dazu.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo Andreas,


    vielen Dank für die schnelle Antwort.


    http://www.forum-raspberrypi.d…lies_green/icon_smile.gif


    Das script (attached an diese Antwort) starte ich aus einer ssh session zum PI, die ich von einem Ubuntu Rechner aus starte.
    Also


    ssh pi@<192.168.1.2>


    .. pwd eingeben
    # cd $scriptort
    ./checkv.sh


    .
    .
    .
    .


    Dann werden die ausgelesenen Werte ausgegeben, bei 50 stoppt das script das PI.
    Die ssh Verbindung wird dann gezwungenermassen abgebrochen.


    Auf dei Ausgabe könnte ich verzichten, aber wie lasse ich das script (falls es korrekt ist) im Hintergrund laufen?


    Viele Grüße


    Uwe

  • Das Problem kenne ich. Ist Dein Pi über WLAN verbunden? Ich hatte die gleichen Symptome weil die WLAN Verbindung kurzzeitg unterbrochen wurde. Das liegt meistens an der PowerSave-Funktion des WLAN Dongles. Bei einem Dongle mit dem weit-verbreiteten Realtek Chip kann man eine


    /etc/modprobe.d/8192cu.conf


    Datei anlegen, und zwar mit dem Inhalt:


    # Workaround for dropping connections because power save
    options 8192cu rtw_power_mgnt=0 rtw_enusbss=0


    Die Verbindung sollte nicht mehr abbrechen. (Reboot bzw. Reload des Moduls erforderlich).


    Falls Du


    smsc95xx 1-1.1:1.0 eth0: unexpected urb length 0


    in /var/log/messages findest, und der Pi nicht über eth0 verbunden ist, kann man auch noch eth0 per initscript deaktivieren. Das ist hier beschrieben. Es gibt/gab wohl einen Bug im USB-Treiber des Pi, der
    bei den B Modellen auftritt und zu einer Unterbrechung der Verbindung geführt hat. Die B+ Modelle
    sind davon wohl nicht mehr betroffen.

  • Hallo luetzel,


    danke für Deinen Beitrag.
    Das Kernproblem wird zwar nicht gelöst, jedoch ist es sporadisch nicht möglich, die WLN Verbindung herzustellen.


    Evtl. hilft Deine Modulparametrisierung, ich werde das mal testen.


    Mein eigentliches Problem (kein login möglich nach shutdown) habe ich gelöst:


    - script, welches das PI herunterfaehrt im Hintergrund ausführen
    - alle Ausgaben des script auf Datei umlenken


    Die 'Wiedererweckung' lief so ab:


    - PI an Monitor und Tastatur anschliessen und login versuchen
    - da dies dann auch nicht ging:
    - per STRG-ALT-ENTF booten
    -> login geht wieder


    Fehler war wohl, dass die Ausgabe des scripts bzw. des im script ausgeführten Kommandos 'sudo halt', also
    'System going down at <date>' nach Neustart Teil der Login Daten wurde. Damit konnte man nie den Benutzer bzw. das Passwort korrekt eingeben. (Siehe /var/log/auth.log)


    Danke nochmal auch Andreas


    Beste Gruesse


    Uwe

  • Hallo Uwe,


    das klingt ja schon mal besser - zum WLAN Drop gibt es jedenfalls zahlreiche Einträge im Forum der raspberrypi.org. Dort hatte ich auch den Tip bezgl. des PowerSave gefunden. Weil das Dongle
    "eingeschlafen" war, konnte ich mich nicht mehr auf dem Pi einloggen, bzw. erst nach dem x-ten
    Versuch oder sogar Reboot. Unter Windows, mit Putty ist dann immer die Verbindung nach kurzer Zeit abgebrochen.


    Ein weiterer Tip wäre noch das WLAN nicht üder die wpa_supplicant.conf sondern in der /etc/network/interfaces zu konfigurieren, etwa so:


    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp
    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet dhcp
    wpa-ssid MeinAccessPoint
    wpa-psk 1234567890


    Grüsse,


    luetzel