ACT LED leuchtet dauerhaft

  • Hallo zusammen,


    Zuerst mal: bin mir nicht sicher, ob ich hier im richtigen Bereich bin.. Konnte aber keinen besseren finden :) falls was nicht passt bitte verschieben.


    Zu meinem Problem:
    Ich habe heute an meinem Power Button (tut hier im Forum) gebastelt, zunächst mit Probleme, die aber softwaretechnischer Natur waren.
    Nachdem ich da fertig war und in der Richtung jetzt alles funktioniert wie es soll, ist mir aufgefallen, dass meine Act led jetzt dauerhaft leuchtet. Also die, die eigentlich anzeigt ob er gerade was auf der sd karte rödelt.


    Habe danach nochmal ein altes Image eingespielt, mit dem defintiv die led so blinkte wie sie es tun soll. - ohne Erfolg, Leutet nach wie vor dauerhaft.


    Der raspberry funktioniert soweit ich es bisher testen konnte einwandfrei. Fährt normal Hoch und man kann wie gehabt damit arbeiten.


    Trotzdem fände ich es ganz schön wenn die led wieder funktionieren würde..


    Hat jemand eine Idee oder Erfahrungen, an was es liegen könnte?


    Danke schonmal und viele grüße

  • Hallo Real_Napster,


    ein heiteres Ratespiel:


    Die ACT_LED leuchtet, weil etwas auf die Karte geschrieben wird.


    Die ACT_LED leuchtet, weil eine Software sie leuchten lassen möchte.


    Du hast Dich an einem TUT entlang gehangelt. OK, das machen viele. Aber welches TUT mag es gewesen sein?


    Falls Du eine Software ins Spiel gebracht hast, ist da ein Quellcode oder eine Konfiguration, die Du uns mitteilen könntest?


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Zuerst mal danke für die Antwort.
    Welches tut es war, hatte ich gar nicht erst genauer erwähnt weil ich nicht davon ausgehe, dass es daran liegt.
    Der Vollständigkeit halber war aber aber dieses:
    http://www.forum-raspberrypi.d…ls-taster-incl-status-led


    Warum es daran eigentlich nicht liegen kann ist wie gesagt, weil das Problem auch bei einem "nackigen" Image auftritt, bei dem es führer keine Probleme gab.


    Zum Verständnis: die led leuchtet dauerhaft. D.h. Kein flackern o.ä. Was auf andauernde schreib / lesevorgänge hinweisen würde.


    Viele grüße

  • Hallo Real_Napster,


    suche mal nach

    Code
    Device Tree Tutorial raspiprojekt


    und mach das, was dort steht...



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hi,
    in meinen Augen etwas sehr riskant, was den Vorwiderstand der LED angeht.
    Der Autor geht da von einem Strom zwischen 10 und 20 mA aus und rät zu einem 100 Ohm Widerstand.
    Das ist imho mehr als bedenklich :fies:
    Miss das mal, was da an Strom fliesst. Ich kann Dir nur den Rat geben diesen Wert auf zwischen 2 und max. 6 mA zu beschränken.
    Das wäre dann ein Vorwiderstand von >= 910 Ohm bei einer roten bzw. >= 680 Ohm bei einer grünen LED.
    cu,
    -ds-