Dauerbetrieb - Problem mit Raspberry

  • Hi,
    ich habe beim Dauerbetrieb mit einem V2 Raspberry immer wieder das Problem, das eine dauerhafte Übertragung aussetzt. Zuerst habe ich vermutet, das bei dauerhafter Übertragung (also durchgehen) der Stick für WLAN schuld ist, war er zum Teil auch - aber nachdem ich es fest am Netzwerkabel hatte, stellte ich fest das manchmal mit dem IP-Wechsel auch die Verbindung irgendwie einfriert.


    Hat da jemand Erfahrung ?


    Gruss Kasi


  • aber nachdem ich es fest am Netzwerkabel hatte, stellte ich fest das manchmal mit dem IP-Wechsel auch die Verbindung irgendwie einfriert.


    Hat da jemand Erfahrung ?


    Klar, wenn während der Übertragung die IP gewechselt wird, dann bekommt der Empfänger der laufenden Verbindung das nicht mit.


    Allerdings ist das eine Vermutung, weil Du nichts genaueres über die Übertragung sagst.


    Ich empfehle Dir eine statische IP-Konfiguration.

  • Hallo Kasimir,


    nutze einmal die Suchfunktioni dieses Forums und suche nach


    Code
    Mysterium


    Dort findest Du reichlich Hinweise über Ursachen und Maßnahmen.


    Wenn Du allerdings während einer Üertragung die IP-Adressen wechselst, dann wundert mich dass allerdings auch nicht...



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo,
    und danke erst einmal für die Antworten...


    Also - die Übertragung verläuft folgender Maßem...
    (Szenario)


    Der Raspberry befindet sich auf einem Boot und sendet über einen UMTS Stick einen Datensatz von ca. 80-120 Byte - also lat/lon und kleinere Infos.


    Der GPS Server nimmt es entgegen und speichert es in einer Datenbank
    Traccar Server von traccar.org (liegt auf einem Server im Netz).


    Das machte der Raspberry in einer Zeitspanne von 3-10 Sekunden (wahlweise) über ein Python Programm auf dem Raspberry. Aufgefallen ist mir das in einem Testbetrieb wo ich feststellen wollte, wie zuverlässig das Ganze durchgehend funktioniert, denn wenn die Boote unterwegs sin, dann ist es schlecht, wenn das alles an Kleinigkeiten scheitert.


    Der Testbetrieb ist folgender Maßen aufgebaut - ich nutze keinen UMTS Stick, sondern übertrage das Ganze mit einem Kabel und über eine Fritzbox 7490 zum Server. Die IP bekomme ich von der Fritzbox über DHCP zugewiesen - Später soll das wahlweise über einen UMTS Stick laufen der entweder direkt im Raspberry steckt oder mittels eines TP-Link Wireless N Router TL-MR3020 genutzt wird und dabei auch an Bord W-Lan zur Verfügung stellt.


    Über dieses W-Lan werden dann wiederum später einige Boots Sensoren abgegriffen, wie zum Beispiel Tiefenmesser - siehe auch OSM Beispiel von Victor OSM - siehe hier
    http://wiki.openseamap.org/wik…p-dev:HW-logger/raspberry
    (Das ist dann das Ziel mit einigen Verbesserungen in der Übertragung zum Server)


    Ich hoffe, ich konnte damit das Ganze für euch transparenter machen.
    Das mit der statischen I.P. hatte ich auch schon mehrmals gelesen. Dummerweise ist das aöles nicht so leicht zu testen, weil ich auch mit den UMTS Sticks Probleme habe, denn die Besipiele mit der Software lassen sich bei mir nicht realisieren, scheitern schon an der Installation - und Debian habe ich nicht ganz so viel gemacht bisher ;)


    Ich habe mir daher jetzt noch mal einen UMTS Stick bestellt, der von TP-Link empfohlen wurde, damit ich überhaupt erstmal das Ganze simulieren kann - was jetzt noch ein experimenteller Aufbau ist. Aber das Problem mit dem Stick habe ich hier auch schon mal als Beitrag abgegeben, aber ich stehe mit dem Fehler irgendwie ein wenig alleine da, konnte jedenfalls nichts davon lesen, das andere Probleme hatten, bei mir läuft wvdial auf keinem Raspberry, bzw. lässt sich nirgendwo installieren - friert bei Einrichten ohne Fehlermeldung ein.


    Soweit zu dem Thema..
    Aber ich gehe euren Hinweisen und Vorschlägen nach und bedanke mich für die Antworten !


    Gruss Kasi

  • was ist das für ein umts stick?
    ich habe auch einen an einer mobilen anwendung, strom kommt extra nicht vom pi.

    das leben ist hart, aber wir müssen da durch.