Raspberry Pi in Reboot Schleife

  • Hallo zusammen,


    seit heute habe ich folgendes Problem:


    Mein Edimax WLAN Stick schaltet sich ständig an/ aus, dh. mein pi verbindet sich mit dem Internet, dann kann ich per WinSCP und Putty drauf zugreifen und dann nach weiteren 5 sek ungefähr "rebootet" der Stick, d.h. er hört auf, blau zu blinken, wartet eine Weile (paar Sekunden) und verbindet sich dann aufs neue mit meinem Router. Dann kann ich wieder drauf zugreifen für paar Sekunden und das Spiel beginnt von vorn.


    Ich habe gestern den Watchdog aktiviert, eigentlich mit dem Hintergedanken, dass mein Pi sich bei Verlust des Signals zum Router selbst neu verbindet. Aber ich habe Angst, dass sich da irgendwo ein Fehler eingeschlichen hat und Watchdog jetzt ständig neu verbinden lässt. Allerdings habe ich vorhin mit "sudo /etc/init.d/watchdog status" ein "failed: watchdog is not running" bekommen, also liegt es wohl nicht daran oder?


    Habe jetzt die Befürchtung, dass der WLAN Stick kaputt ist.


    Hat jmd. eine Idee? Das Problem ist, dass ich keine externe Tastatur habe => ich kann noch nicht mal direkt auf meinen Pi zugreifen -.-


    Aber hey, ca. 5 Sekunden für Befehlseingaben habe ich pro "Wiedereinwahl" ;)


    Wäre super, wenn ihr mir weiter helfen könntet :)


    VG

    Edited once, last by elchico ().

  • Hallo Elchico,


    bevor man Dir sinnvolle Tips geben kann, erst einmal ein paar Fragen:


    - Welches Raspberry Pi-Modell setzt Du ein?
    - Wie hast Du den WLAN-Stick an den Raspberry Pi angeschlossen (direkt über USB-Buchse oder einen aktiven USB-Hub oder einen passiven USB-Hub)?
    - Wie hast Du den WLAN-Stick konfiguriert? Poste bitte die entsprechenden Dateien!
    - Poste bitte die Watchdog-Konfiguration!


    Ansonsten solltest Du den Raspberry Pi einmal an einen Bildschirm anschließen, um zu sehen, was der gerade so treibt und welche Fehlermeldungen er absetzt.


    In diesem Zusammenhang wäre auch die Ausgabe von

    Code
    dmesg


    und

    Code
    lsusb


    und

    Code
    lsusb -t


    interessant. Einmal während eine Verbindung "steht" - und wenn sie nicht mehr existiert.



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • ok also:
    Pi B+
    Edimax direkt an USB-Anschluss


    Außerdem habe ich, wie du meintest, ihn mal an einen externen Bildschirm angesprochen und siehe da: es liegt nicht am WLAN Stick, wie ich zuvor dachte, sondern das ganze System hängt in einem reboot loop. Deswegen habe ich immer nur ein paar Sekunden und dann startet das System komplett neu.


    Habe jetzt meine SD Karte am PC angeschaut, und versteh von den Dateien leider gar nix.


    Gibt es noch eine Möglichkeit, das ganze rückgängig zu machen? Oder muss ich das System neu aufsetzen?


    VG und Danke :)

  • Hallo Elchico,


    der Reboot-Loop hat zwei mögliche Ursachen
    1. Ist so eingestellt (kann ich mir nicht vorstellen, dass Du sowas machst) ;)
    2. Das arme Teil bekommt zuwenig Strom


    Wenn Dein Rapberry Pi einmal stromlos ist, dann entferne doch mal den USB-Stick und boote das Teil ohne WLAN-Stick.
    Wenn Du das Teil nicht ausschalten kannst (wovon auszugehen ist), dann entferne den WLAN-Stick in einem Moment, indem die grüne LED NICHT leuchtet oder blinkt. In einem solchen Moment ist es relativ ungefährlich, ein USB-Medium zu entfernen.


    Wenn Du den Raspberry Pi von der Spannungsversorgung trennst, während die grüne LED leuchtet / blinkt, dann ist die Wahrscheinlichkeit relativ groß, das Dateisystem der SD-Karte zu zerstören.



    Bootet er jetzt ordnungsgemäß, dann liegt es an einer mangelhaften Stromversorgung.
    Fragen:
    1. Was hängt noch alles an den USB-Buchsen des Raspberry Pi?
    2. Betreibst Du weitere Verbraucher (z.B. über GPIO etc.)?
    3. Welche technischen Daten sind auf Deinem Netzteil aufgedruckt?


    Von raspiprojekt gibt es ein Messgerät, dass Du an die USB-Schnittstelle (Mikro-USB) anschließen kannst und Du erhältst dann Informationen über Spannung (4,75 V <= Spannung <= 5,25 V) und den aktuellen Strombedarf.


    Aller Wahrscheinlichkeit liefert Dein Netzteil zu wenig Strom, um sowohl den Raspberry Pi als auch den WLAN-Stick (und ggf. weitere Peripherie) betreiben zu können.


    Suche mal unter

    Code
    Mysterium

    in diesem Forum!



    Bootet das Teil nach Abklemmen des WLAN-Sticks nicht ordnungsgemäß, dann hast Du ein generelles Problem mit dem Netzteil. Dieses ist für den Betrieb nicht (mehr) geeignet.
    Stichwort hierzu:

    Code
    Netzteil Alterung

    oder

    Code
    Alterung von Kondensatoren



    Falls Du einen aktiven USB-Hub bsitzt, dann betreibe den WLAN-Stick darüber - und Deine Probleme gehören der Vergangenheit an. Da spreche ich aus eigener Erfahrung. Ich klemme seit geraumer Zeit maximal nur noch geeignete Tastaturen und Maus direkt an den Raspberry Pi an. Alles andere läuft erfolgreich über einen aktiven USB-Hub.


    Mein aktueller Favorit (seit über einem Jahr im Dauer-Einsatz an mehreren Raspberry Pis):
    LogiLink 10Port USB-Hub mit 10 USB-Buchsen und Netzteil mit 3,5 A Stromversorgung).


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • hey


    ohne WLAN Stick häng ich immer noch im Reboot fest. Ich habe alles abgehängt. Jetzt ist nur noch ein HDMI Kabel und das Stromkabel verbunden.


    Habe als Stromquelle zwei verschiedene Handy-Ladegeräte ausprobiert, wobei mit beiden das Pi noch gelaufen ist (mit einem lief es gestern noch, mit dem anderen letzte Woche). So schnell können die doch beide nicht "gealtert" sein oder?


    Daten zu den Netzteilen:
    1x Output: 5 V, 600 mA
    1x Output: 5 V, 700 mA



    Die Chancen stehen gut, dass es eine fehlerhafte Einstellung ist oder? Also mir ist zwar keine solche Einstellung bewusst, aber wie oben erwähnt: das letzte mal, dass das Pi lief, war gestern und da hatte ich Watchdog aktiviert. Hinzu kommt, dass ich vorhin gesehen habe, dass zum einen bcm2708_wdog gestartet wird, zum andern watchdog keepalive (welches aber sofort wieder beendet wird) und der watchdog daemon wir auch gestartet.


    Ich würde ja gern die conf vom Watchdog hier hochladen, aber geht bei `ner Bootschleife schlecht :/


    Noch `ne Idee ;)? Danke nochmals!
    VG


    EDIT: habe die Überschrift aktualisiert

    Edited once, last by elchico ().

  • Hallo Elchico,


    hm, da fährst Du Deinen Raspberry Pi aber sehr grenzwertig. Außerdem haben sich klassische Handyladegeräte als denkbar schlechteste Spannungsversorgung für einen Raspberry Pi erwiesen.


    Das Laden von Handy-Akkus stellt keine großen Anforderungen an die Konstanz von Spannung und der Fähigkeit, einen konstanten Strom zu liefern. Größere Schwankungen sind normal und schaden beim Akku-Laden auch nicht weiter. Außer, dass es länger dauert, als man sich ausrechnen kann - wenn die Werte stimmen würden.


    Der Raspberry Pi arbeitet nur in einem Bereich von 4,75 V bis 5,25 V zuverlässig. Jedes mA, das Dein System aus dem Handyladekabel zieht, vermindert die Spannung. Liegt diese unter 4,75 führt dies zu einem Reboot. Ggf. alle 5 Sekunden ;).


    Das Teil selber braucht rund 700 mA, der WLAN-Stick in Abhängigkeit des Status locker einmal 300 mA.


    Merkst Du was?


    Es gibt User, die mit einem 1200 mA-Netzteil schon Probleme haben. Und Du versuchst mit einem 600 ma/700 mA-Handyladekabel klar zu kommen? :s :denker: :@


    Du hast Dein Ladekabel ständig auf Anschlag gefahren. Da wundert es mich nicht, dass es schneller altert als eines, das im moderaten Betrieb arbeitet.


    Solche Alterungserscheinungen sind schleichende Vorgänge, die Du prinzipiell messen kannst. Aber letztlich stellst Du immer wieder fest: Gestern ging es noch, heute nicht mehr!


    Besorge Dir ein richtig gutes Netzteil und besser auch einen aktiven USB-Hub und Du hast wieder ein zuverlässig arbeitendes System.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hey Andreas,


    also habe jetzt ein neues Netzteil (auch Handy) mit 5 V, 2100 mA Ausgang und hiermit geht es auch nicht ... Keine anderen Komponenten am Pi angeschlossen (kein WLAN Stick, nichts).


    So langsam verzweifle ich :D


    Hast du zufällig noch eine Idee :D? Sonst muss ich die SD doch platt machen und nochmals neu installieren etc.

  • Hallo Elchico,


    na, an der SD-Karte liegt's auch nicht!


    Außer, :s :denker: ... außer, ... :geek: :daumendreh2: ... außer ... die SD-Karte hat durch die Aktionen einen abbekommen und deren Dateisystem ist zerstört.


    Was erscheint denn auf dem Bildschirm, wenn Du zu booten versuchst?


    Kannst Du ein Photo posten?


    Falls Du einen weiteren Linux-Computer hast (der Trend geht zum Zweit- und Dritt-Pi), dann kannst Du die SD-Karte über einen Card-Reader anschließen und Dir die Dateistruktur anschauen.


    Ggf. hilft ein


    Code
    fsck


    bzgl. der SD-Karte.


    Wenn Du keinen Linux-Computer hast, dann wird es wahrscheinlich das Beste sein, die SD-Karte neu zu bespielen. Obwohl es sinnvoller ist, wenn man sich davon überzeugt, dass das Dateisystem wirklich zerschossen wurde.



    Äh, wie hast Du das denn bisher das Betriebsystem auf die SD-Karte bekommen?
    - Hardware?
    - Software?


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Nochmal hi Andreas,


    danke erstmal, dass du dir solche Mühe gibst :)


    Also hab die SD per Windows Laptop installiert. Habe leider keine weitere Linux Hardware ;)


    Boot sieht (soweit ich das einschätzen kann) normal aus, werde gleich aber noch ein Foto posten (Handy Kamera) und ich komme bis zur Benutzernameneingabe und per WinSCP und Putty kann ich ja sogar per WLAN bis in die Shell vorstoßen und evtl. sogar noch einen Befehl abgeben. Dann kommt der Reboot.


    VG
    [hr]
    also habe jetzt ein altes img (kurz nach den ganzen Einstellungen hatte ich mal eins gespeichert) drauf gemacht und jetzt geht wieder alles :)


    Danke dir nochmals :)

    Edited once, last by elchico ().

  • Auch nach Update und Upgrade ??

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT