miniDLNA erkennt USB-STICK nicht

  • Hallo,


    ich habe einen miniDLNA auf einem Raspberry Pi 2 konfiguriert.
    Config:

    Code
    media=/media
    db_dir=/var/lib/minidlna
    log_dir=/var/log
    network_interface=eth0
    port=8200
    friendly_name=RASPI MINIDLNA
    serial=12345678
    model_number=1
    inotify=yes
    notify_interval=30


    Alle USB-Medien werden automatisch unter /media gemountet.


    Jetzt scheint aber MiniDLNA Probleme zu haben mit den Berechtigungen.


    Ich habe es versucht das USB-Laufwerk mittels UUID direkt in /etc/fstab einzutragen:

    Code
    UUID=...<tab>/media/USB-STICK<tab>ntfs-3g<tab>defaults<tab>0<tab>0


    Natürlich habe ich das Verzeichnis noch angelegt und ich habe diesem Verzeichnis die Berechtigungen gegeben und natürlich habe ich in der minidlna.conf auch eben dieses Verzeichnis angegeben.


    Wenn ich dies mit der UUID in der fstab mache, kann ich das Laufwerk nicht mehr automatisch mounten. Es kommt eine Fehlermeldung mit "only root can mount".


    Wenn ich die o.g. Konfigurationsdatei verwende und eigentlich der Meinung bin, nimm einfach alles, was unter /media gemountet wird, bekomme ich das Problem, dass die Berechtigungen nicht stimmen.


    Natürlich habe ich für /media bzw. für den Test für /media/USB-STICK die Berechtigungen angepasst.


    Wenn ich ein Verzeichnis auf der eingebauten SD-Karte anlege und die Berechtigungen dort setze und ein paar Videos bzw. Bilder dort hinein kopiere, dann funktioniert das. Ich hätte aber natürlich gern, dass die unter /media gemounteten Geräte aufgenommen werden.


    Was mache ich falsch? Die UUID-Lösung wäre machbar, aber dann funktioniert das mounten nicht mehr.


    Die Medien sind mit ntfs formatiert und das Paket ntfs-3g ist installiert.


    Ich hoffe, dass noch jemand eine gute Idee hat. Leider sind meine Linuxkenntnisse etwas rudimentär. Ich kenne mich mit Windows aus, aber Linux ist doch was anderes.

  • Quote

    Ich habe es versucht das USB-Laufwerk mittels UUID direkt in /etc/fstab einzutragen:

    Code
    UUID=...<tab>/media/USB-STICK<tab>ntfs-3g<tab>defaults<tab>0<tab>0


    ist nicht die UUID. Nehme mal blkid und such da dein USB STICK raus.


    Da steht das dan ungefähr so:

    Code
    /dev/sdb1: UUID="c7966c6b-8919-4b84-87c3-9532dc08a405" TYPE="ext4"


    In meinem Fall eine USB Festplatte.


    MfG RealHalifax

  • Ja mir ist klar, dass das nicht die UUID ist. Das ist der Eintrag, den ich in der fstab gemacht habe. Die Punkte sind natürlich durch die UUID zu ersetzen, da ich aber von einem anderen Rechner als dem Pi diesen Forumseintrag mache, habe ich mir mal erspart, die UUID auch hier hineinzuschreiben. Ich habe den Eintrag natürlich mit BLKID gesucht und via Copy&Paste in die fstab kopiert.

  • Ich lasse meinen USB-Stick per autofs automatisch bei Bedarf mit diesen Optionen mounten - also nur dann, wenn drauf zugegriffen wird:


    /mnt/Verbatim_128/ -fstype=ntfs,uid=root,gid=root,umask=0022 :/dev/disk/by-uuid/0CD9-0520


    Du kannst den die Berechtigungen und damit den Zugriff mit
    * uid (welchem User sollen die Daten gehören?),
    * gid (welcher Gruppe) und
    * umask (welche Berechtigungsbits sollen vom Vollzugriff entzogen werden? 0022 = kein Schreiben für Gruppe und Other)
    steuern.

  • Ich habe es jetzt hinbekommen, dass via USBMOUNT die Usb-Medien automatisch in vorhandene Verzeichnisse unter /media/usb0-7 gemountet werden.
    Für diese Verzeichnisse habe ich die Rechte angepasst und wenn ich minidlna mit der Option -R starte, wird auch alles gescannt und die Medien werden gefunden.


    Ich habe aber in der Konfigurationsdatei inotify=yes und ein inotify_interval=30 eingestellt. Ich kann aber ewig warten, meine Dateien tauchen nicht auf. Was ist hier das Problem?

    Edited once, last by verarind ().