Owncloud 5 Server installieren (nginx Webserver)

  • Hallo zusammen , bin seit einigen tagen ebenfalls Besitzer eines solchen Pracht Computers (-:


    ich möchte den Pie als Owncloud (nur als Owncloud server) betreiben , bin aber mit dem PHP zauber völlig überfordert , ist jemand so gut und stellt mir seine funktionierende Pie Owncloud als image zur Verfügung , wäre sehr sehr sehr Dankbar


    Grüße an alle

  • Wenn du etwas vorgefertigtes willst, benutze doch das Script owncloudPie, welches hier im Forum grassiert. Habe ich auch verwendet. Läuft echt super

  • Ich installiere generell den Apache.


    Wieso ?


    Ganz ehrlich = Gewohnheit und ich kenne jede seiner Macken im schlaf.


    Aber ngix hab ich jetzt auch ein paar mal hinter mir. So wie der set-up im HowTo beschrieben ist, ist das "Ausführen des php Codes" um einiges schneller als wie wenn du es null 8 15 in den Apache rein klopfst.


    Bei einer normalen web site auf einem normalen Server kein Argument. Sobald du aber unmengen an high traffic hast wird das ganz schnell ganz interessant.


    Doch wir reden hier von einem raspi ... ich hab ownCloud auf dem raspi mit ngix am laufen und ich kann mich null beklagen. Hab ihn nicht mal beschleunigt. Hat 4 Benutzer und wird hauptsächlich für Kalender und Kleinigkeiten genutzt.


    Das iTunes syncen bei dir lahm ist wegen der kleinen Dateien (und der Daten Menge) kann mehrere Gründe haben ... deine Leitung zu Hause von extern bringt nix.


    Du schreibst auf die SD Karte ... der raspi nutzt schon sein SWAP und alle wollen was von der Karte.


    Andere Dienste laufen noch auf dem raspi.


    Oder mal ganz ehrlich ... du nutzt einen raspi ?!?


    Das Teil ist Geil und ich hab drei aber erwarte keine Wunder von dem Ding.
    [hr]


    Hallo zusammen , bin seit einigen tagen ebenfalls Besitzer eines solchen Pracht Computers (-:


    ich möchte den Pie als Owncloud (nur als Owncloud server) betreiben , bin aber mit dem PHP zauber völlig überfordert , ist jemand so gut und stellt mir seine funktionierende Pie Owncloud als image zur Verfügung , wäre sehr sehr sehr Dankbar


    Grüße an alle


    Geht so einfach nicht wirklich. Da man dirdie Zertifikate nicht überlassen möchte. Deine IP Adresse wird anders sein, etc.


    Nimm das HowTo ... so wie es da steht ... cut und paste ... cut und paste ... er hat nicht ausgelassen ...
    [hr]


    Vielen Dank für die Anleitung. Es funktioniert bei mir alles, allerdings bekomme ich, jedes mal wenn der Mac-Kalender Daten abruft die Fehlermeldung "Die Anfrage auf „https://192.168.178.21/owncloud/remote.php/caldav/principals/pollux/“ erzeugte einen Konflikt." Das ist sehr nervig, weil der Kalender sich so jedes mal in den Vordergrund bringt. Kennt jemand einen Weg, das abzustellen?


    Man sollte genaueres über den "konflikt" wissen.


    Hört sich so an als ob irgendwas mit den Kalender Daten nicht stimmt. Sind deine Einträge gleich im Kalender in der ownCloud und auf dem Mac Gerät? Beide in der gleichen Zeit Zone?


    Ich hab die 7er (Beta) genutzt und habe weder am Mac noch am iPhone Probleme mit dem Kalender.

    Auch meine ganz billigen Komponenten aus China laufen ... aber nach 4 Wochen auf hoher See hat mein 1602 Display wohl etwas an Kontrast verloren.

    Edited once, last by stranger26 ().

  • hey com,


    habe das tut bis punkt sieben durchgespielt ... lief alles ganz prima, soweit ich das beurteilen kann ...


    bei punkt 8 - neustart nginx - gab es dann folgende fehlermeldung:


    sudo /etc/init.d/nginx restart
    Restarting nginx: nginx: [emerg] SSL_CTX_use_certificate_chain_file("/etc/nginx/cert.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory error:20074002:BIO routines:FILE_CTRL:system lib error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib)
    nginx: configuration file /etc/nginx/nginx.conf test failed


    hat jemand ne idee ? vllt. sogar ne lösung !?


    danke euch
    gruß
    zugereister


    p.s.


    bei folgender anweisung im tut war ich mir etwas unsicher:


    An das Ende der Datei fügen wir nun noch folgendes an:
    Code: Alles markieren
    upload_tmp_dir = /srv/http/owncloud/data


    ich habe den code vor das


    ;End:


    gesetzt. Weil ich der Meinung bin, dass nach dem "End:" nix mehr passiert ?!

  • habe jetzt erst mal eine cloud mit seafile realisiert - mit tutorial hier aus dem forum


    vllt. lässt sich das problem mit der fehlermeldung doch noch mal lösen ...

  • Hallo Zusammen,


    ich hätte da ein Problem und würde mich echt freuen, wenn mir wer helfen kann.


    Ich habe nun OwnCloud 7.0.1 auf meinem Raspberry PI nach dieser Anleitung mit nginx installiert. Das hat soweit auch geklappt. Lokal (also mit http://LOKALE-IP/) komme ich inzwischen direkt auf die OnwCloud anmelde Seite.


    Ich habe einen DDNS Account bei AnyDNS.
    Dieser ist in der FritzBox eingerichtet und die Ports 80 und 443 sind direkt auf den PI weitergeleitet.


    Dennoch komme ich von aussen über die DDNS nicht auf meine OwnCloud. Ich komme einfach nicht mehr weiter und weiss nicht mehr was ich tun soll.


    Kann mir hier jemand bitte helfen?


    Hier mal meine Datei sudo nano /etc/nginx/sites-available/default:

    Edited once, last by nachon ().

  • Hat keiner eine Idee?


    Einen Hinweis noch:
    Ich habe OwnCloud auf RaspBMC installiert. Wie gesagt, lokal funktioniert es. Nur über die DDNS gar nicht.


    Leite ich die Ports an einen anderen WebServer im Netzwerk, komme ich mit der DDNS auch auf den entsprechenden WebServer. Leite ich die Ports wieder auf den PI geht nichts mehr.


    Irgendwo muss doch da noch etwas eingestellt werden? :s


    Habt erbarmen mit mir. Bitte. :danke_ATDE:




    [EDIT]:
    Habs hinbekommen, herzlichen Dank. Die Firewall auf dem PI musste noch angepasst werden. Wer hätte daran noch gedacht. Danke.

    Edited once, last by nachon ().

  • Könnt Ihr alle auch mit Eurem iOS Client von OwnCloud auf die OC zugreifen? Bei mir ist das das einzige, was noch nicht klappt.
    Alles andere läuft. Hat hier wer noch einen Tipp für mich? Ich wäre wirklich sehr dankbar.


    Bekomme nach Eingabe der URL immer die Meldung: "Authentifizierung mit Server nicht möglich".

    Edited once, last by nachon ().

  • Hey Hey,
    ist eine echt gute anleitung was nach etwas hin und her bei mir gefunzt hat aber ich habe ein problem. ich kann nicht auf den ordner zugreifen "/var/www/data/", ich habe dafür keine berechtigung. wie bekomm ich darauf zugriff?


    Zur info: owncloud liegt bei mir in der ordnerstruktur "/var/www/data/"

  • Hi,
    ich habe seit geraumer Zeit Probleme mit meiner Owncloud. Installiert ist owncloud 7.0.2, nginx und php.
    Als ich OC5 damals aufgespielt habe lief alles. Mit einem Update kamen vermutlich die Meldungen. Da ich nicht täglich Logs lese kann ich nicht sagen ab wann dies geschah.
    Was muss ich tun?


    Das äußert sich im Clienten wie folgt:

    Code
    12:33     pfad/zur/datei              Ordnername            Error downloading https://192.168.x.x/owncloud/remote.php/webdav/pfad/zur/datei - server replied: Internal Server Error


    Serverseitig:

    Code
    Error 	PHP 	Session has been closed - no further changes to the session as allowed at /var/www/owncloud/lib/private/session/memory.php#80 	2014-09-27T12:46:48+00:00
    Fatal 	remote 	An exception occurred while executing 'UPDATE "oc_filecache" SET "size"=? WHERE "fileid" = ?': SQLSTATE[HY000]: General error: 5 database is locked


    Der Fehler bremst den Pi ziemlich aus. Wenn ich die Sync mehrere Stunden laufen lasse wird dennoch alles geuploaded.


    Ich habe gemäß der Anleitung installiert. Um einen Fehler auszuschließen habe ich testweise auch raspbian neu aufgesetzt. Der Fehler besteht weiter.


    Code
    pi@raspberrypi ~ $ cat /var/log/nginx/error.log 
    2014/09/27 14:02:58 [error] 11721#0: *1 open() "/var/www404" failed (2: No such file or directory), client: 192.168.12.31, server: 192.168.x.x, request: "GET /owncloud/status.php HTTP/1.1", host: "192.168.x.x"
    2014/09/27 14:02:58 [error] 11721#0: *1 open() "/var/www404" failed (2: No such file or directory), client: 192.168.12.31, server: 192.168.x.x, request: "GET /owncloud/owncloud/status.php HTTP/1.1", host: "192.168.x.x"
    2014/09/27 14:21:55 [error] 2095#0: *8 access forbidden by rule, client: 192.168.x.x, server: 192.168.x.x, request: "GET /owncloud/data/htaccesstest.txt HTTP/1.0", host: "raspberry"
    2014/09/27 14:21:57 [error] 2097#0: *15 access forbidden by rule, client: 192.168.x.x, server: 192.168.x.x, request: "GET /owncloud/data/htaccesstest.txt HTTP/1.0", host: "raspberry"
    2014/09/27 14:22:15 [error] 2096#0: *17 access forbidden by rule, client: 192.168.x.x, server: 192.168.x.x, request: "GET /owncloud/data/htaccesstest.txt HTTP/1.0", host: "raspberry"
    2014/09/27 14:22:24 [error] 2095#0: *11 FastCGI sent in stderr: "PHP message: creating sqlite db" while reading response header from upstream, client: 192.168.12.31, server: 192.168.x.x, request: "POST /owncloud/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "raspberry"
    2014/09/27 14:23:33 [error] 2094#0: *82 access forbidden by rule, client: 192.168.x.x, server: 192.168.x.x, request: "GET /owncloud/data/htaccesstest.txt HTTP/1.0", host: "raspberry"
    2014/09/27 14:24:28 [error] 2096#0: *110 access forbidden by rule, client: 192.168.x.x, server: 192.168.x.x, request: "GET /owncloud/data/htaccesstest.txt HTTP/1.0", host: "raspberry"
    2014/09/27 14:30:30 [error] 2096#0: *343 access forbidden by rule, client: 192.168.x.x, server: 192.168.x.x, request: "GET /owncloud/data/htaccesstest.txt HTTP/1.0", host: "raspberry"


    Eine hta*.txt existiert nicht, nur eine .htaaccess (an der ich nichts verändert habe).


    Code
    pi@raspberrypi ~ $ uname -a
    Linux raspberrypi 3.12.28+ #709 PREEMPT Mon Sep 8 15:28:00 BST 2014 armv6l GNU/Linux



    Code
    pi@raspberrypi ~ $ dpkg -l | grep nginx
    ii  nginx                                 1.2.1-2.2+wheezy3                       all          small, powerful, scalable web/proxy server
    ii  nginx-common                          1.2.1-2.2+wheezy3                       all          small, powerful, scalable web/proxy server - common files
    ii  nginx-full                            1.2.1-2.2+wheezy3                       armhf        nginx web/proxy server (standard version)
  • Status: owncloud gemäss der Anleitung von ps915 aufgesetzt.


    Hat jemand mal versucht per davfs vom Linux auf den owncloud Server zu connecten? Ich bekomme immer einen 405. Das dafvs Log zeigt


    Was ich im Netz gefunden habe ist dass nginx wohl kein OPTIONS HTTP request kann - ausser man hat irgendwelche Plugins. Hat jemand einen Tip wo ich die finde bzw was man sonst machen muss um dafvs benutzen zu können?

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Es geht doch unter Linux :shy: Man muss nur den Owncloud Space etwas anders als bei anderen webdav Servern wie t-com oder 1&1 einbinden (Siehe z.B. hier). Ist auch hier dokumentiert.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Hallöchen,
    Erst einmal vielen Dank für diesen tollen Tutorial! Hat nach einigen Schwierigkeiten alles geklappt. Allerdings habe ich ein Problem, ich würde auf meine Owncloud gerne auch über das Internet zugreifen, das funktioniert jeden nicht. Über das lokale Netz ist das kein Problem.
    DynDns-Service ist eingerichtet.
    Portweiterleitung auf Port 80& 443 ebenfalls.
    Und virtueller Server ist ebenfalls im Router auf diese Ports eingestellt.


    Ich habe das halbe Internet durchforstet, aber alle möglichen Lösungen haben nicht funtioniert.:helpnew:
    Kann es an einer Firewall des Pi's liegen?


    Bin kompletter Neuling, wie man vielleicht merkt. :rolleyes:


    Vielen Dank im Voraus!


    MeRge:danke_ATDE:

  • Hallo,


    ich schließe mich mit der gleichen Frage an.
    Alles funktioniert soweit - nur eben nicht der Zugriff aus dem Internet.
    Wenn ich meine dns-Adresse eingebe, taucht von außerhalb des Heimnetzes nur auf: https://192.xxx.xxx.xx (also die IP-Adresse meines Servers im heimischen Netz). Dann tut sich (natürlich?) nichts mehr.


    Ich weiß, die Frage ist schon auf den letzten vierzehn Seiten vorgekommen :blush: - aber irgendwann schwirrte mein Kopf, und ehe ich jetzt plan- und ziellos rumprobiere.


    Allerdings: In meiner Fritzbox (7330 SL) ist die Portweiterleitung für port 80 auf die Adresse des Servers möglich, nicht aber eine port-Weiteleitung auf 443.


    Wo ist der Lösungsansatz? - Bei der nginx-Konfiguration, wo die IP-Adresse des Servers eingestellt ist oder bei der Box?


    lG
    Martin

  • Wenn du Port 443 auf der FRITZ Box weiterleiten willst musst du den Port von Myfritz ändern dann klappt es auch. Ich glaube Avm schlägt als Alternative dann den Port 40443 vor.

  • Prima - vielen Dank!


    Wahrscheinlich ist alles auch unterschiedlich bei verschiedenen Fritzbox-Versionen.
    In meiner 7330 SL habe ich die vorgeschlagene Lösung jetzt umgangen:
    Ich habe einfach eine My-Fritz-Freigabe für den Raspberry eingerichtet. - Das ist zwar eine recht kryptische Adresse, aber was soll's, ist ja auch nicht für jedermann bestimmt und kann ja in den clients gespeichert werden.


    Ich habe dann in der nginx - Config den Servernamen statt der IP-Adresse eingetragen und konnte dann auch aus dem Internet auf die Seite zugreifen.


    Dann hat erst mal die owncloud gemeckert, weil das eine "untrusted domain" sei.
    Konnte ich aber dann in der config.php von ownclod einfach eintragen - jetzt läuft alles ... ;)


    Danke alle Mitdenkern.
    Martin