SSH nur stabil mit ping

  • Moin,


    meine WLan Verbindung zum Raspberry ist nur stabil, wenn ich in einem zweiten Terminal Fenster den Ping Befehl laufen lasse. Ansonsten "schläft" die Verbindung ein und ich werde getrennt, oder muss lange warten, bis ich einen SSH Befehl absetzen, oder über Samba auf den Pi komme.


    Habe mal ethtool laufen lassen:


    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes: 100baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Speed: 10Mb/s
    Duplex: Half
    Port: MII
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbag
    Wake-on: d
    Current message level: 0x00000007 (7)
    drv probe link
    Link detected: no


    Kann sich da jemand n Reim drauf machen?


    Nachtrag: Ich greife über meinen Mac auf den Raspberry zu und öffne dort ein zweites Terminal Fenster und pinge den Raspi an.

    Edited once, last by fsk25 ().

  • Hallo fsk25,


    hast Du bei Deinem WLAN-Adapter den Auto-Sleep-Modus aktiviert?


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Ich konnte das Problem bei mir dauerhaft lösen, indem ich in PuTTY 15 Sekunden beim Keep Alive Signal eingestellt hab.

  • Hab's jetzt erstmal mit 'nem Ping alle 15 Sekunden gelöst. Nicht befriedigend, aber was anderes fällt mir nicht ein. Energiesparmodus des EDIMAX Wlan Sticks ist nicht aktiv. Die Fritzbox zeigt auch an, dass der Raspi verbunden ist. Er soll nur in Zukunft dauerhaft laufen, und ich will dann per SSH und Samba im laufenden Betrieb drauf zugreifen können. Das funktioniert halt zur Zeit noch nicht verlässlich.


  • meine WLan Verbindung zum Raspberry ist nur stabil, wenn ich in einem zweiten Terminal Fenster den Ping Befehl laufen lasse.


    Wenn es um die WLAN-Verbindung zwischen deiner FritzBox (Router) und deinem Pi geht, dann ist es doch nicht schön wenn Du auf einem dritten Gerät, permanent einen Ping zum Pi laufen lassen musst. Da gibt es evtl. andere/zusätzliche Möglichkeiten, die zwischen deiner FritzBox und deinem Pi, für eine stabile WLAN-Verbindung wirken/sorgen können
    Dass das PM des WLAN-Sticks auf off ist, hast Du ja schon geschrieben.
    Wie sind auf deinem Pi (ohne sudo bei apt-get da lediglich Trockenübung) die Ausgaben von:

    Code
    apt-cache policy arping iputils-arping
    ps -fC cron
    arp -av
    apt-get -s install arping


    ?

    The most popular websites without IPv6 in Germany.

    Edited once, last by rpi444 ().

  • Gib uns mal deine Ausgabe von "iwconfig".
    Interessant ist vor allem folgende Zeile des wlan-Adapters:

    Code
    Power Management:off


    Deaktivieren kannst du das Power Management dann mit folgendem Befehl (als root):

    Code
    iwconfig wlan0 power off


    Oder als User mit "sudo":

    Code
    sudo iwconfig wlan0 power off

    .

    Linux - Für das Leben nach dem Absturz!

  • So, hier die Ausgaben der Befehle:


    rpi444


    arping:
    Installiert: (keine)
    Installationskandidat: 2.11-1
    Versionstabelle:
    2.11-1 0
    500 http://mirrordirector.raspbian.org/raspbian/ wheezy/main armhf Packages
    iputils-arping:
    Installiert: (keine)
    Installationskandidat: 3:20101006-1
    Versionstabelle:
    3:20101006-1 0
    500 http://mirrordirector.raspbian.org/raspbian/ wheezy/main armhf Packages


    UID PID PPID C STIME TTY TIME CMD
    root 2212 1 0 18:08 ? 00:00:00 /usr/sbin/cron


    Martins-MBP.fritz.box (192.168.178.20) auf f8:1e:df:da:fc:ab [ether] auf wlan0
    fritz.box (192.168.178.1) auf 9c:c7:a6:6b:60:85 [ether] auf wlan0
    Einträge: 2 Ignoriert: 0 Gefunden: 2


    HINWEIS: Dies ist nur eine Simulation!
    apt-get benötigt root-Privilegien für die reale Ausführung.
    Behalten Sie ebenfalls in Hinterkopf, dass die Sperren deaktiviert
    sind, verlassen Sie sich also bezüglich des reellen aktuellen
    Status der Sperre nicht darauf!
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
    libopts25
    Verwenden Sie »apt-get autoremove«, um es zu entfernen.
    Die folgenden zusätzlichen Pakete werden installiert:
    libnet1 libpcap0.8
    Die folgenden NEUEN Pakete werden installiert:
    arping libnet1 libpcap0.8
    0 aktualisiert, 3 neu installiert, 0 zu entfernen und 4 nicht aktualisiert.
    Inst libpcap0.8 (1.3.0-1 Raspbian:7.0/oldstable [armhf])
    Inst libnet1 (1.1.4-2.1 Raspbian:7.0/oldstable [armhf])
    Inst arping (2.11-1 Raspbian:7.0/oldstable [armhf])
    Conf libpcap0.8 (1.3.0-1 Raspbian:7.0/oldstable [armhf])
    Conf libnet1 (1.1.4-2.1 Raspbian:7.0/oldstable [armhf])
    Conf arping (2.11-1 Raspbian:7.0/oldstable [armhf])


    @Nightskil


    wlan0 IEEE 802.11bgn ESSID:"FRITZ!Box Fon WLAN 7360 SL" Nickname:"<WIFI@REALTEK>"
    Mode:Managed Frequency:2.412 GHz Access Point: 9C:C7:A6:6B:60:87
    Bit Rate:72.2 Mb/s Sensitivity:0/0
    Retry:off RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=100/100 Signal level=63/100 Noise level=0/100
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    lo no wireless extensions.


    eth0 no wireless extensions.

  • sudo nano /etc/modprobe.d/8192cu.conf

    Code
    # Disable power management
    options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

    Offizieller Schmier und Schmutzfink des Forum.
    Warum einfach wenn's auch schwer geht ?


    Kein Support per PN !
    Fragen bitte hier im Forum stellen. So hat jeder etwas davon.

  • Aber iwconfig sagt doch:


    Power Management:off


    Daher denke ich, dass das Power Management ausgeschaltet ist.


    Habe die Datei mal erstellt, gabs nämlich nicht. Mal sehen ob es was bringt.


    EDIT: Erster Eindruck ist stabiler. Verstehe zwar nicht ganz warum, aber Hauptsache es läuft.


    Was hat das mit dem arping auf sich?

    Edited once, last by fsk25 ().


  • Was hat das mit dem arping auf sich?


    arping ist ein Netzwerktool, das man ähnlich wie ping nutzen bzw. einsetzen kann.

    The most popular websites without IPv6 in Germany.