Tastaturproblem

  • Hallo,
    ich bin Neuling und habe jetzt folgendes Problem:
    Bei meinem RPi B+ V1.2 kann ich im LXTerminal über die Tastatur keine Sonderzeichen eingeben. Z.B. kommt bei / das & usw.
    Alle Buchstaben und Zahlen funktionieren...
    Muss ich etwas umschalten ?
    Vielen Dank für die Hilfe
    Peter

  • Du musst das Tastaturlayout ändern:
    sudo raspi-config
    Für "-" drück auf ß
    Dann mit den Pfeiltasten auf "configure_keyboard" gehen und Enter drücken.
    Dort lass dann den aktuellen Eintrag und drück auf Enter. Jetzt musst du German oder ähnlich bzw. QWERTZ auswählen und auf Enter drücken.

    Es gibt KEINE dummen Fragen!

  • Hallo,
    vielen Dank für die Antwort. Ich habe das Menü gefunden, allerdings ist meine Tastatur in der Auswahl nicht dabei.
    Ich habe eine "Lenovo SK8825". Einige andere habe ich probiert, geht nicht.
    Momentan stehe ich im Aus...
    Peter

  • Hallo Peter,


    es geht nicht um die Tastatur-Auswahl, sondern um die Definition, dass Du ein deutsches Tastatur-Layout einzusetzen gedenkst.


    Dazu musst Du nach Eingabe von

    Code
    sudo raspi-config


    den Menüpunkt "Internationalisation Options" auswählen, dort innerhalb von "Change Locale" alle Einträge mit de_DE... aktivieren, im anschließenden Fenster den Eintrag "de_DE@euro" auswählen.


    Der Raspberry Pi rödelt danach ein wenig.


    Anschließend wählst Du wieder den Menüpunkt "Internationalisation Options" aus und gehst dieses Mal auf "Change Keyboard Layout".


    Dort wählst Du eine Tastatur aus, die der Deinen möglichst nahe kommt (Anzahl der Tasten). Mit "Generische PC-Tastatur mit 105 Tasten (Intl)" hast Du einen guten Anfang gesetzt.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hallo Andreas,
    erstmal vielen Dank für die wertvollen Hinweise.
    Ich habe alles auf DE umgestellt, funktioniert auch.
    Allerdings weigert sich der Pi immer noch die Tastatur anzunehmen...
    Ich habe es bestimmt mit ca. 10 Tastaturen probiert, kein Erfolg.
    Jetzt habe ich den Kanal voll und mir eine Logitech Cordless Tastatur über ebay (für wenig Geld) bestellt die in der Liste vorhanden ist.
    Ich denke damit dürfte es dann funktionieren.
    Alsdann vielen Dank, Peter