Bridge: FritzBox - WLAN - Pi - eth0 - Endgerät -> Verbindung bricht ab

  • Ich komme leider erst wieder heute Abend dazu, Deine Ratschläge zu testen.
    Habe mir die Punkte mal angeschaut,


    Was ich noch erwähnen wollte, Du hattest ja mal geschrieben, dass Dir der Befehl "-b br0" in der Interfaces-Datei mit entsprechendem Syntax nicht bekannt wäre.


    Ich habe allerdings folgendes gefunden: "wpa-bridge br0" (siehe hier)
    Wie gesagt, nur noch nicht probiert.


    Schade, dass Du es mit WLAN nicht testen kannst...
    kann wohl noch ein paar Tage dauern, bis wir hier zu dem gewollten Ergebnis kommen.


    Nochmal zur IP-Vergabe:
    Wenn ich den Raspi z.B. einem Bekannten gebe, (was vermutlich auch passieren wird,) der ein anderes Netz hat, funktioniert es ohne neue Konfiguration nicht. Daher bekomme ich die IP-Vergabe per DHCP nicht aus dem Kopf.
    Da muss es doch eine Möglichkeit zu geben, wie es auch mit DHCP funktioniert...

    Edited once, last by TRiViUM ().


  • Was ich noch erwähnen wollte, Du hattest ja mal geschrieben, dass Dir der Befehl "-b br0" in der Interfaces-Datei mit entsprechendem Syntax nicht bekannt wäre.


    Ich habe allerdings folgendes gefunden: "wpa-bridge br0" (siehe hier)
    Wie gesagt, nur noch nicht probiert.


    Ja, das hatte ich schon vermutet und auch gesehen. Ob es mit "wpa-bridge" funktioniert muss man testen/probieren.



    Nochmal zur IP-Vergabe:
    Wenn ich den Raspi z.B. einem Bekannten gebe, (was vermutlich auch passieren wird,) der ein anderes Netz hat, funktioniert es ohne neue Konfiguration nicht. Daher bekomme ich die IP-Vergabe per DHCP nicht aus dem Kopf.
    Da muss es doch eine Möglichkeit zu geben, wie es auch mit DHCP funktioniert...


    Evtl. funktioniert es ja auch mit dhcp, wenn man das "sauber" konfiguriert. Du nutzt ja z. Zt. auch noch den NetworkManager und damit habe ich keine gute Erfahrungen, was die Interaktion/Zusammenarbeit des NM mit der interfaces-Datei und den gegen dbus gelinkten wpa_supplicant betrifft. Evtl. nachdenken, ob Du auf den NM (GUI) verzichten kannst und die Konfiguration des Netzwerkes auf dem PI, rein text-basiert (ohne NM) machen kannst/willst. Mit dhcp habe ich auch nicht die (große) Erfahrung, da ich nur statische IP-Adressen (... nicht per dhcp zugewiesen) nutze.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • So, da bin ich wieder.
    Hatte es gestern leider nicht mehr geschafft.
    Schau mal bitte, was ich hier gefunden habe, bevor ich wir uns hier noch weiter Mühe geben, und es am Ende dann doch nicht auf diesen Wegen funktioniert....
    Muss man da also mit hostapd arbeiten?


  • Schau mal bitte, was ich hier gefunden habe, bevor ich wir uns hier noch weiter Mühe geben, und es am Ende dann doch nicht auf diesen Wegen funktioniert....


    Lt. Titel des Threads soll es aber keine Bridge in ein WLAN sein, sondern vom WLAN zum LAN (eth).

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden


  • Lt. Titel des Threads soll es aber keine Bridge in ein WLAN sein, sondern vom WLAN zum LAN (eth).


    Stimmt, allerdings dachte ich, es sei vom Prinzip das selbe.


    Aber du hast Recht:
    Ich will vom Pi-LAN in mein vorhandenes WLAN brücken.


    EDIT:
    Ich hatte aber schon einen Thread dafür geöffnet, siehe hier.


    EDIT2: LÖSUNG
    Um dem Spuk ein Ende zu setzen, ich habe eine Lösung gefunden!
    Letztendlich hab ich mir ein altes Image geschnappt, welches den Kernel 3.6.11+ besitzt (Kernels mit neueren Versionen besitzen diese Funktion leider nicht mehr).


    In meinem Falle habe ich dieses Image (2013-02-09-wheezy-raspbian) benutzt.


    Falls kein LAN-Gerät am Pi angeschlossen ist, verbindet er sich wie gewohnt ganz normal mit dem WLAN.
    Sobald man dann ein LAN-Gerät am Pi anschließt, bekommt dieses per DHCP eine IP vom Router.


    Wichtig:
    Es darf kein apt-get update/ upgrade aufgerufen werden, da sonst der Kernel aktualisiert wird und die Bridge-Funktion im neuen Kernel deaktiviert wurde.


    Benötigt:
    sudo apt-get install bridge-utils


    Meine Interfaces-Datei:

    Edited once, last by TRiViUM ().

  • Stimmt, allerdings dachte ich, es sei vom Prinzip das selbe.


    Hallo zusammen,


    bin gerade neu hier und wärme das noch mal auf. Ich bekomme das auch nicht stabil hin, Raspi 3 B mit jessie als Access Point. Die Netzwerkschnittstellen fallen irgendwann auf die Nase. Läuft ein paar Stunden und dann ist das Netzwerk platt.


    Bin nach folgender Anleitung vorgegangen:


    ELKO WLan-Access-Point


    Schade eigentlich. Netzteil hat 2,5A aus Raspi-Bundle und Powerbank von Anker mit 3A, 20000mA und Messgerät dazwischen hab ich auch schon probiert. Wird daran kaum liegen.


    Hat sich noch jemand mal an sowas versucht und ähnliche Erfahrung?


    Viele Grüße.


    Andreas (prinzunix)


  • bin gerade neu hier und wärme das noch mal auf. Ich bekomme das auch nicht stabil hin, Raspi 3 B mit jessie als Access Point. Die Netzwerkschnittstellen fallen irgendwann auf die Nase. Läuft ein paar Stunden und dann ist das Netzwerk platt.


    Kannst Du Dich ein wenig konkreter äußern, was Du mit den letzten beiden Sätzen meist.


    Verwendest Du den internen WLAN-Adapter? Funktioniert es mit einem externen WLAN-Adapter?