XBMC und Kodi starten regelmäßig ohne Internetverbindung zu finden

  • Hallo,
    ich habe bis vor paar Tagen das XBMC aufm Raspi 1 und aktuell Kodi auf dem Raspi 2 genutzt. Ich habe bei beiden Raspis das Problem, wenn ich den Raspi starte, er 01.Jan 1970 startet und keine Internetverbindung hat. Dann starte ich den Raspi neu, manchmal klappt es dann mit dem Internet sofort bzw ich musste auch schon 10mal neu starten bis es klappte.
    Wie gesagt hatte ich das Problem bei XBMC und Kodi.
    Hat Jemand ne Idee???


    Gruß

  • Hallo Bachspautzer,


    kannst Du etwas über die technischen Daten Deines Netzteils berichten sowie Aussagen machen, welchen Strom Dein W-LAN-Stick zieht?


    Denn Deine Schilderungen deuten sehr daraufhin, dass hier ein Phänomen auftritt, dass wir hier "Mysterium" genannt haben. Aber ohne genaue Daten zu haben, will ich mich da noch zurückhalten.



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hallo,
    ich habe die zwei Links von PiBorg noch nicht gelesen, ich wollte erst antworten.
    Die beiden Pi's waren jeweils mit nem eigenen Netzteil angebunden. Der Pi1 damals mit nem Netzteil 1,2 A von einem Huawei Handy, der Pi2 mit nem 2 A Netzteil von Amazon, dass für den Pi getestet wurde.
    Die Pi's waren immer per LAN Kabel an die Fritzbox angeschlossen und ich hatte beim Pi2 gestern die Wartezeit auf Internet beim Start auf bis zu 30s hochgesetzt, jedoch ohne Erfolg. Heute morgen hab ich den Pi bzw Kodi gestartet und er hatte sofort Internetverbindung.


    Gruß

  • Hallo Bachspautzer,


    die sog. Handyladekabel sind die denkbar ungeeignetsten Einrichtungen, um einen Raspberry Pi mit einer ausreichenden Meng an Strom zu versorgen.


    Beim Laden von Akkus ist weder die Fähigkeit, eine Spannung konstant zu halten, noch einen Mindeststrom konstant fließen lassen zu müssen entscheidend. So ist es für ein Ladekabel in Ordnung, bei höherer Stromstärke (anfängliches Akku-Laden) die Spannung auf 4,5 V oder was auch immer abfallen zu lassen.


    Beides ist aber für den Betrieb eines Raspberry Pi von ganz entscheidender Bedeutung. Der Raspberry Pi ist darauf angewiesen, dass die Spannung zwischen 4,75 V und 5,25 V aufrecht erhalten bleibt - bei jedem Strom, der für den Betrieb erforderlich ist.
    Der Strom selber variiert in Abhängigkeit der Peripherie, die noch angeschlossen ist. Hier vergisst man ganz gern, dass z.B. HDMI, Tastatur, Maus auch Strom benötigen. Jedes USB-Teil, dass direkt in die USB-Buchsen des Raspberry Pi eingesteckt wird, kann - muss aber nicht - den RPi in die Knie zwingen. Mal wird der Bildschirm kurz schwarz, berappelt sich aber wieder, mal scheint die Maus oder die Tastatur zu "hängen". Dahinter verbirgt sich ein Deaktivieren von USB-Geräten, was man in den LogFiles verfolgen kann.


    Die Deaktivierung erfolgt aus dem GRund, den "Rest" mit Strom versorgen zu können. Stellt der Raspberry Pi fest, dass jetzt doch wieder ausreichend Strom bereit steht, dann werden die USB-Geräte wieder reaktiviert. Auch dies wird in den LogFiles gemeldet.


    Da USB und LAN über den gleichen Baustein (LAN951x) realisiert werden, zieht dies auch die LAN- / WLAN-Verbindung mit hinunter.


    Im Gegensatz zu USB-Peripherie wird LAN/WLAN nicht automatisch reaktiviert. Dies muss der Anwender selber machen oder über einen Workaround im Fall des Falles LAN/WLAN reaktivieren.


    Dies haben wir in diesem Forum als "Mysterium" bezeichnet. Nachdem die von Dir geschilderten Symptome in diese Richtung gehen, ist die Wahrscheinlichkeit recht groß, dass Deine Stromversorgung in Form eines Handyladekabels zu schwach ist.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hey,
    das Problem hat sich seit dem Update auf Isengard erledigt. Seitdem klappt die Internetverbindung auf Anhieb.


    Gruß