AirPlay mit dem Raspberry Pi - Shairport Installation

  • Hallo zusammen, ich hab ne Frage die vermutlich nur bedingt mit dem Pi zu tun hat, aber vielleicht wisst ihr was :)


    Ich hab' die letzte Version von shairport installiert, die ja nicht mehr auf Perl aufsetzt. Auf meinem Mac funktioniert die Wiedergabe über AirPlay auch (iTunes), auf meinen iDevices kann ich aber nur bei Videos (bspw. in der YouTube-App) auf AirPlay umschalten!


    Der Musik-Player bietet mir das AirPlay-Icon penetrant nicht an (wie gesagt: in Youtube auf dem gleichen Gerät ist es da und funktioniert).


    Irgend ne Idee? Geht das mit iOS 7 nicht mehr? Brauche ich nen anderen Player für Musik? Gibt's ein Setting bei shairport?


    Bin verwirrt.

  • Nevermind - hab's gefunden.


    Apple hat das Airplay-Logo bei iOS 7 für das "ganze System" im System-Slider zum hochschieben versteckt, damit es ja niemand findet. :X


    Daher wird's in der Musik-App dann nicht speziell angezeigt.

  • Kämpfe jetzt den zweiten Abend mit der Installation.
    Während der Installation habe ich keine Fehlermeldung gesehen. Mit Shairport start bekomme ich die Meldung: Buffer should be >30 and <512. Nur, wo stelle ich das ein?
    Für jede Hilfe dankbar.

  • Hallo,


    das Tutorial ist super! bei mir hat es mit den Tipps auf der ersten Seite im zweiten Anlauf geklappt.


    Ich habe eine Frage:


    wo und wie lege ich fest in welchem Netzwerk shairport läuft?


    mein Raspi ist mit zwei Netzwerken via Lan und WLan verbunden.


    vielen Dank!

  • Der Post von ps915 war top!


    ich versuche es seit 2 Tagen zum fliegen zu bekommen und was mir gefehlt hat, war scheinbar nur


    Code
    wget http://www.forum-raspberrypi.de/mydownloads/downloads/shairport_0.05-1_armhf.deb
    sudo dpkg -i shairport_0.05-1_armhf.deb


    Aber sonst auch, super Tutorial, Danke!


    Gruß

  • Hi, nach jedem Neustadts meines Pi´s muss ich folgendes wieder neu ausführen bevor mein iPhone den Pi im Netzwerk findet:


    sudo dpkg -i shairport_0.05-1_armhf.deb


    Wie kann das sein?! Und wie kann ich das lösen?

  • Hallo zusammen,


    ich habe Sehairport auch erfolgreich Installiert und benutze es täglich.
    Nur leider nervt mich das ich jeden morgen den Dienst neustarten muss. :wallbash:


    Code
    service shairport restart


    Woran kann das liegen? :helpnew: :helpnew: :helpnew:
    Wie könnte man auf nicht schöne Art u Weise den Dienst täglich um 3 Uhr neustarten?


    :danke_ATDE:

  • Es ist nicht normal das etwas crasht. Man sollte mögliche Probleme lieber lösen anstatt sie zu ignorieren... Du scheinst da auf jeden Fall ein Problem zu haben.


    Prüfe mal die Logdateien /var/log/shairport.err oder /var/log/shairport.log oder /var/log/syslog



    //EDIT: Eine kleine Anmerkung zu dieser Anleitung:


    Die Anleitung ist von 2012. Mittlerweile gibt es aber eine weitaus aktuellere shairport-sync Version. Am besten ihr ladet euch die derzeit aktuelle Stable über github herunter. Siehe dazu "General Build Instructions" --> https://github.com/mikebrady/s…c#building-and-installing

  • Ich weiß nicht ob das hier schon erwähnt wurde aber mittlerweile ist es sehr einfach einen AirPlay Sharepoint auf dem Raspberry zu erstellen. Wenn man sich z.B. Volumio installiert wird Airplay automatisch mitinstalliert und aktiviert und man hat noch viele weitere Möglichkeiten damit. :thumbs1:


    Ich habe hier mal eine genaue Anleitung dafür erstellt.


    http://powerpi.de/high-end-mus…raspberry-pi-2-anleitung/

  • Hallo

    Ich bin Gundolf und neu hier, dann erstmals ein Gruß an alle hier.


    Thema hat sich erledigt, ich habe Shairport-sync installiert, Airplay läuft..


    Vielen Dank bis später

    Gruß Gundolf

    Edited 4 times, last by GundolfW ().

  • Hallo,

    auf den 1. Blick mußt Du nichts ändern. (Aber ich bin kein Shairport-Experte)


    Aber, weil Du dieses Skript direkt in Deinen Beitrag eingefügt hast, ist es verstümmelt (Smileys).

    Das kannst Du ändern.

    1. Bearbeite Deinen Beitrag mit Button Bearbeiten und wähle Beitrag bearbeiten aus.
    2. Klicke in der schwarzen Leiste auf das </>-Symbol (=Code-Block)
      Im Code-Block eingefügte Skripte/Code/etc. werden unverändert und mit führenden Leerzeichen dargestellt.

    Schönen Gruß, kle