AirPlay mit dem Raspberry Pi - Shairport Installation

  • Erstmal Danke für die gute und ausführliche Beschreibung.


    Hat alles gut funktioniert,.... bis auf die kleine Tatsache, dass kein Ton rauskommt!!!


    Auswahl => 1 - headphones


    Was mir noch aufgefallen ist...
    Beim Booten wird folgendes angezeigt:
    [warn] PulseAudio configured for per-user sessions ... (warning).


    Bin grad etwas ratlos.

    Don´t touch this ...

    Edited once, last by RFID-FREAK ().

  • Hallo,


    ich bin jetzt schon seit Stunden auf der Suche nach einer Alternative des überteuerten AppleTVs gewesen. Jetzt endlich bin ich hier auf diesen Thread gestoßen.


    Obwohl ich schon von dem RPi gehört hatte, besitze ich bis jetzt noch keinen. Bevor ich mir so einen jetzt kaufe, hätte ich noch ein paar Fragen zu dem Shairport-Programm.


    Und zwar würde ich gerne vom iPad Filme von LOVEFiLM - Amazon Unternehmen (über die Video on Demand-Funktion) auf meinen Samsung Smart TV streamen.
    Würde das auch mit Videos über HDMI mit guter Soundqualität funktionieren, oder wäre man noch für ein angenehmes Filmerlebnis dazu gezwungen, weitere Hardware (Soundkarte) zu besorgen?


    Ich bin zwar Schüler an einem IT-Gymnasium, jedoch habe ich mich bis jetzt noch nicht mit Linux oder Ähnlichem beschäftigt... :-/ Gibt es hier im Forum ein Thema, wo Einsteigern erklärt wird, wie man ein RPi zum laufen bringt? (Also so weit, dass ich das anwenden kann, was hier im Thema erklärt wird)



    Ich hoffe mir weiß einer zu helfen :D

  • Vielleicht als kleine Ergänzung:


    Wer wie ich eine externe Soundkarte via USB nutzt und beim "Umschalten" von interner zu externer Soundkarte ein paar Schwierigkeiten hat!!


    Folgendes habe ich umgestellt:


    sudo nano /etc/modprobe.d/alsa-base.conf


    Alt:
    #Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=-2



    [font="Helvetica Neue, Helvetica, Arial, sans-serif"]Ändern in:[/font]
    #Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=0


    [font="Helvetica Neue, Helvetica, Arial, sans-serif"]Und schon klappt es :)[/font]

    Don´t touch this ...

    Edited once, last by RFID-FREAK ().

  • habe alles nach der aktuellen Anleitung gemacht, kann aber nicht von meinem iPad 2 (iOS 6) auf den Raspberry zugreifen. Beide sind im gleichen WLAN, nur sehe ich das AirPlay-Symbol nicht..


    Achja: Habe die ganze Installation und Konfiguration über SSH gemacht, falls das interessant und relevant ist.

  • Ich hab auf einem Raspbian Image alle Schritte der anleitung befolgt, ohne Erfolg. Einzige Abweichung: Ich hab statt eines "make install" vorher checkinstall installiert, und mir damit ein .deb Paket von shairport gebaut.
    Dieses Paket mittels dpkg -i installiert, config angepasst, gestartet - Raspberry taucht im Netzwerk nicht auf, weder auf iOS6 Geräten noch auf OS X 10.8 (im Gegensatz zum AppleTV und AirServer im gleichen Netz).


    Danach hab ich die SDP-Geschichte wieder deinstalliert (dpkg -r) und mittels CPAN die Perl-SDP-Module installiert:


    Anschließend hab ich shairport mal auf der Kommandozeile gestartet:

    Code
    pi@raspberrypi ~/shairport $ /usr/local/bin/shairport.pl -a RaspberryPi
    Eingerichtet unter dem Namen 'E941AB0A40B3@RaspberryPi'


    Keine Fehlermeldung, aber im Netz noch immer unsichtbar.


    Woher kommt denn eigentlich der komische Name, den es beim Start meldet?:huh:


    Bin für jeden Hinweis der irgendwie voranhilft dankbar!


    Ach ja: Frohes Neues Jahr!
    Marek

  • Guten Tag,


    ich habe nun alles Installiert und eingestellt wie es beschrieben wurden. Auf meinem PI habe ich das BS Debian installiert und nun möchte ich dann von meinem Leptop aus die Musik aus Steuern allerdings ist auf meinem Leptop das BS Win7 installiert. Ich kann unter ITunes die Lautsprecher nicht auswählen. Liegt das jetzt weil ich Win7 benutzen oder übersehe ich da eine kleinigkeit

  • bei mir hat auch alles einwandfrei funktioniert, trotz absoluter ahnungslosigkeit. allerdings kommt der don nur über die hdmi ausgabe. auch wenn ich den audioausgang auf 0 oder 1 stelle. lade mir grade den alsamixer runter in der hofnung den auchgang da per gui umzustellen. der soundtest wie hier http://elinux.org/R-Pi_Trouble…C_or_in_some_applications beschrieben fällt allerdings positiv aus. habe probiert dateien vom usb stick als auch über airplay abzuspielen.
    bitte um hilfe, die standartantworten bei google haben mich kein stück weiter gebracht..

    Edited once, last by greySwan ().

  • Hallo,


    Airplay funktioniert bei mir prima (auch wirklich Air, da meine WLAN Karte jetzt auch funktioniert ;)


    Eine Frage noch, ich möchte an das Raspberry ein kleines Display anschließen und dort den aktuell gespielten Song anzeigen.


    Das mit dem Display ist nicht so ein großes Problem, nur woher bekomme ich die Information, welches Lied gespielt wird. Ein Log finde ich vom Shairport nicht


    Hat jemand eine Idee?


    Danke
    Zuppir99

  • Ich habe nur eine kleine frage :-). Hat jemand schon eine App für Android gefunden mit der man wie bei ITunes seinen RaspberryPI auswählen und dann darüber Musik laufen lassen kann ?

  • Hallo,


    ich hatte es vor einigen Tagen auf meinem neusten wheezy installiert. Bei der Installation lief auch alles i.O. und hatte mich schon gefreut, dass es funktionierte.


    Nun 2 Tage später (und ich weiß nicht was ich zwischendurch noch gemacht habe) funktioniert es nicht mehr. Der WLan Stick flackert wenn ich es via iPhone mache, also gehe ich davon aus das der Empfang noch da ist. Merkwürdig ist nur, dass er vom Mac aus zwar noch den "AirPi" anwählen kann, aber nachdem ich auf Play drücke, direkt wieder aufhört.
    *edit* Jetzt geht es auch über den Mac (habe bei AudioMidi-Geräte den Airplay auswählen müssen).


    Den Sound Ausgang habe ich via,..., getestet und funktioniert:



    pi@raspberrypi /opt/vc/src/hello_pi $ cd hello_audio
    pi@raspberrypi /opt/vc/src/hello_pi/hello_audio $ ./hello_audio.bin
    Outputting audio to analogue
    pi@raspberrypi /opt/vc/src/hello_pi/hello_audio $ ./hello_audio.bin 1
    Outputting audio to hdmi
    pi@raspberrypi /opt/vc/src/hello_pi/hello_audio $ ./hello_audio.bin 1
    Outputting audio to hdmi


    Hat jemand Vorschläge woran es liegen kann oder was ich noch testen könnte?


    Vielen Danke!

    Edited once, last by Schw3n ().

  • Quote from cmeckler pid=6086 dateline=1361188283


    Ist das eigentlich das selbe Tool welches in der XMBC Umgebung verwendet wird?


    seit Raspbmc 1.0 ist es standardmäßig integriert, muss nur in den Einstellungen aktiviert werden
    es funktioniert sogar Videos vom iPhone auf den Raspberry zu streamen wie bei einem Apple TV :)

    Edited once, last by 4fox ().

  • Hi Leute,
    ich habe bis jetzt noch keine RPi.
    Ich will bei mir zuhause im Gartenhaus die Stereoanlage mit mit meinem Android - Smartphone betreiben. Bis jetzt stöpsel ich mein Handy beim Aux Eingang der Stereo an.
    Wenn das mit AirPlay funktionieren würde wäre schon ziemlich cool. ich denke auch an einen Monitor, welcher den aktuellen titel anzeigt oder evtl bei Youtube das Video....


    Soweit so gut. Nur welche Hardware muss ich mir dafür besorgen?
    Naja ansonsten bin ich ein ziemlicher Laie bei den Programmiergeschichten... Habe jedoch kein Problem damit mich einzuarbeiten. Vielleicht gibts da auch ein gutes Buch zum einlesen.


    ich bedank mich schonmal im Voraus


    Gruß Pasi


    Achja, das ganze will ich über wlan machen

    Edited once, last by Pasi1001 ().



  • Hi,
    das mit dem Namen interessiert mich aktuell brennend. Es ist bei mir weder die MAC-Adresse des eth0, noch die des wlan0. Aber eine Art Hardwareadresse ist es schon. Nur woher nimmt er sich die (ist immer gleich, unabhängig von Systemneustart o.Ä.) und wie kann man diese auf bspw. die MAC-Adresse des wlan0-Adapters anpassen, damit es so aussieht *wlan0MACAddress*@MeinShairPortName ?


    Viele Grüße, Flash

  • Hallo zusammen,


    habe ein merkwürdiges Problem mit Shairport: Es funtioniert Super, solange das Netzwerkkabel steckt.
    Starte ich den Pi ohne Netzwerk finde ich kein Airplay Gerät mehr!
    Das Problem habe ich unter whezzy und xbian. Habe ich etwas übersehen?

    • Official Post

    Wenn der Raspberry Pi von Netzwerk getrennt ist, kann er auch nichts finden, denn der Raspberry Pi muss im Lokalen Netzwerk sein. Oder meinst du Wifi?

    Well in my humble opinion, of course without offending anyone who thinks differently from my point of view, but also by looking into this matter in a different way and without fighting and by trying to make it clear and by considering each and every one's opinion, I honestly believe that I completely forgot what I was going to say.

  • Danke, jetzt hab ich den Denkfehler gefunden :)
    Ich darf nicht über das Netzwerk gehen sondern muss aus dem pi einen access point machen um ihn direkt anzusprechen.
    Das scheint ja nicht mit jedem USB-Dongle zu gehen. Gibt es da eine Übersicht?
    Hätte einen Asus N13 und einen Edimax EW-7811UN da. Beide funktionieren, aber welcher unterstützt den ap modus?

  • Hallo sinneslöschen,


    steck den WLAN-Adapter an deinen Raspberry Pi und ruf den folgenden Befehl auf.


    Code
    iw list


    In der Ausgabe solltest du den folgenden Abschnitt vorfinden, in welchem ein "AP" stehen muss. Ist dies der Fall unterstützt der WLAN-Adapter den Access Point Modus.


    Code
    Supported interface modes:
                     * IBSS
                     * managed
                     * AP
                     * AP/VLAN
                     * WDS
                     * monitor
                     * mesh point


    Sollte "iw" noch nicht installiert sein kannst du das mit folgendem Befehl nachholen.


    Code
    sudo apt-get install iw


    Gruß Georg