Apache mehrere IP's ?

  • Hallo,


    Habe in den letzten 2 Tagen 4 Raspi's mit wheeze und Apache 2 aufgesetzt.


    Die lokalen statischen LAN IP's sind:


    192.168.200.110
    192.168.200.115
    192.168.200.120
    192.168.200.140


    Alle Port 80.


    In der Fritzbox ist mir aufgefallen, dass ich noch zwei weitere IP's im Netz habe, die von zwei der vier Raspi's stammen.
    192.168.200.12 und 192.168.200.15 Ip's, die in meinem DHCP Bereich liegen.


    Weis jemand, wie das kommen kann und wie ich die "Geister IP's" los werde.


    Die Raspi's sind nur über LAN Kabel verbunden. Kein WLAN angeschlossen.


    Vielen Dank

    Edited once, last by rmjspa ().

  • Sind die IP's denn pingbar?


    Falls nein, sind das Überreste der Installation, nach der erstmal DHCP aktiv ist.
    Falls ja, finde raus von welchen Raspis die IP's stammen ("nslookup" oder auf dem Raspi selbst mit "ifconfig"). Wenn das geschehen, gibst du uns die Netzwerk-Config der betroffenen Raspis.


    PS: Es spricht nichts dagegen, dass du an einem Netzwerk-Interface mehrere IP's gebunden haben kannst.

    Linux - Für das Leben nach dem Absturz!

    Edited once, last by Nightskill ().

  • Die Leasetime der FB ist sehr lange, normalerweise verschwinden dieI Ps irgendwann. Ein Aktualisieren hilft aber nicht. Du müsstest die IP löschen, wenn sie sofort weg soll.


    Keine Sorge, dass ich hier die IPs offen zeige, Bereich und IPs sind von der letzten Gamesession, wird sowieso immer neu aufgesetzt!

  • Ja, die pseudo IP's sind pingbar.


    Im Browser kommt man auf die Startseite des Apache.


    Sie sind nicht mit Ifconfig sichtbar.


    Die Raspi's haben eine feste IP mit:


    sudo nano /etc/network/interfaces


    iface eth0 inet static
    address 192.168.200.120
    netmask 255.255.255.0
    gateway 192.168.200.1


    sudo /etc/init.d/networking restart


    Was ich geschrieben habe mit der Fritzbox stimmt nicht ganz. Mir ist es vor allem aufgefallen durch einen Ping fest des Heimnetzwerkes.


    Ich muss noch sagen, das neben dem Apache eine Redis Datenbank / Server installiert ist. Ferner hatte ich vorher nicht das aktuellste wheeze Image vom 05.05.2015.


    Irgendetwas, der Apache, das Redis, oder das neue wheeze Image muss auf das DHCP Angebot vom Router eingehen und sich mit den IP's anmelden.

  • Mit etwas Glück kannst Du die MAC-Adresse zu den "Pseudo-IPs" heraus bekommen.


    Erst sonstwas zu den Pseudo-IP-Adressen aufbauen (ansurfen, ...)
    Oder alle anpingen

    Quote

    ping -b -c 5 192.168.200.255

    (als root)


    Danach, als root, ein

    Quote

    arp -n


    Das sollte dann alle MAC-Adressen zu allen erreichbaren IP-Adressen im Netz heraus geben.


    Dann hast den Überltäter und kannst da weiter nachschauen. Dienste weiter untersuchen usw. ...


    HTH


    Viele Grüße
    Olaf

    Es gibt immer verschiedene Möglichkeiten um an ein Ziel zu kommen.
    Alle angegebenen Eingaben, wenn nicht anders angegeben, sind als Benutzer 'root' auszuführen.

  • Danke für den Tip.


    Wie man sieht haben die IP'
    192.168.200.110 ether b8:27:eb:39:3d:fc C eth0
    192.168.200.10 ether b8:27:eb:39:3d:fc C eth0
    sowie
    192.168.200.11 ether b8:27:eb:b9:67:8f C eth0
    192.168.200.115 ether b8:27:eb:b9:67:8f C eth0
    die gleiche MAC Adresse.


    Nur woher kommt das?


    Ergänzung:


    Das ganze tritt nur an einem Raspi2 und einem B+ auf. Ältere Raspi B sind nicht betroffen.


    Ich habe das wheezy vom 5.5.15 in Verdacht.

    Edited once, last by rmjspa ().

  • Das ist ja der Knaller,


    also mit

    Quote

    ip addr show

    bekommst Du alle IP-Adressen angezeigt auf dem RPi. Vielleicht wurde bei dem Interface noch etwas mitgegeben.
    Hilft aber auch nicht weiter, welche Software dafür verantwortlich ist.


    Der apache hört im Default auf alle IP-Adressen, welche er erreichen kann.
    Richtet aber, soweit ich weiss, keine IP-Adressen ein.


    Wurde die Pseudo-IP über DHCP gezogen? Kann man das in der Fritzbox nachvollziehen?
    Dann würde ich den dhcp-client deinstallieren / löschen und schauen ob wer im Log meckert.



    Viele Grüße
    Olaf

    Es gibt immer verschiedene Möglichkeiten um an ein Ziel zu kommen.
    Alle angegebenen Eingaben, wenn nicht anders angegeben, sind als Benutzer 'root' auszuführen.

  • Hallo Olaf,
    Ja, die pseudo IP wird über DHCP gezogen.


    Habe jetzt noch mal einiges probiert. Raspi's reboot und DHCP an der Fritzbox ausgeschaltet.
    Wenn DHCP aus ist, sind auch keine pseudo IP'S vorhanden. Schalte ich DHCP wieder ein, sind sie sofort wieder da.


    Auf DHCP kann ich wegen mobiler Geräte und Gäste nicht verzichten.


    Was mir aber noch aufgefallen ist, wenn ich einen Raspi vor wheezy vom 5.5.2015 installiert habe, stand dann in der sudo nano /etc/network/interfaces


    iface eth0 inet DHCP


    seit wheezy vom 5.5.15 steht da:


    iface eth0 inet manual


    was mich schon verwundert hat, wie soll das gehen, ohne weitere Einträge.


    Ich ändere das aber ohnehin immer in:


    iface eth0 inet static
    address 192.168.200.xxx je nach dem
    netmask 255.255.255.0
    gateway 192.168.200.1


    und habe mir da keine weiteren Gedanken gemacht.


    Gruß
    Ron

  • Hallo Ron,



    Ja, die pseudo IP wird über DHCP gezogen.
    [...]


    Auf DHCP kann ich wegen mobiler Geräte und Gäste nicht verzichten.


    Ich meinte auf den RPI den dhcp-client deinstallieren/deaktivieren/löschen, wenn das dort nicht benötigt wird.



    seit wheezy vom 5.5.15 steht da:


    iface eth0 inet manual


    Hui, dass sieht schwer danach aus, dass das Interface dann von "etwas" anderem gestartet wird. Entweder ein Start- / Stop-Script oder halt ... k.P.



    Jo, so hätte ich das auch getan.


    (Da kann ich nur noch zu meiner "Lieblingsdistro" minibianpi raten. Nein quatsch)


    Also. In meinem "alten" Image von k.P. (älter halt) gibt es z.B. kein dhcpcd im "/etc/init.d"-Verzeichnis.
    (Bei minibianpi auch nicht :-)



    In dem Image von 05.05.2015 schon.


    Spätestens jetzt würde ich ein lockeres

    Quote

    update-rc.d dhcpcd disable


    eingeben. Ein Reboot tut dann immer gut.



    Wenn man DHCP wieder benötigt hilft zum aktivieren wieder

    Quote

    update-rc.d dhcpcd enable


    Ich habe es jetzt nur kurz überflogen. (Es ist auch mal wieder spät) :sleepy:
    So wie es aussieht scheint "dhcpcd" die Datei "/etc/network/interfaces" nicht zu beachten.
    Dafür ist es wohl eine "DHCP-Wollmilchsau" und benutzt "/etc/dhcpcd.conf"


    HTH


    Viele Grüße
    Olaf

    Es gibt immer verschiedene Möglichkeiten um an ein Ziel zu kommen.
    Alle angegebenen Eingaben, wenn nicht anders angegeben, sind als Benutzer 'root' auszuführen.

  • Super Danke! :bravo2:


    Das hat geholfen.


    Ich denke mal, man will im wheezy vom 5.5.2015 verhindern, dass man sich selbst aussperrt und deshalb zusätzlich noch eine DHCP IP bezieht.
    Es scheint aber nur die 40 poligen Raspi also Raspi2 und B+ zu betreffen. Bei den alten B tritt das nicht auf.


    Vielen Dank nochmal für den Hinweis


    Gruß Ron