NewTron-Radio: Auflösungsunabhängiges Tron-Radio

  • Hallo kle,

    hab mir peppy mal angesehen und feststellen müssen, dass mein 3,2" Waveshare LCD nicht unterstütztwird...

    Werd' mich wohl weiter mit Newtron vergnügen...

    Danke trotzdem für die schnelle Antwort"!

    Hajo


    EDIT: Hab maldas 2,8" image probiert und das zeigt was an. Jetzt muss ich nur noch die USB-Soundkarte irgendwie zum Laufen bekommen ...

    Edited once, last by hajos118 ().

  • Moin!

    Ich habe das neuste Buster Desktop Image auf mein rpi4 gespielt und mein 3.5" Display (waveshare) zum Laufen bekommen (offizielle Treiber installiert). Touchscreen läuft und ist via UI -> Config -> TS kalibrieren eingestellt. Nun habe ich das newtron radio v3.2 (#1833) installiert. Leider startet es immer im Fenstermodus. Vollbild habe ich bereits in den Einstellungen eingestellt, speichert und neugestartet.


    Autostart funktioniert leider auch nicht


    Dann habe ich die Anleitung aus #1778 für Touchscreen Treiber befolgt. Also Script gestartet, mein Bildschirm ausgewählt. ts_calibrate zeigte mir danach nur schwarzen Bildschirm, durch rumdrücken kam ich da aber durch .... Bringt mich aber nicht weiter. Zwar kommen die Fehlermeldungen beim Testen des autostarts nicht mehr, aber nun stehe ich vor einem schwarzen Bildschirm.

    Edited 2 times, last by ottelo ().

  • Hallo RPI-Gemeinde,


    ich ein bisschen am verzweifeln.


    ich habe 2017 es geschafft, mit euren Anleitungen hier im Forum, das NewTron-Radio 2.7.5 zum laufen zu bekommen.

    Nun wollte ich "mal eben" (der erste Fehler :-) ) das Radio Updaten.


    Ich habe gesehen, das es eine neu Version des Radios gibt (Version: 3.2) und ich dafür auch eine neues Betriebssystem benötige .

    Also, ein schneller Entschluss, alles komplett neu aussetzen.

    Jetzt stehe ich vor einem Problem. Altes Radio weg, Neuinstallation bekomme ich nicht hin :-(


    ich hoffe Ihr könnt mir helfen.


    Folgende Hardware habe ich:

    Raspberry Pi 3 Model B v1.2

    Display: Adafruit PiTFT Plus 320x240 2.8" TFT + Capacitive Touchscreen

    USB-Soundkarte


    Was habe ich bemacht:

    verwendetet Image: 2020-02-13-raspbian-buster-lite.img


    Die Grundeinstellungen waren kein Problem (Sprache, Tastatur, feste IP, SSH, Expand Filesystem)


    Anschließend : Update und Upgrate


    Nun kam das Display :-(

    Da fingen die Probleme an.

    Mit der Anleitung und dem Skript von Adafruit "adafruit-pitft.sh" wurde abgefragt was ich für ein Display habe und welche Ausrichtung ist benötige. Die Installation verlieft problemlos, bis auf eine Anmerkung:

    "Warnung: apt does not have a stable CLI interface. Use with caution in scripts"


    Diese Warnung sagt wir so leider nix.

    Wenn ich die Anleitung weiter gehe, ist der nächste Schritt die Konfiguration.

    Da fiel mir aus, das die Datei "Touchscreen" in /dev/Input" nicht vorhanden ist. Zudem ist beim Versuch den Touch zu testen die TSLib nicht da.


    ich habe es auch mit anderen Image versucht:

    - 2020-02-13-raspbian-buster-full.img

    - 2018-03-13-raspbian-stretch.img (Vorschlag aus der Display-Anleitung)


    Beim Installieren des Radios kommen, natürlich Fehler auf, das der RPI und das Display nicht richtig sind.


    ich bin zudem auch noch ein Laie mit dem RPI.


    ich hoffe ich konnte mich verständlich ausdrücken und jemand weiß einen Rat.


    Im Voraus Danke.


    Grüße aus dem Sauerland

    IC-Cruncher

  • Nun habe ich das newtron radio v3.2 (#1833) installiert. Leider startet es immer im Fenstermodus. Vollbild habe ich bereits in den Einstellungen eingestellt, speichert und neugestartet.

    redest Du vom NewTron-Radio Fenster Settings? Dort gibt es eine Checkbox mit Namen Fullscreen.


    die Funktioniert nicht mehr bei grafischer Oberfläche.

    sieht bei mir so aus:

    forum-raspberrypi.de/attachment/25345/ default Auflösung 720x480 auf einem 320x240 Display

    das Bild ist ein Screenshot vom VNC, auf dem Display schaut es ähnlich aus.

    Touchscreen läuft und ist via UI -> Config -> TS kalibrieren eingestellt

    ...

    Dann habe ich die Anleitung aus #1778 für Touchscreen Treiber befolgt. Also Script gestartet, mein Bildschirm ausgewählt. ts_calibrate zeigte mir danach nur schwarzen Bildschirm,

    Konsole/CLI und Desktop/GUI sind bezüglich Display-Konfiguration 2 verschiedene Sachen.


    Du willst offensichtlich mit der grafischen Oberfläche (Desktop/GUI) arbeiten.


    Der Beitrag #1778 ist ausdrücklich für

    Touchdisplays im Konsolenmodus

    geschrieben.

    Der Autostart mit der systemd-unit newtron-radio funktioniert im Konsolbetrieb.

    Mit der grafischen Oberfläche kommt NewTron-Radio zu früh, bevor die grafische Oberfläche fertig ist.


    Edit:

    Ich würde mal

    After graphical.target

    in der systemd-unit probieren.

    Lösung in Beitrag #1893

    Edited 4 times, last by kle ().

  • Hallo,

    Deine Informationen sind hilfreich.

    wenn Du keine Angst vorm Lernen hast: alles gut.

    --- erst alles durchlesen und verstehen ---

    Also, ein schneller Entschluss, alles komplett neu aussetzen.

    Jetzt stehe ich vor einem Problem. Altes Radio weg, Neuinstallation bekomme ich nicht hin

    Backups sind immer eine gute Idee.

    • Die SD-Karte könnte unbrauchbar werden.
    • Du änderst, aber Du willst den alten Stand wieder herstellen.

    ein Tool ist raspiBackup von Framp.

    Display: Adafruit PiTFT Plus 320x240 2.8" TFT + Capacitive Touchscreen

    Kapazitive Displays müssen nicht kalibriert werden.

    (Info: ich besitze kein kapazitives Touchscreen-Display)

    hast Du diese Adafruit-Anleitung befolgt?

    "Warnung: apt does not have a stable CLI interface. Use with caution in scripts"

    Diese Warnung besagt, daß die Konsol-Ausgaben von apt sich ändern können. Du sollst sie deshalb nicht in Skripten verwenden.

    Mit der Anleitung und dem Skript von Adafruit "adafruit-pitft.sh"

    ...

    Da fiel mir aus, das die Datei "Touchscreen" in /dev/Input" nicht vorhanden ist.

    Das device /dev/input/touchscreen wird durch eine udev-Rule beim Booten erzeugt. Das Adafruit-Skript legt nur die udev-Rule an. Fehlt /dev/input/touchscreen nach einem Neustart?

    (Info: man kann die udev-Rule auch selbst anlegen)

    Zudem ist beim Versuch den Touch zu testen die TSLib nicht da.

    tslib wird mit dem NewTron-Radio Installer mit installiert.

    Das Test-Programm ts_test funktioniert nicht für kapazitive Touchscreens.

    Das Test-Programm evtest funtioniert.


    Vorgehensweise:

    • 2020-02-13-raspbian-buster-lite.img installieren
    • display installieren und rebooten.
    • NewTron-Radio installieren (#1833)
      mit sh ./newtron-radio-setup-v3.2.sh > newtron-radio-setup-v3.2.sh.log 2>&1

    Info: mit dem Kommando werden alle Ausgaben und Fehlermeldungen in eine Datei umgeleitet. Das dauert einige Zeit bis der Prompt wieder da ist. Wenn Du gleichzeitig beobachten willst was das Skript tut, gibst Du in einem anderen Fenster das Kommando tail -f newtron-radio-setup-v3.2.sh.log ein. Das tail -f-Kommando beendest du mit Strg C.


    Bei Fehlern das Kommando und die Fehlermeldung in einem Codeblock () posten.

    Schönen Gruß, kle

  • Hallo Kle,


    danke für deine schnelle Antwort.


    ich versuche zu lernen und zu verstehen :-)


    Ein Backup vom alten Radio habe ich. ich habe die SD-Karte mit "Win32 Disk Imager" ausgelesen.


    ich habe die Anleitung von Adafruit benutzt und nach einem Reboot war die Datei "Touchscreen" nicht da.


    ich versuche die Einrichtung noch einmal neu.


    ich melde mich später noch einmal :-)



    Gruß IC-Cruncher

  • Zur Sicherheit: nach dem adafruit-pitft.sh Skript würde ich rebooten und

    • dabei auf das Display schauen und
    • mit ssh/putty das Kommando ls -l /dev/input/touchscreen eingeben
  • ich glaube ich habe den Fehler gefunden. Die Touchfunktion am Display ist kaputt.


    ich habe das alte Image aufgespielt. Das Radio startet und ist zu sehen, Musik ist zu hören, jedoch keine Reaktion am Display wenn ich es berühre.


    da werde ich mir leider ein neues zulegen müssen.


    hast du eine Empfehlungen für ein Display, was günstiger, aber nur für das Radio ausreichend ist?

    hat sich erledigt. im Beitrag: #1.778 sind einige aufgeführt.

  • Hallo,

    hast Du ein Gehäuse für Raspi und Display?

    Ich habe Displays getötet, weil ich sie ohne Gehäuse verwendet und zu fest gedrückt habe.


    Es gibt verschiedene Schnittstellen für Displays: SPI, HDMI, DSI.


    Fertige Gehäuse gibt es für 2.8", 3.2" und 3.5" (alles SPI) die ersten beiden habe 320x240 Pixel, das 3.5" hat 480x320".

    Für das 5" HDMI Touch-Display müsstest Du selber was bauen.


    Das offizielle 7" Raspberry Pi Display (DSI) (800x480 Pixel) hat sehr viel Rand und ist nicht billig. Ausserdem braucht spezielle Treiber für dem Konsolbetrieb.

    Nimm was von Waveshare und ein Gehäuse dazu, bei den Clones hast Du evtl. Schwierigkeiten das Display in der Konsole zu betreiben.

    Du hast mich ja gefragt, kle

  • ottelo s. Fullscreen und Autostart

    Fullscreen

    veloci in /usr/local/lib/newtron-v3/newtron-radio.py ist ein kleiner Fehler, read_config() muß vor disp_init() aufgerufen werden, weil dort fullscreen abgefragt wird.

    Autostart

    Autostart mit systemd für grafische Oberfläche habe ich auf die schnelle nicht hinbekommen.

    Als Workaround funktioniert eine desktop-Datei in Verzeichnis ~/.config/autostart

    Code: ~/.config/autostart/newtronradio.desktop
    [Desktop Entry]
    Encoding=UTF-8
    Type=Application
    Exec=/usr/local/bin/newtron-radio
    Icon=newtronradio
    Name=NewTron Radio
    Categories=AudioVideo;Audio;Player;Multimedia;

    das reicht für den Autostart.

    -----------------------------------------

    Info_1: das ist eine Kopie der Datei /usr/share/applications/newtronradio.desktop

    Info_2: auf den Schreibtisch enthalten desktop-Dateien Links,

    Code
    [Desktop Entry]
    Type=Link
    Name=NewTron Radio
    Icon=newtronradio
    URL=/usr/share/applications/newtronradio.desktop

    im Verzeichnis ~/config/autostart funktionieren Links nicht.

    Schönen Gruß, kle

  • Vielen DANK!!!


    Bei mir funzt leider noch keine Ausgabe über Bluetooth Lautsprecher. Youtube usw funktioniert nur das Radio will nicht. Hab schon manuell einen Eintrag in conf.mpd hinzugefügt, leider bringt das auch nichts.


    EDIT

    Ok, die Suche hier im Thread scheint nicht richtig zu funzen. Nach Bluetooth gesucht und der letzte Eintrag von 2017 wurde angezeigt. 2 Seiten per Hand zurück geblättert und schon gibts ne Lösung ^^


    Funzt ... aber ich kann nun die Lautstärke nicht mehr ändern im Radio.

    Edited 4 times, last by ottelo ().

  • Erstmal ein großes Danke für die super Lösung.

    habe es in folgender config laufen - völlig problemlos:

    - RPI 4B+ 2GB

    - 2020-05-27-raspios-buster-armhf mit Desktop

    - Pimoroni Hyperpixel 4 Display

    - newtron-radio-setup-v3.2.sh

    - Kabelgebundene Lautsprecher an der 3,5mm Klinke


    Enter, enter --> geht ! So wie es sein sollte aber selten ist ;-)

    mfg

    Michael

  • Nach einigen Stunden genießen:

    - wie sage ich MPD, dass es auch Bluetooth Lautsprecher gibt ?

    - Paarung war einfach, der Pi zeigt sie an - leider aber unter MPD Audio Options - nur My ALSA Device - dort sollten doch die gepaarten Bluetooth LS wählbar sein.. oder?


    - wo kann ich die Grundlautstärke einstellen ?


    mfg


    Michael

  • 68gt500 Auf der grafische Oberfläche (Desktop) wählst Du den Lautsprecher folgendermaßen:

    • klicke mit der rechten Maustaste auf das Lautsprecher-Symbol in der Taskleiste und
    • klicke mit der linken Maustaste auf den Bluetooth-Lautsprecher

    Der gewählte Lautsprecher gilt für alle Audio-Ausgaben, nicht nur für NewTron-Radio.

    der Pi zeigt sie an - leider aber unter MPD Audio Options - nur My ALSA Device - dort sollten doch die gepaarten Bluetooth LS wählbar sein.. oder?

    im mpd, NewTron-Radio-Fenster MPD Audio ist das default alsa pcm device angewählt. Das ist fast richtig

    Du änderst nur den mixer_type im audio_output auf "software" mit Kommando sudo nano /etc/mpd.conf

    Info: alles hinter einem #-Zeichen bis Zeilenende überliest der mpd, ist also Kommentar.

    Code: /etc/mpd.conf
    audio_output {
    type "alsa"
    name "My ALSA Device"
    # device "hw:0,0" # optional
    # mixer_type "hardware" # optional
    mixer_type "software"
    # mixer_device "default" # optional
    # mixer_control "PCM" # optional
    # mixer_index "0" # optional
    }

    hyle danke, hab ich vergessen (s. Beitrag #1898).

    Die grafische Oberfläche merkt sich den ausgewählten Lautsprecher in Datei ~/.asoundrc.

    Um Fehler bei Zugriffsrechten zu vermeiden, muß diese Datei noch nach /etc/asound.conf kopiert und der mpd neu gestartet werden.

    Am besten legst du dafür eine Desktop Datei an, guck da.

    Damit mußt nach Auswahl des Lautsprechers zusätzlich die neue Desktop-Datei ausführen.


    Schönen Gruß, kle

    Edited 2 times, last by kle ().