NewTron-Radio: Auflösungsunabhängiges Tron-Radio

  • NewTron-Radio: Auflösungsunabhängiges Tron-Radio? Schau mal ob du hier fündig wirst!

  • Hallo BenWob,


    Auch wenn ich Deine Schritte befolge, passiert nix oder ist nicht vorhanden.

    Du schreibst dermaßen ausführliche und präzise Fehlerberichte...
    Mit 'geht nicht' hilfst Du
    (1) weder einem anderen, der ein ähnliches Problem hat,
    (2) noch einem, der Dir helfen will.
    Ich fühle mich eher genervt durch 'es geht nicht' und weiß nicht warum Du postest.
    Bist Du noch an einer Lösung interessiert?


    ...Nutze das Tontec mz61581 Display...

    Display: Tontec MZ61581
    Raspi: ?
    Betriebssystem: ?
    Desktop- oder Konsolbetrieb: ?


    Das komische ist ja, dass mein Touch anspringt und auch arbeitet.
    Habe libts-bin nachinstalliert, aber ist bereits vorhanden.

    Was willst Du damit sagen?
    (1) Zeigt das Display etwas an?
    (2) reagiert es auf Berührung?
    (3) ist es calibriert (mit ts_calibrate)?

    Kalibrieren im Konsolbetrieb mit:

    Code
    sudo TSLIB_FBDEVICE=/dev/fb1 TSLIB_TSDEVICE=/dev/input/event0 ts_calibrate

    Du hast in Datei '/usr/local/lib/newtron-v2/newtron-radio.py' in Zeile 33 '/dev/input/touchscreen' geändert in '/dev/input/event0' und dann kommt beim Starten von newtron-radio die gleiche Fehlermeldung?

    Dann poste mal die Ausgabe der Kommandos

    Code
    ls -l /dev/input

    und

    Code
    ls -l /dev/fb*

    und

    Code
    which ts_calibrate

    Gruß kle

  • kle
    deine Geduld will ich haben.
    Ich hätte schon etliche sarkastisch Sprüche fallen lassen.

    Einer der nicht 'richtig' liest, nicht 'richtig' lernen will, nicht die vorhandenen Möglichkeiten nutzt, hat eigentlich unsere Hilfe nicht verdient.
    Aber wir haben ja die Glaskugel.

    Hier im Forum beschweren sich Hilfesuchende 'Grünschnäbel' über den Ton mancher, nach aber tausenden Beträgen dieser Leute und etwas mehr Erfahrung (Linux) werden sie hoffentlich über ihre damalige 'Überheblichkeit' oder ist es 'Dummheit' oder oder, schmunzeln.

  • Hi Leute. Bei mir läuft das Radio eigentlich ganz gut. Hab Rpi3 und verwende den Klinkenausgang. Damit die Lautstärkeeinstellung wieder geht musste ich in der mpd.conf mixer_type auf software stellen. Das geht aber die Lautstärke lässt sich nun nur verzögert einstellen. mpd ist als v 0.19.1-1.1 installiert

  • Mhhh, erst einmal ist es schön das es soweit funktioniert.
    mit dem Eintrag in der mdp.conf ist richtig.

    Ich habe dieses Problem der verzögerten Reaktion des Mixers selbst noch nicht gehabt und auch keine richtige Lösung.

    Es müsste ja in deinem Fall (Klinke) der Alsamixer sein, ich denke der hat nicht die nötige Priorität. Google mal danach.

    Vielleicht kennt jemand hier das Problem und kann dir konkret helfen.

  • Hey Kle,
    vielen Dank für Deine Geduld.

    Ich nutze den Pi 2 mit dem aktuellen Jessy BS.

    (1) Zeigt das Display etwas an? jups und zwar den Desktopmodus
    (2) reagiert es auf Berührung? ohne Probleme
    (3) ist es calibriert (mit ts_calibrate)? ist auch erledigt

    [font="monospace"]ls -l /dev/input zeigt mit folgendes an:[/font]

    [font="monospace"]

    Code
    pi@raspberrypi:~ $ ls -l /dev/input[/font][/size][/color][/color]insgesamt 0drwxr-xr-x 2 root root      60 Apr 16 19:47 by-pathcrw-rw---- 1 root input 13, 64 Apr 16 19:47 event0crw-rw---- 1 root input 13, 63 Apr 16 19:47 mice[color=#333333][color=#333333][size=10][font="monospace"]crw-rw---- 1 root input 13, 32 Apr 16 19:47 mouse0

    [/font][/size][/color][/color]


    [font="monospace"][font="monospace"]ls -l /dev/fb* zeigt mir folgendes an:[/font][/font]

    [font="monospace"]

    Code
    crw-rw---- 1 root video 29, 0 Apr 16 19:47 /dev/fb0crw-rw---- 1 root video 29, 1 Apr 24 07:27 /dev/fb1

    [/font]

    [font="monospace"][font="monospace"]which ts_calibrate zeigt mir folgendes an:[/font][/font]

    [font="monospace"][font="monospace"]

    Code
    /usr/bin/ts_calibrate

    Wenn ich nun mit newtron-radio starten will, erscheint diese Fehlermeldung weiterhin:[/font][/font]

    [font="monospace"][font="monospace"]

    Code
    pi@raspberrypi:~ $ newtron-radio[/font][/size][/color][/font][/size][/color][/color]No ConfigFile found, using defaultstrying fbcon<class 'pygame.error'>: Unable to open a console terminalDriver fbcon failed!Is libts/libts-bin installed?Also check:SDL_FBDEV = /dev/fb1SDL_MOUSEDEV = /dev/input/event0SDL_MOUSEDRV = TSLIBAre theese correct? Set them in Line 30ff.Traceback (most recent call last):  File "/usr/local/lib/newtron-v2/newtron-radio.py", line 1704, in <module>    disp_init()  File "/usr/local/lib/newtron-v2/newtron-radio.py", line 323, in disp_init    raise Exception('No suitable video driver found!')[color=#333333][color=#333333][size=10][font="monospace"][color=#333333][size=10][font="monospace"]Exception: No suitable video driver found!


    [/font][/size][/color][/font][/size][/color][/color]
    [font="monospace"][font="monospace"]viele Grüße und Danke[/font][/font]


  • RPi: Pi 2
    Display: Tontec MZ61581
    OS: Raspbian Jessy
    Betriebsart: Desktop d.h. grafische Oberfläche

    Hallo BenWob,

    Du startest newtron-radio als user pi. Das ist falsch.
    newtron-radio muß mit root-Rechten gestartet werden.


    (1) Starten aus einem Terminal-Fenster

    Code
    # Starten als user pi ist FALSCH:
    newtron-radio &
    # oder auch FALSCH:
    /usr/local/lib/newtron-v2/newtron-radio.py &
    # Info: wenn Du newtron-radio als user pi startest, kommt eine irreführende Fehlermeldung
    # Dem Programm fehlen Rechte.
    #
    # RICHTIG ist:
    exec sudo /usr/local/lib/newtron-v2/newtron-radio.py &
    # dann wird newtron-radio mit root-Rechten gestartet


    (2) Starten über Menu:
    menu => Sound & Video => NewTron Radio

    (3) Autostart im Desktop-Modus:
    Datei autostart editieren:

    Code
    cd;cd .config/lxsession/LXDE-pi
    nano autostart


    an das Dateiende folgende Zeile anhängen:

    Code
    /usr/local/bin/newtron-radio &

    Für newtron-radio ist der Desktop-Modus nicht erforderlich!
    (1) raspi-config: Boot options => boot to console
    (Info: 'boot to Console' geht schneller)
    (2) Autostart im Consol-Modus
    Autostart-Datei editieren mit 'sudo nano /etc/rc.local' und Zeile: '/usr/local/bin/newtron-radio &' vor 'exit 0' einfügen.
    (Achtung: diese Zeile in Datei '/etc/rc.local' muß im Desktop-Modus auskommentiert werden.)

    INFO: die Autostart-Skripte, werden mit root-Rechten ausgeführt, deshalb ist dort richtig, was im Desktop-Terminal-Fenster falsch ist.
    Gruß kle

    Edited once, last by kle (April 24, 2017 at 6:55 PM).


  • Mhhh, erst einmal ist es schön das es soweit funktioniert.
    mit dem Eintrag in der mdp.conf ist richtig.

    Ich habe dieses Problem der verzögerten Reaktion des Mixers selbst noch nicht gehabt und auch keine richtige Lösung.

    Es müsste ja in deinem Fall (Klinke) der Alsamixer sein, ich denke der hat nicht die nötige Priorität. Google mal danach.

    Vielleicht kennt jemand hier das Problem und kann dir konkret helfen.

    Also Wenn ich über die console den alsamixer starte (steuerung) kann ich ja per Mausrad die Lautstärke bequem einstellen. Dies passiert ohne Verzögerung sofort! Wenn ich die Lautstärke über das Radio einstelle, dann sieht man im Alsamixer garnichts und trotzdem ändert sich die Lautstärke. Der Bereich, den ich mit alsamixer gerade einstelle gilt dann fürs Radio. D.h. momentane alsamixer Lautstärke = maximale Lautstärke fürs Radio. Parallel betreibe ich shairport (airplay). Wenn ich dort die Lautstärke über ein Handy veränder, passiert dies auch sofort und man kann es über alsamixer sehen...

    EDIT:
    Also es liegt definitiv an mpc. Bei mir hängt sich das ganze Radio auch kurz (1min) auf, wenn ich die Radiosender wechsel. Rechte der playlisten sind richtig gesetzt (user pi, group audio). Wenn es gerade hängt gibt mpc status ein timeout aus. Wenn ich mit mpc direkt die Lautstärke einstelle passiert dies ebenfalls nur verzögert.

    Edited once, last by ottelo (April 24, 2017 at 5:23 PM).

  • Hey kle,
    vielen Dank dafür, denn das hat mich schon weiter gebracht.

    Wenn ich den Pi jetzt neu starte, komme ich in den Desktop-Modus und das Radio startet selber. Macht aber wenig Sinn, da es direkt nach dem Neustart starten soll.
    Ich habe in der raspi-config die Boot Optionen geändert, aber das Radio startet dadurch nicht, sondern es startet nur die Eingabeaufforderung.

    Wenn ich das Radio dann im Desktop Modus starte, steht Volum auf -1% und somit kommt auch kein Sound heraus.

    Das sind jetzt noch zwei Problemchen die ich habe, wenn diese erledigt sind, kann ich Luftsprünge machen. :D

    Danke für Deine Geduld =)


  • (1) Ich habe in der raspi-config die Boot Optionen geändert, aber das Radio startet dadurch nicht, sondern es startet nur die Eingabeaufforderung.

    (2) Wenn ich das Radio dann im Desktop Modus starte, steht Volum auf -1% und somit kommt auch kein Sound heraus.

    Im Desktop-Modus kann das Radio erst nach dem Desktop gestartet werden.

    zu (1)
    --- ich wiederhole mich:
    Im Console-Modus benutzt Du eine andere Datei ( /etc/rc.local ) für Autostart.

    Code
    sudo nano /etc/rc.local
    # vor der Zeile mit 'exit 0' folgende Zeile einfügen:
    /usr/local/bin/newtron-radio &   # auto start von newtron-radio

    (Info 1: das &-Zeichen sorgt dafür, daß newtron-radio im Hintergrund ausgeführt wird.
    Das ist wichtig, sonst würde das Skript darauf warten, daß newtron-radio beendet wird.)

    (Info 2: für Desktop-Modus machst Du ein #-Zeichen vor die Zeile, dann ist sie nur noch Kommentar.)


    zu (2)
    dann fehlt in Datei /etc/mpd.conf etwas.

    Code
    sudo nano /etc/mpd.conf


    suche nach 'mixer_type', dann findest Du den Block:

    Code
    audio_output {
           type            "alsa"
           name            "My ALSA Device"
    #       device          "hw:0,0"        # optional
    #       mixer_type      "hardware"      # optional
    #       mixer_device    "default"       # optional
    #       mixer_control   "PCM"           # optional
    #       mixer_index     "0"             # optional
    }

    (Info: in dieser Datei ist alles hinter #-Zeichen Kommentar)

    den Block änderst Du in:

    Code
    audio_output {
          type            "alsa"
          name            "My ALSA Device"
          mixer_type      "software"
    }

    bitte genau lesen, den 'zu 1' Abschnitt, habe ich beim letzten Mal schon geschrieben

    Edited once, last by kle (April 25, 2017 at 2:48 PM).

  • Ich bedanke mich an alle die hier mitgewirkt haben. Wird Zeit für einen weiteren Pi der erste wird wohl als Radio weiter dienen.

    Alles funzt soweit ganz gut ausser die Lautstärke steht nach dem Start auf -1%. Wenn ich auf den Pfeil hoch und runter drücke passiert folgendes.
    Drück ich zweimal auf leise wird gemutet, ein klick auf den oberen Pfeil und das gemutete ist wieder normal es bleibt jedoch auf -1% stehen.

    Zur Zeit läuft der Raspberry mit HDMI am TV.

    Edited once, last by wurstherpes (May 3, 2017 at 4:24 PM).

  • Hi Leute. Habe mir n PhatDac Clone bestellt und soeben angeschlossen. Script installieren lassen, Sound kommt raus :thumbs1:

    Natürlich geht nun kein Volume Control mehr übers Newtron Radio. Volumeänderung über Shairport (Airplay) funzt jedoch einwandfrei. Ist wohl ein Softwaremixer hinter. Geht das irgendwie auch bei newtron? Script anpassen?

    EDIT:
    Man sollte nach der Änderung auf mixer_type = Software auch mal neustarten und nicht nur das newtron radio :D
    Geht nun also alles.

    Edited once, last by ottelo (May 19, 2017 at 6:55 PM).

  • Hallo liebes Forum,

    vorneweg vielen Dank für die sehr vielen sehr hilfreichen Hinweise und die ausführlichen Anleitungen.
    Ein Problem meines Newtron Radios konnte ich aber auch über die SuFu bisher nicht lösen. Seit dem ersten Einrichten von eigenen Playlisten ist eine Playlist als Standard gesetzt und startet beim Einschalten automatisch. Nun will ich eine andere Playlist als default setzen und habe die entsprechende Zeile im Skript angepasst - ohne Erfolg. Auch nach Löschen der aktuellen default Playlist aus den Ordnern usr/local/lib/newtron-v2/playlists und var/lib/mpd/playlists mit anschließender Aktualisierung des mpd-Verzeichnisses startet ebendiese Playlist nach dem Einschalten des Radios automatisch (ist über die Playlistenauswahl aber nicht mehr wählbar).

    Vielen Dank für die Hilfe :)

    Daniel

  • Hallo,

    So jetzt muss ich mich ein wenig wieder (r)einarbeiten.

    Code
    ###### Playlistenmanagement ################################
    # Vollständiger Pfad zur mpd.conf
    mpd_config = '/etc/mpd.conf'
    defaultplaylist = 'Radio BOB!' # eine Playlist aus dem 'playlist_directory'
    sort_playlists = True

    Die Zeile defaultplaylist... gegen deine austauschen.
    Im var/lib/mpd/playlists deine playlist Datei kopieren, default = Radio Bob!.m3u

    Eventuell Schreibschutz entfernen. Dann gibt es noch ein paar Dateien in denen sich mpd merkt wo und was etc. eventuell diese löschen wenn ein Neueinlesen der playlist nicht hilft.
    Findest du im mpd Ordner.

    state

    Edited once, last by paulaner (May 25, 2017 at 7:15 PM).

  • Naja, die Defaultplaylist die im Programm vorgegeben ist wird nur verwendet, wenn im Player keine Playliste geladen ist. Sobald aber eine (Radio-)playliste ausgewählt wurde wird diese verwendet - auch nach einem Neustart.

    Also: Touch aufs Hauptfenster, Senderliste auswählen und mit ←' bestätigen. Das sollte reichen...


  • Dann gibt es noch ein paar Dateien in denen sich mpd merkt wo und was etc. eventuell diese löschen wenn ein Neueinlesen der playlist nicht hilft.
    Findest du im mpd Ordner.

    state

    Es war eine Playlist in /var/lib/mpd/state gesetzt. Löschen dieses Eintrags und es wird die defaultplaylist aus der newtron-radio.py verwendet.

    Problem gelöst, Danke an Paulaner und Veloci!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!