Spannungsversorgung Pi2

  • Hallo,
    betreibe Kodi mit Ambilight (Hyperion, 50LEDs) auf einem Pi2 mit OpenELEC.
    Das ganze läuft auch schon seit gut 2 Monaten problemlos. Allerdings war das ganze noch provisorisch aufgebaut. Heißt, der Pi war via Micro USB an einem 1A USB Ladegerät angeschlossen, die LEDs an einem 5V4A Steckernetzteil. Außerdem war noch ein aktiver USB Hub angeschlossen (2,5A), welcher den Pi zusätzlich noch mit Spannung versorfte.


    Nun habe ich die ganzen Netzteile durch ein 5V10A Schaltnetzteil ersetzt.
    Das ganze sieht nun so aus:
    [Blocked Image: http://abload.de/thumb/raspitvdequw.png]


    Von dem Netzteil gehe ich mit Plus und Minus an eine kleine Platine. Von dort aus gehen alle Plus und Minus ab, die ich für Display und LEDs brauche. Auch der Pi wird darüber versorgt, dafür habe ich aus einem alten MicroUSB Kabel ein "Adapter" (Plus und GND als Kabel rausgeführt, welche an Plus und Minus der kleinen Platine gehen) gebaut.



    Problem:
    Kodi zeigt mir oben rechts ein kleines buntes Quadrat an, was soweit ich weiß für eine Spannungsunterversorgung steht.
    Wenn ich das Ambilight deaktiviere wird dieses nicht mehr angezeigt.
    Ich habe das Netzteil auf 5,1V Ausgangsspannung gedreht, änderte aber nichts. Mehr hab ich mir nicht getraut.
    Das selbstgebaute MicroUSB Kabel funktioniert auch 100%ig, habs ans Handy angeschlossen und sowohl das HAndy, als auch so ein kleines USB Multimeter was man zwischen USB KAbel und USB Netzteil steckt, haben mir gesagt, dass das Handy mit 1000mAh geladen wird.


    Lösungsansatz1:
    Was ich mir jetzt noch vorstellen könnte ist, dass ich auf der kleinen Platine für die Spannungsversorgung zwei 5V+ Schienen machen müsste.
    Eine die vom Netzteil versorgt wird, woran ich den MicroUSB Adapter und das Ambilight anschließe, und eine zweite, die vom Pi versorgt wird (Pin2), an die ich das Display anschließe.
    Oder würde es auch gehen,