Einbinden von TimeCapsule nicht möglich

  • Hi alle zusammen,


    ich habe heute versucht meine TimeCapsule zu mounten, allerdings habe ich dabei ein sehr interessantes Problem:
    Sobald ich Versuche in das Verzeichnis zu mounten verschwindet es.


    Ich erstelle mir so ein Verzeichnis:
    mkdir /mnt/timecapsule


    und dann mache ich den folgenden Eintrag in der fstab um die TimeCapsule nach dem Reboot zu mounten:
    [font="Menlo"]//10.0.1.1/Matthis_Externe /mnt/timecapsule cifs credentials=/home/pi/.smbcredentials,rw,file_mode=0777,dir_mode=0777,sec=ntlm,_netdev 0 0[/font]


    Danach bekomme ich aber den Fehler:
    couldn't chdir to no such file or directory:: /mnt/timecapsule



    Warum bekomme ich diesen Fehler?


    Gruß
    Matthis


    PS: Das OS ist XBIAN

  • Nach der Fehlermeldung zu urteilen ist das Verzeichnis nicht da.


    Hast du denn nach dem du das Verzeichnis erstellt hast, den mount per Hand erfolgreich ausführen können?
    Du brauchst den PI nicht zu rebooten um deine fstab zu testen. Wenn du alles eingerichtet hast, einfach mal ein "mount -a" ausführen. Spart den reboot.

    --
    man ist das System-Anzeigeprogramm für die Handbuchseiten von Linux.

  • Nachtrag: Gibt denn der Timecapsule überhaupt CIFS aus?

    --
    man ist das System-Anzeigeprogramm für die Handbuchseiten von Linux.

  • Hi, ja die Timecapsule kann cifs, ich binde die sonst genau so immer ein und bei den anderen Geräten klappt das auch immer.
    Das ist ja gerade das Problem, ich gehe sonst immer so vor um die Timecapsule einzubinden ...
    Aus meiner Sicht macht nur einfach die Fehlermeldung no such file or directory einfach keinen sind,
    schließlich habe ich mit mkdir die directory erstellt

  • Ach eine Frage hatte ich vergessen zu beantworten:


    Nein, ich konnte den mount-Befehl nicht per Hand ausführen, da kam direkt schon die Fehlermeldung

  • Hi,


    also ich konnte das Problem jetzt lösen, aber leider mit einer nur wenig zufrieden stellenden Lösung:
    Installation von Xbian for Raspberry Pi2 stable.
    Ich hatte sonst immer die aktuellste Version genommen, doch scheint es bei dieser erhebliche Problem zu geben beim mounten.
    Woran das liegt konnte ich leider nicht in Erfahrung bringen.


    Nightskill, dass hier war wie oben auch schon geschrieben der Fehler der bei "sudo mount -a" ausgegeben wurde:
    couldn't chdir to no such file or directory:: /mnt/timecapsule


    Aus meiner Sicht macht das aber gar keinen Sinn, da ich vorher mit "sudo mkdir timecapsule" in /mnt das Directory erstellt habe,
    welches ich auch genau solange benutzen kann, bis ich den Mount-Eintrag in der fstab gemacht habe, danach kann ich auf das Directory nicht mehr zugreifen.


    Danke für die schnellen Hilfen!!


    Gruß Matthis