Pimatic - Keine WebGUI

  • Hallo,


    bei mir startet der Service nicht. Bitte um Hilfe.
    Folgender Fehler:


    sudo service pimatic start


    Job for pimatic.service failed. See 'systemctl status pimatic.service' and 'journalctl -xn' for details.



    systemctl:
    pimatic.service loaded failed failed LSB: pimatic service


    journalctl:



    Logs begin at Mo 2016-06-06 20:59:08 CEST, end at Mo 2016-06-06 21:36:29 CEST
    Jun 06 21:35:51 raspberrypi sudo[2698]: pi : TTY=pts/1 ; PWD=/home/pi ; USER=roo
    Jun 06 21:35:51 raspberrypi sudo[2698]: pam_unix(sudo:session): session opened f
    Jun 06 21:35:51 raspberrypi systemd[1]: Starting LSB: pimatic service...
    -- Subject: Unit pimatic.service has begun with start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit pimatic.service has begun starting up.
    Jun 06 21:35:51 raspberrypi pimatic[2719]: /etc/init.d/pimatic: 25: /etc/init.d/
    Jun 06 21:35:51 raspberrypi systemd[1]: pimatic.service: control process exited,
    Jun 06 21:35:51 raspberrypi systemd[1]: Failed to start LSB: pimatic service.
    -- Subject: Unit pimatic.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit pimatic.service has failed.
    --
    -- The result is failed.
    Jun 06 21:35:51 raspberrypi systemd[1]: Unit pimatic.service entered failed stat
    Jun 06 21:35:51 raspberrypi sudo[2698]: pam_unix(sudo:session): session closed f
    Jun 06 21:36:29 raspberrypi sudo[2725]: pi : TTY=pts/1 ; PWD=/home/pi ; USER=roo
    Jun 06 21:36:29 raspberrypi sudo[2725]: pam_unix(sudo:session): session opened f
    lines 1-23...skipping...
    -- Logs begin at Mo 2016-06-06 20:59:08 CEST, end at Mo 2016-06-06 21:36:29 CEST. --
    Jun 06 21:35:51 raspberrypi sudo[2698]: pi : TTY=pts/1 ; PWD=/home/pi ; USER=root ; COMMAND=/usr/sbin/service pimatic start
    Jun 06 21:35:51 raspberrypi sudo[2698]: pam_unix(sudo:session): session opened for user root by (uid=0)
    Jun 06 21:35:51 raspberrypi systemd[1]: Starting LSB: pimatic service...
    -- Subject: Unit pimatic.service has begun with start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit pimatic.service has begun starting up.
    Jun 06 21:35:51 raspberrypi pimatic[2719]: /etc/init.d/pimatic: 25: /etc/init.d/pimatic: pimatic.js: not found
    Jun 06 21:35:51 raspberrypi systemd[1]: pimatic.service: control process exited, code=exited status=127
    Jun 06 21:35:51 raspberrypi systemd[1]: Failed to start LSB: pimatic service.
    -- Subject: Unit pimatic.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit pimatic.service has failed.
    --
    -- The result is failed.
    Jun 06 21:35:51 raspberrypi systemd[1]: Unit pimatic.service entered failed state.
    Jun 06 21:35:51 raspberrypi sudo[2698]: pam_unix(sudo:session): session closed for user root
    Jun 06 21:36:29 raspberrypi sudo[2725]: pi : TTY=pts/1 ; PWD=/home/pi ; USER=root ; COMMAND=/bin/journalctl -xn
    Jun 06 21:36:29 raspberrypi sudo[2725]: pam_unix(sudo:session): session opened for user root by (uid=0)

    Edited once, last by WeaponX ().

  • Hast du es nach anleitung installiert und dan einfach noch
    sudo npm install sqlite3@3.1.3 --unsafe-perm
    Nachinstalliert


  • Hast du es nach anleitung installiert und dan einfach noch
    sudo npm install sqlite3@3.1.3 --unsafe-perm
    Nachinstalliert


    Hallo und Sorry für die späte Antwort.
    Ja habe einfach SQLite nachinstalliert. dann hats geklappt.


    MFG