EDIMAX Wlan Stick...

  • Hallo Jungs und Mädels,


    ich bin der Justus und ein Anfänger. Habe einen sehr bescheuerten Fehler den ich seit 2 Wochen versuche zu beheben.


    Mein Raspberry Pi 2 B soll mit dem Edimax Wlanstick betrieben werden. Nach 12x aufsetzen des Betriebssystem bin ich nun am Ende. Nach dem letzten aufsetzen, habe ich ein Update und ein Upgrade durchgeführt per Ethernetport. Danach habe ich den Edimax eingesteckt und per (sudo nano /etc/network/Interfaces) die Fette Zeile hinzu gefügt


    allow-hotplug wlan0
    iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
    iface default inet dhcp


    nach einem Reload ging es dann in die (sudo nano /etc/wpa_supplicant/wpa_supplicant.conf) wo ich dies schrieb


    network={
    ssid="WLAN-Name"
    psk="WLAN-Passwort"
    key_mgmt=WPA-PSK
    }


    Nach einem weiterem Reload funktionierte der Wlan Stick wunderbar und ich war begeistert (trotz dem langsamen Internetbrowsers). Doch als ich ein "sudo reboot" durchführte verschwand die Wlan anzeige und ich habe keine Chance auf meine Netzwerk Service GUI zu kommen. :s Heißt, ich gehe oben in der Leiste auf die zwei Monitore (Netzwerk) per rechtsklick und wähle den ersten punkt aus, doch es öffnet sich kein Fenster.


    Ich bin wirklich sehr verzweifelt. Eigentlich will man doch mal anfangen mit dem Programmieren.


    Bitte um dringende Hilfe
    Liebe Grüße,
    Justus

  • Hallo Justus,


    bei mir, Raspi B Rev.2, steht alles in der /etc/network/interfaces und sieht so aus



    Wichtig ist auch in /etc/modprobe.d/8192cu.conf folgendes einzufügen, um die Stromsparfunktion vom WLAN-Stick zu deaktivieren.


    Code
    options 8192cu rtw_power_mgnt=0 rtw_enusbss=0


    Vielleicht hilft's, Gruß

  • Danke für die schnelle Antwort.


    Habe es eben ausprobiert und es hat zuerst funktioniert. Doch nach dem Reboot ging wieder nichts.


    Setze das Betriebssystem nochmal auf und werde gleich über die WPA_supplicant es mal probieren.


    Ich verstehe es nur nicht, warum er nach einem Reboot den Stick nicht mehr mag und auch meine Netzwerk einstellungen nicht mehr öffnen lässt.

  • Moin,
    was hast Du für ein Netzteil angeschlossen ?


    Eventuell braucht der Stick so viel Strom, dass das Netzteil überlastet ist.
    Dann kommt es zu merkwürdigem Verhalten.


    Gruss
    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.

  • Hallo Justus,


    komisch ist das...


    Letzte Woche hatte ich einen Raspberry mit aktuellem Raspbian Wheezy aufgesetzt und auch einen WLAN-Stick eingebunden. Da gab es keine Probleme. Ich musste auch an keinen Dateien herumfrickeln. Auf der X-Oberfläche gab es ein Piktogramm, in dem ich lediglich das WLAN auswählen und das Passwort eingeben musste - fertig und läuft.



    Das andere Problem, dass der Raspberry Pi nicht hochfährt, wenn zuviel Stromfesser um den Strom für den Raspberry Pi buhlen, haben wir hier im Forum das "Mysterium" genannt. Vielleicht suchst Du mal unter diesem Stichwort und lässt Dich insbesondere von dem inspieren, was der User Zentris und ich dazu erdichtet haben.


    Ganz allgemein lässt sich aber sagen, dass sich solche Probleme durch den Einsatz eines aktiven USB-Hubs dauerhaft und nachhaltig beseitigen lassen.


    Und in der aller Regel ist dies auch ein Hinweis auf ein zu schwaches Netzteil. Was setzt Du da denn ein (Hersteller, Modell, technische Daten)?



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.