Zimmerlicht an = GPIO Falling detected

  • Hallo,


    ich bin ziemlich neu in der Welt der Elektrotechnik und bin zurzeit dran, mich über Telegram informieren zu lassen, wenn es an meiner Haustür klingelt.
    Das fuktioniert auch schon wunderbar. Nur leider, reagiert er auch an andere Ereignisse, z.B. wenn ich das Licht in einem Zimmer einschalte. ???


    Nach der Anleitung und dessen Schaltplan bin ich vorgegangen: http://blog.heimetli.ch/raspbe…wechselstrom-eingang.html


    Ich hab nun die Türklingel weggelassen und stattdessen einen Schalter dazwischen getan. Schalter zu = Falling Edge, Schalter offen = Rising Edge. Und auch hier passiert dasselbe: Nicht immer, aber häufig wird ein "Falling Edge" ausgelöst, wenn ich das Zimmerlicht einschalte.


    Mein Testskript sieht so aus:



    Woran liegt das? Mein Raspberry Pi versorg ich ganz normal über den Micro-USB-Anschluss mit Strom, liegt es daran? Mit meinem Multimeter erkenn ich keinen Spannungsabfall, wenn ich diesen zwischen GPIO und 3.3V schalte.


    Jemand eine Idee?

  • Rein von der Logik würde ich Dir recht geben ... aber wenn der Pin beim booten/Initialisieren mal auf Ausgang und LOW geht, dann hast Du da imho eine etwas unglückliche Konstellation ;) ...
    //EDIT:
    Ooops ... grad' gesehen ... noch dazu - ohne den Widerstand hättest Du beim Durchschalten des Optokopplers ja einen Kurzschluss, oder ...


    patlux ... Multimeter ist auch viel zu träge ...
    was ich gerade erst gesehen habe: Du hast den internen Pullup aktiviert? Das ist keine gute Idee, weil Du damit zwei Widerstände parallel schaltest ...


    cu,
    -ds-

  • Quote

    Ooops ... grad' gesehen ... noch dazu - ohne den Widerstand hättest Du beim Durchschalten des Optokopplers ja einen Kurzschluss, oder ...


    GANZ GENAU!


    Quote

    Ich hab nun die Türklingel weggelassen und stattdessen einen Schalter dazwischen getan. Schalter zu = Falling Edge, Schalter offen = Rising Edge. Und auch hier passiert dasselbe: Nicht immer, aber häufig wird ein "Falling Edge" ausgelöst, wenn ich das Zimmerlicht einschalte.



    werde sagen unmöglich, ABER! ich kenne Deinen schaltplan (?Stromlauf) nicht. Poste bitte die "verkabelung" (Schaltplan) - ... "wir" haben damals erfahrungen gemacht, dass eine Leuchtröhre schon entnorme probleme (Störungen) produziert hat. ...
    also -> schaltplan.


    gruß
    georg

    Sollte ich "Müll- reden" :blush: - bitte mich (?) "auf die Nuss" hauen. :huh:

  • Danke für eure Antworten!


    @[font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]georg-Lu_1963-1: [/font]Ich hab dieselbe Schaltung wie die vom verlinkten Artikel:


    [Blocked Image: http://abload.de/img/brueckee8ob2.png]


    Bei mir fehlt bloß der 560 Ohm Widerstand, da mein Oktokoppler mehr verträgt, als seiner, daher brauch ich den nicht.


    Ich hab nun den Pull-Up Softwareseitig nicht mehr aktiv, sondern nur noch Hardwareseitig (danke dreamshader).


    Den Pull-Up hab ich nun außerdem durch einen Pull-Down ersetzt, zwar wird überall empfohlen, lieber ein Pull-Up zu verwenden, aber in den meisten Anleitungen findet man dann doch eher Pull-Downs...verstehen tu ich es nicht. Jedenfalls wird der Interrupt nur mit 0V ausgelöst, wenn ich das Licht ein- und ausschalte, d.h. ein Pull-Down wäre in meinem Fall besser.
    Nunja, aber es funktioniert mit meinem Schalter. Aber mit meiner Türklingel habe ich immer noch dasselbe Problem, das wird aber wohl an der langen Leitung liegen. Ich zieh nämlich einfach nur zwei 3M lange Kabel von meiner Klingel zum Raspberry Pi.


    Wie schütz ich nun zuverlässig das Kabel von Störungen? Mit einem Ferittkern? Ist das dann zuverlässig gegen Störungen abgesichert oder braucht man da noch etwas?


    Das Testskript hab ich etwas angepasst:



    Ich denke ich werde mir nun paar Ferritkerne bestellen..

  • Nö ... ich dachte da schon daran, das Kabel gegen ein Netzwerk-Kabel oder ähnlich geschirmtes auszutauschen ;) ... drei Meter sind doch nur ein Fetzen ... oder? ;)


    btw: die zwei Drähte ... hast Du die verdrillt? Das könnte auch schon Abhilfe schaffen ...


    cu,
    -ds-

  • Ah ok :D Das Wort "Fetzen" brachte mich auf die Idee, dass du es vielleicht so meintest :D
    Ich will kein "fettes" Netzwerkkabel verlegen (sonst brauch ich ein dickeren Kabelkanal :D), deswegen wäre es schon besser, wenn ich das mit den zwei Drähten hinbekommen könnte.


    Die zwei Drähte sind nicht verdrillt, vielleicht ein paar Mal drum herum gewickelt, aber von Verdrillung kann da nicht die Rede sein. Ich verdrill die morgen abend mal und versuch es noch einmal. Vielen Dank für den Tipp! :bravo2:

  • [font="Arial"]Hi,[/font]
    [font="Arial"]

    Quote

    Bei mir fehlt bloß der 560 Ohm Widerstand, da mein Oktokoppler mehr verträgt, als seiner, daher brauch ich den nicht.

    [/font]
    [font="Arial"]! - NICHT zum Empfehlen- ![/font]
    [font="Arial"] [/font]
    [font="Arial"]Meine Erfahrung mit ?Mikro / Prozessoren hat folgendes ergeben:[/font]
    [font="Arial"]- Sensoren .... / .... Aktoren (wenn es vorkommen soll) werden mit einem Abgeschirmten Kabel verbunden. (Wie der dreamshader das AUCH! Betont hat.) [/font]
    [font="Arial"]Ich benutzte keine Netzwerkkabel, SONDERN richtig Abgeschirmte Kabel.[/font]
    [font="Arial"]D.h. - jede Ader ist abgeschirmt. .... -> Sicher ist sicher [/font]
    [font="Arial"]In Kritischen (wo wirklich "alles Strahlt") Räumen hilft nur eine volle Abschirmung; d.h.:[/font]
    [font="Arial"]Den Prozessor (hier den Raspi) in eine Entstörung- Metallgehäuse einzupacken.[/font]
    [font="Arial"]Hyyyy - was für ein Ding? - Gucke Dir Dein PC- Netzteil - es befindet sich in einer Entstörung- Metallgehäuse.[/font]
    [font="Arial"]Ich habe es so (im Raum wo es wirklich Phänomene [was Störungen angeht]) gemacht und bestätige hierbei, dass es funktioniert hat. Die Ferritkerne haben bei mir (sehr viel Strahlungen) nicht funktioniert.[/font]
    [font="Arial"] [/font]
    [font="Arial"]Fazit:[/font]
    [font="Arial"]- Sensoren immer mit einem Abgeschirmten Kabel verbinden[/font]
    [font="Arial"]- Im "Fatalfall" den Prozessor in eine Entstörung- Metallgehäuse "packen" [/font]
    [font="Arial"]- Fast Vergessen! -> die Entstörung- Metallgehäuse und Abschirmung mit der Masse / GND verbinden.[/font]
    [font="Arial"] [/font]
    [font="Arial"]Was Deine Schaltung betrifft, -> sollte ich mir SICHER sein, dass die Störungen von der Klingeln- Seite kommen, werde ich so was [font="Arial"]VERSUCHEN:[/font][/font]
    [Blocked Image: http://abload.de/img/schaltplanjcsv2.jpg]


    [font="Arial"]Kleine Störungen werden am Punkt A wahrgenommen, jedoch im Punkt B nicht! -> solange eine Zeitliche Relation (RC) beibehaltet wird. Kurz;[/font]
    [font="Arial"]Dein Oktokoppler schaltet NUR dann, wenn die Spannung am C1 der "Auslöser Spannung" des Oktokoppler gleich oder mehr ist. [/font]
    [font="Arial"]( also ...die Spannung, welche für die LED- Emission des Oktokoppler benötigt wird.)[/font]
    [font="Arial"]NUR! ein lange Impuls (Klingeln) wird den Kondensator C1 laden können, so das der die "Auslöser Spannung" des Oktokoppler erreicht.[/font]
    [font="Arial"]Ich lasse hier die Mathe wie auch die Werte AUS. Warum?[/font]
    [font="Arial"]Weil wenn jemand gerade keinen 1uF Elko parat hat - ! - aber einen 4,7uF schon![/font]
    [font="Arial"]ist der "auch dabei". Mit dem Poti (?Verstellbareswiderstand) ist auch nicht kritisch. 5K - oder 100k - einfach ausprobieren*[/font]
    [font="Arial"] [/font]
    [font="Arial"]

    Quote

    Den Pull-Up hab ich nun außerdem durch einen Pull-Down ersetzt,

    [/font]
    [font="Arial"]Bitte nachdenken - Pull-Up ist bei Dir schon OK![/font]
    [font="Arial"] [/font]
    [font="Arial"]Gruß[/font]
    [font="Arial"]Georg[/font]
    [font="Arial"] [/font]
    [font="Arial"]* - ???[/font]
    [font="Arial"]Tipp[/font]
    [font="Arial"]Poti soll nicht kleiner als 1K --- und nicht größer als 100K sein[/font]
    [font="Arial"]Elko soll nicht kleiner als 2.2uF --- aber nicht größer als 10uF sein[/font]
    [font="Arial"] [/font]
    Automatisch zusammengefügt:
    [hr]

    Sollte ich "Müll- reden" :blush: - bitte mich (?) "auf die Nuss" hauen. :huh:

    Edited once, last by georg-Lu_1963-1 ().

  • Hi, danke erstmal für deine Hilfe, georg-Lu_1963-1. Die Störungen kommen allerdings nicht von der Klingelseite, wie gesagt, ich hatte dasselbe Problem auch, als ich die Klingel durch einen normalen Schalter ersetzt habe. Dabei hab ich aber dasselbe 3M lange Kabel benutzt und dennoch sind die Störungen aufgekommen. Kann also nur am Kabel liegen, ich werde am Wochenende mal die zwei Drähte verdrillen und gucken obs dann immer noch vorkommt, die Ferritkerne sind auch schon bestellt, dauert aber einige Wochen bis die da sind, da sie aus China geliefert werden. Wenn das alles nicht klappt, dann verzichte ich auf die Kabellösung und schau ob ich das ganze mit einem ESP8266 hinbekomme.

  • Wo sind die 3m Kabel: Vor oder nach dem Optokoppler ?


    Der Optokoppler und der Widerstand sollen so nahe wie moeglich zum Pi !


    Auf der anderen Seite gibt viel es weniger EMV-Probleme weil es einen groesseren
    Strom braucht. Wenn doch: an jedem Ende des Kabels ein 10k-Widerstand sollte
    die Einstrahlungen deutlich daempfen.


    Ein RC-Glied wie vorgeschlagen schadet sicher auch nicht, aber das duerfte
    eigentlich nicht noetig sein.


    Achtung: ALLES was am PI haengt, kann die EMV beeinflussen:
    * Ist das Netzteil anfaellig auf Stoerungen ?
    * Hat es noch Reserven ?
    * Wie lang ist das Kabel zum Netzteil ?
    * Wo fuehrt es durch ?
    * Was haengt sonst am PI ?


    Auch wenn sich die Stoerung am Eingang manifestiert, ist keineswegs sicher
    dass die Einstrahlung dort passiert...