Offizielles Raspberry Pi 7'' Display


  • Klassischer Fall von 'Frust durch Fehlinformationen'


    Ich vermute mal du hast 'display_rotate=2' verwendet aber nicht das eigentlich vorgesehene lcd_rotate=2 ... Ersteres funktioniert zwar auch aber dann rotiert (wie du gemerkt hast) die Touch-Funktion nicht mit. display_rotate ist die alte Einstellung wie es auch für HDMI funktioniert.



    Ich trage btw grad alle nützlichen Informationen zusammen und füge diese in meinen ersten Beitrag hier im Thread (#4) ein: http://www.forum-raspberrypi.d…play?pid=173663#pid173663


  • @raspiproject
    Vorab, weil es wohl wieder Vollmond wird oder heute Empfindliche unterwegs sind - das ist eine Frage, keine Kritik!


    Hast du dir mal das Polystyren Gehäuse genauer angesehen? Wenn ich das richtig sehe, dann ist der HDMI Ausgang (und damit auch der Micro-USB Port und der Audio Ausgang des Pi) beim Farnell bzw. Multicomp Gehäuse Oben. Wenn ich mir das aber - nach dem letzten Firmware Update, das ja den DSI Output dreht um einen besseren Blickwinkel auf das Display zu gewährleisten - durch den Kopf sacken lasse, dann wären die Ausgänge damit genau falsch positioniert. Kannst du das bestätigen?


    Ich sehe in Deiner Frage keine Kritik, zumal ich das Gehäuse nicht entworfen habe. Auch ich finde das ganz schön peinlich mit dem Display, sowas sollte eigentlich nicht passieren, zumal da ein ganz anderes Entwicklungsvolumen dahinter steht. Aber man soll nicht mit Glashäusern werfen, wenn man auf einem Steinhaufen sitzt. Bei meiner Relaiskarte ist der Transistor auch falsch rum gedruckt, aber man kann ja nicht 1000 Platinen einfach wegwerfen. Vielleicht könnt Ihr mich ja für das nächste Gehäuse beschimpfen, ich habe für die Firma einen 3D Drucker geordert und wir wollen nun mindestens ein paar Prototypen in Sachen Robotik machen.


    So nun zum Thema. Das Gehäuse hat so richtig kein unten und oben. Der unförmige Kasten hinten dran (das eigentliche Gehäuse) hat aber logischerweise die Aussparungen für Netzwerk, HDMI usw.. Dadurch ist die Lage des Displays vorgegeben. Trotzdem steht das Display in beide Richtungen. Einmal direkt auf der abgewinkelten Gehäusekante und dem Rahmen und einmal leigt es irgendwie auf den Kabeln (die dann nach unten zeigen) und dem Rahmen etwas steiler. In beiden Fällen ist der Blickwinkel an einem normalen Tisch genau richtig. Dadurch das das Display kapazitiv ist und man keinen Druck ausüben muss rutscht es auch nicht weg, das war bei meinem Pollindisplay ein Problem.


    OT Ich habe es nochmal beobachte, es ist definitif kein Vollmond. Es muss ander Ursachen haben :lol:

  • Das Display funktioniert ausnahmslos an jedem RaspberryPI Modell.


    Was aber Probleme verursachen kann ist die Stromversorgung. Das Display benötigt mind. 430mA. Alle PI Modelle vor B+ haben eine Polyfuse welche den Strom auf max. 1A begrenzt. Der PI benötigt aber mind. 700mA für sich selbst. Wer also mit älteren PI's vor hat das Display über den PI mit Strom zu versorgen wird hier Probleme kriegen.
    Ihr müsst dann also euer Netzteil ans Display anschließen und von dort geht ihr, wahlweise über GPIO oder dem PWR-Out USB, erst zum PI. Dann funktioniert auch das problemlos (sofern das Netzteil genug Ampere liefern kann).


  • Das Display funktioniert ausnahmslos an jedem RaspberryPI Modell.


    Was aber Probleme verursachen kann ist die Stromversorgung. Das Display benötigt mind. 430mA. Alle PI Modelle vor B+ haben eine Polyfuse welche den Strom auf max. 1A begrenzt. Der PI benötigt aber mind. 700mA für sich selbst. Wer also mit älteren PI's vor hat das Display über den PI mit Strom zu versorgen wird hier Probleme kriegen.
    Ihr müsst dann also euer Netzteil ans Display anschließen und von dort geht ihr, wahlweise über GPIO oder dem PWR-Out USB, erst zum PI. Dann funktioniert auch das problemlos (sofern das Netzteil genug Ampere liefern kann).


    Hallo meigrafd,
    stimmt leider nicht.
    Gordon (von der Foundation) schrieb dazu in seinem Blog


    Quote


    Unfortunately the B didn’t have the right I2C connections down the DSI connector. That’s one of the reasons for the extra pins on the display conversion board.
    Will investigate what changes (software and jumper wires) would be required, but I would suggest a B+ / 2B / A+ would be the easiest addition
    Gordon


    siehe dazu auch diesen thread:
    Official display and RPi "B"


    Es wurde schon im Vorstellungblog des Displays (Blog) moniert.
    Beim dem RPI ist die I2C Verbindung nicht an dem dem Steckverbinder (S2) für das Display angeschlossen.
    Bei dem B+ und dem RPI 2 B ist der I2C Bus angeschlossen. Über dem I2C Bus werden einige Parameter (Helligkeit, Power) gesteuert. Wie oben zitiert will Gordon eine Lösung finden, es funktioniert bei mir aber auch mit der allerneusten Software
    (rpi-update) von gestern noch nicht.
    Darum bin ich jetzt etwas erstaunt das es bei Beetlevirus jetzt läuft.



    Ich habe 2 alte Raspis, bei dem einen habe ich den I2C Bus an den Displayanschluß angeschlossen (siehe auch den obeb erwähnten Thread), damits funktioniert es dann.




    Ach ja, der Raspi ist so angeschlossen wie Du es oben vorgeschlagen hast.


    Ait


  • SEHR GUTER HINWEIS! :bravo2:


    Auch die zusammengetragene Doku finde ich Prima!
    Wenn jetzt noch die Möglichkeit eruiert würde beide Displays zu nutzen ohne den OMX Player nutzen zu müssen ... wäre das perfekt.


    Ich selber habe RASPIAN auf dem PI2 und starte dann eine KODI (XBMC) Oberfläche.
    Auf dieser XBMC Oberfläche würde ich gerne dann die Videos auf dem Touchscreen auswählen, das Video selber aber dann auf dem Bildschirm HDMI ausgeben....



    Apropo Netzteil:
    Wäre es nicht eine Idee ein Netzteil zu nehmen und jeweils Display und PI2 separat mit einer eigenen Spannungsversorgung (KABEL) an das Netzteil anzuklemmen ?
    bei 0,5A für das Display tue ich mich ein wenig schwer diese Last über die GPIO zu schicken ... wenn es anders geht.


    zur Spannungsversorgungsarchitektur:
    Printtrafo mit 230V:9V
    V
    Schaltregler mit 5V 3A (gibt es bei Aliexpress als fertigen Baustein: LM2596s)
    V V
    PI2 DISPLAY

  • Habe ein Angewinkeltes USB Kabel genommen, Power geht in die Display Platine und von da mit dem Kabel in den PI.
    Leider bin ich zu Blond um hier ein Bild anzuhängen !:-)


    http://imgur.com/lobT5Pp

  • Die Idee von R1F800 kam mir auch Kodi Oberfläche auf dem TFT und dann Filmausgabe auf HDMI.
    Reichelt rund 200 Euro (Raspi 2 Bundle, TFT Display und dafür das Gehäuse)

  • Inhalte mit unterschiedlichen Auflösungen darzustellen bedarf enormen Rechenaufwand und ist Sache der Software, also in diesem Fall XBMC bzw KODI. Das hat nichts mehr mit der Firmware oder sowas zu tun. Mit omxplayer war es z.B. auch erst nach einer Anpassung möglich, omxplayer musste also dahingehend modifiziert werden das es nicht nur eine Ausgabe auf dem Primären Device ermöglicht. Selbst X (LXDE) kann das nicht und das hat nichts mit DSI, HDMI oder sonst was zu tun.



    R1F800: Ich versteh nicht wo das Problem is? Aufgerundete 0,5A über die 5V Schiene des PI's zu schicken ist überhaupt nicht schlimm - er verkraftet ja auch problemlos 1,2A über USB auszugeben.
    Die GPIO haben damit btw nichts zu tun. Es befindet sich zwar alles auf der GPIO-Stiftleiste aber die 5V Pins kommen direkt von der microUSB-Polyfuse und gehen nicht erst zum SoC (von dem ungebuffert die GPIO's kommen)


    Rasby: Wenn du dich im Editor des Forums befindest kannst du ganz unten "Attachments" hinzufügen. Achte nur darauf keine zu großen *.png's anzuhängen da es ein Limit gibt. Wandel die *.png's am besten vorher mit Paint o.ä. in *.jpg um.. Oder lad die Bilder auf zB http://imgur.com hoch und poste hier nur den Link, oder nutze [ img] [/img] (ohne leerzeichen)...


  • Inhalte mit unterschiedlichen Auflösungen darzustellen bedarf enormen Rechenaufwand und ist Sache der Software, also in diesem Fall XBMC bzw KODI. Das hat nichts mehr mit der Firmware oder sowas zu tun. Mit omxplayer war es z.B. auch erst nach einer Anpassung möglich, omxplayer musste also dahingehend modifiziert werden das es nicht nur eine Ausgabe auf dem Primären Device ermöglicht. Selbst X (LXDE) kann das nicht und das hat nichts mit DSI, HDMI oder sonst was zu tun.


    Dass es nicht einfach geht ist mir klar. es wäre ja auch eine Möglichkeit die Monitore DSI > HDMI > DSI über eine einfache Möglichkeiten umzuschalten ... schon wäre mein "Problem" bzw. Wunsch befriedigt.


    Ich bin halt von falschen Voraussetzungen ausgegangen, nämlich dass beide Display parallel den Videodatenstrom bekommen und umsetzen.


    Was ich aber losgelöst von der Umschaltmöglichkeit noch nicht hinbekommen habe ist die Kalibrierung des Touchfeldes. WEDER unter RASPIANnoch unter KODIs XBMC...



    R1F800: Ich versteh nicht wo das Problem is? Aufgerundete 0,5A über die 5V Schiene des PI's zu schicken ist überhaupt nicht schlimm - er verkraftet ja auch problemlos 1,2A über USB auszugeben.
    Die GPIO haben damit btw nichts zu tun. Es befindet sich zwar alles auf der GPIO-Stiftleiste aber die 5V Pins kommen direkt von der microUSB-Polyfuse und gehen nicht erst zum SoC (von dem ungebuffert die GPIO's kommen)


    Nun sagen wir es ist kein Problem. Ich will einfach separate Spannungsversorgungslinien haben.


  • Habe ein Angewinkeltes USB Kabel genommen, Power geht in die Display Platine und von da mit dem Kabel in den PI.
    Leider bin ich zu Blond um hier ein Bild anzuhängen !:-)


    http://imgur.com/lobT5Pp


    Hallo rasby,
    bitte poste Deine Bezugsquelle für das Kabel, Danke.


    Gruss
    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.

  • Übrigens, das Gehäuse von Farnell hat den Anschluss für die Stromversorgung von Display und PI an der Stelle, an der der PI (B+/B 2) seinen Anschluss hat, nicht an der Stelle, an der der Anschluss von der Display-Platine liegt.

    Selber denken,
    wie kann man nur?

  • Hat eigentlich schon jemand herausgefunden, wie man (wenigstens) die Hintergrundbeleuchtung des Displays abschalten kann?
    Komplett abschalten ist keine Option und wäre ja auch zu einfach. Wenn ich das Display von der Stromversorgung trenne, ist nach dem Einschalten nix zu sehen, weil das Display offenbar beim Booten mit initialisiert werden muß.
    Der Pi soll ja aber ständig laufen und nicht jedes Mal, wenn das Display benötigt wird, neu gebootet werden müssen. Ist bei einem Server irgendwie unpraktisch ;-).
    Da wäre es schön, wenn man wenigstens die Hintergrundbeleuchtung dimmen oder temporär ganz abschalten könnte.


    Ansonsten finde ich es schon ziemlich straff, dass das Display damit beworben wird, dass es an *allen* Versionen des Raspi funktioniert, nur eben die Bohrungen für die Befestigung nicht passen. Das ist ja nun definitiv nicht der Fall... Oder gibt es da schon eine (einfache) Lösung ohne an den winzigen SMD-Widerständen eine Kunstverdrahtung anlöten zu müssen?


    Gruß
    Kurt


  • Hat eigentlich schon jemand herausgefunden, wie man (wenigstens) die Hintergrundbeleuchtung des Displays abschalten kann?


    Wenn ich es richtig im Hinterkopf habe, dann ist ein Update geplant um die Hintergrundbeleuchtung des Displays per Software abschalten zu können - das vernahm ich, im englischen Forum, aus den Pi Towers...


    Irgendwo weiter vorne in diesem Thread habe ich meine Verkabelung beschrieben, ich versorge das RaspiDisplay über die GPIO Leiste mit Strom. In dieser Kombination schaltet der Pi die Hintergrundbeleuchtung aus, wenn er den Bildschirm abschaltet und wacht brav wieder auf, wenn man erneut auf ihn zugreift.

  • Wenn ich es richtig im Hinterkopf habe, dann ist ein Update geplant um die Hintergrundbeleuchtung des Displays per Software abschalten zu können - das vernahm ich, im englischen Forum, aus den Pi Towers...


    Irgendwo weiter vorne in diesem Thread habe ich meine Verkabelung beschrieben, ich versorge das RaspiDisplay über die GPIO Leiste mit Strom. In dieser Kombination schaltet der Pi die Hintergrundbeleuchtung aus, wenn er den Bildschirm abschaltet und wacht brav wieder auf, wenn man erneut auf ihn zugreift.


    Öhm... echt? Kann ich kaum glauben. Das würde ja bedeuten, dass der Pi der der I/O-Leiste komplett den Saft abdreht, wenn der Bildschirm dunkel geschaltet würde.
    Und da wird dann das Display jedes Mal neu intitialisiert?
    Na gut, ich werd es mal testen...

  • Hallo Mitstreiter,


    auch ich habe am RPi2 das offizielle Touchscreen Display im Einsatz und benötige hier Eure Hilfe.


    Das Display ist konfiguriert/kalibriert und der RPi2 startet in die GUI.


    1. Problem


    Ich habe in der GUI nur den LXTerminal und den Trash


    --> keine Taskleiste oder sonstiges


    Wenn ich google.de bemühe, sieht überall die GUI anders aus und hat auch eine Taskleiste :) z.b.:



    http://www.kwartzlab.ca/2012/0…pi-windows-desktop/pigui/


    2. Problem


    Ich habe mal Anhänge vorbereitet, mich quält so eine weiße Leiste im oberen Bildschirmrand. Diese poppt stetig auf und und springt wieder weg.
    Was ist das? Und wie kann man das verhindern?


    Der Touchscreen soll letztlich nur einen Browser darstellen, worüber ich meine Hausautomation steuern kann :)


    Grüße
    Christian