Jessie Installation

  • Hallo Wissende,


    ich habe mir gestern das neueste Raspbian (Jessie) für meinen Raspbi der ersten Generation heruntergeladen und installiert. BS startete, ich konnte aber kein Update machen. Folgender Hinweis:


    E:Fand einen Abschnitt ohne Paket: header
    E:Problem MergeList / var / lib / dpkg / status
    E:Paketlisten oder Statusdatei konnte nicht analysiert oder geöffnet werden.


    Mit "googlen" bekam ich folgende Lösung angeboten:


    [font="Times New Roman"]$ Sudo rm / var / lib / dpkg / status
    $ Sudo touch / var / lib / dpkg / status
    $ Sudo apt-get update


    Hat nicht funktioniert.


    Weil ich dachte, es könnte auch ein Übertragungsfehler beim Downloaden sein, habe die BS nochmal neu heruntergeladen und nochmal neu auf die SD-Karte gebracht. Start einwandfrei, aber Update mit den gleichen Hinweisen nicht möglich.


    Was läuft da wohl falsch? Wer kann helfen?


    Gruß


    treasoner


    [/font]
    [font="Times New Roman"]. [/font]

    Edited once, last by treasoner ().

  • Moin,
    sudo apt-get update -> Paketlisten aktualisieren, hat eben bei mir noch funktioniert
    sudo apt-get upgrade -> Jessie aktualisieren, liefert noch keine Updates, da keine vorhanden


    Gruss
    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.


  • Hallo Kurti,


    "upgrade" sehe ich ein, da das BS so neu ist, daß wahrscheinlich noch nichts vorliegt. Bei mir kommen aber die aufgeführten Fehlermeldungen schon nach "update". Ich kann "upgrade" also gar nicht ausführen!


    Gruß


    treasoner

  • Hi,


    was sagt den deine Package liste ? ( /etc/apt/sources.list) bzw. /etc/apt/sources.list.d/*


    Gruß Joiyco


  • Hi,


    was sagt den deine Package liste ? ( /etc/apt/sources.list) bzw. /etc/apt/sources.list.d/*


    Gruß Joiyco


    Hallo Joiyco,


    ja, die etc/apt/sources.list gibt es nicht, die etc/apt/sources.list d zeigt an: No subfolders, ist also leer.
    Alle Ordner unter apt haben keine Unterordner, warum auch immer.


    Der Befehl rm /status gibt denn auch aus: cannot remove /status: No such file or directory.


    Ist also gar nicht installiert, obwohl zweimal Download und zweimal SD-Karte beschrieben.


    Die Originalantwort nach sudo apt-get update ist:


    E: Encountered a section with no Package: header
    E: Problem with Megelist /var /lib /dpgk /status
    E: The package lists or status fille could not be parsed or opened


    Gruß


    treasoner

    Edited once, last by treasoner ().

  • ja, die etc/apt/sources.list gibt es nicht, die etc/apt/sources.list d zeigt an: No subfolders, ist also leer.
    Alle Ordner unter apt haben keine Unterordner, warum auch immer.


    Und deshalb kommen folgende Fehlermeldungen:




    E: Encountered a section with no Package: header
    E: Problem with Megelist /var /lib /dpgk /status
    E: The package lists or status fille could not be parsed or opened


    Entweder weißt Du nicht was Du tust oder Du tust das falsche.


    Wie aber kann es sein, dass Du ein offensichtlich neues Image hast, das so einen Fehler hat. Irgendwas stimmt doch da nicht..


    Woher hast Du das Image?


    Wie bringst Du es auf Deine SD-Karte?

    Edited once, last by PatrickS ().

  • Hallo zusammen,



    Es ist ein gewaltiger Unterschied, ob man

    Code
    1. /etc/apt/sources.list


    oder

    Code
    1. etc/apt/sources.list


    verwendet.


    Das erste ist die absolute Pfadangabe zu einer Datei, die unter Linux auch existiert.


    Das zweite verweist auf eine Datei im aktuellen Verzeichnis - im Zweifelsfall [font="Courier New"]/home/pi/etc/...[/font]


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Moin,
    so habe ich es gemacht:
    1. Image herunterladen von https://www.raspberrypi.org/downloads/
    2. nicht mit Windows-Entpacker entpacken sondern z.B. mit 7zip, da die entpackte Datei über 4 GB hat
    3. nicht auf eine Festplatte entpacken, die FAT32 formatiert ist. Da die entpackte Datei über 4 GB hat und das auf FAT32 nicht funktioniert, NTFS ist gut
    4. img auf SD-Card übertragen, ich habe Win32DiskImager-0.9.5 genommen
    5. starten und glücklich sein


    Gruss
    Kurti


    Edit: Fehler und Ungenauigkeiten beseitigt

    Die beste Funkverbindung ist immer noch ein Kabel.

    Edited once, last by Kurti ().

  • Hallo zusammen,


    herzlichen Dank für Eure Antworten, die ich allerdings ein weinig kommentieren muß:



    @PatrickS
    "Entweder weißt Du nicht was Du tust oder Du tust das falsche"
    Glaube ich nicht. Ich bin ein Raspberry-Jünger, der einen der ersten überhaupt schon hatte. Karten habe ich schon x-mal beschrieben und bisher hat es auch jedesmal funktioniert. Das Image stammt von hier https://www.raspbian.org/RaspbianImages und wurde mit dem win32diskimager auf die Karte gebracht. Also: Ich weiß schon, was ich tue, falsch kann es immer mal sein.



    Kurti
    so habe ich es gemacht:
    1. Image herunterladen von https://www.raspberrypi.org/downloads/
        s.o. Über diese Adresse lande ich auf der gleichen Seite, die Du angeführt hast.
    2. nicht mit Windows-Entpacker entpacken sondern z.B. mit 7zip, da die entpackte Datei über 4 GB hat
    Ich auch
    3. nicht auf eine FAT32 Partition entpacken, da die entpackte Datei über 4 GB hat und das auf FAT32 nicht funktioniert, NTFS ist gut
    Meine Karte war FAT32 partitioniert, könnte ja der entscheidende Hinweis sein. Allerdings ist ja sonst alles auf der Karte; ich hab also gewisse Zweifel. Trotzdem werde ich es probieren.
    4. iso auf SD-Card übertragen, ich habe Win32DiskImager-0.9.5 genommen
    Ich gehe davon aus, daß Du img meinst.
    5. starten und glücklich sein
    [color=#3399ff]Ich werde berichten.


    Gruß
    treasoner

    Edited once, last by treasoner ().

  • Kurti
    3. nicht auf eine FAT32 Partition entpacken, da die entpackte Datei über 4 GB hat und das auf FAT32 nicht funktioniert, NTFS ist gut
    Meine Karte war FAT32 partitioniert, könnte ja der entscheidende Hinweis sein. Allerdings ist ja sonst alles auf der Karte; ich hab also gewisse Zweifel. Trotzdem werde ich es probieren.
    4. iso auf SD-Card übertragen, ich habe Win32DiskImager-0.9.5 genommen
    Ich gehe davon aus, daß Du img meinst.


    3. wie Deine Karte formatiert ist, ist egal. Das überschreibt Win32DiskImager sowieso.
    Wichtig ist die Formatierung Deines Datenträgers, auf den Du die heruntergeladene Datei entpackst (zip -> img)


    4. img ist natürlich richtig, sorry


    Gruss
    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.

  • Ich habe eben Jessie mit dem oben genannten Image problemlos installiert.


    Update und Upgrade liefen einwandfrei durch, sogar ein rpi-update klappt problemlos.


    Das Einzige, was ich hatte war, dass beim rpi-config / Partition vergrößern ne Meldung kam, dass die Partitionstabelle nicht neu eingelesen werden könne, da das Gerät (die SD Karte) in Benutzung wäre.
    Es hat aber trotzdem funktioniert.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic/Win10IoT) / 2x Pi Zero 1.2 (J. Lite)
    2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0

  • @ Outlaw
    Danke für die Mitteilung.


    Kurti
    1. Nochmals auf SD installiert, so, wie wir es geschrieben haben. Keine Änderung.
    2. Nochmals eine neuen Dowload gemacht, dazu windiskimager 0.95 (hatte bisher 0.92).


    Ein Wunder, jetzt funktioniert alles so, wie es soll. Leider kann ich nun nicht sagen, lag es am Download (zweimal defekt?) oder an 0.95. Egal, jetzt bin ich wieder glücklich.


    Nochmals herzlichen Dank für Deine Unterstützung.


    Gruß


    treasoner

  • Hi,
    schön, dass es jetzt funktioniert und Danke für die Rückmeldung.


    Gruss
    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.