Keine GUI bei Jessie

  • Servus,


    habe soeben Raspbian Jessie von https://www.raspberrypi.org/downloads/raspbian/ auf mein neues Raspberry Pi 2 geflashed. Der Bootvorgang läuft einwandfrei, jedoch erhalte ich anschließend keine GUI, und auch mit startx lässt sich nichts auf den Bildschirm bringen außer die Console. (Error: org.freedesktop. Policy Kit1.Error.Failed:An authentication agent already exists for the given subject.")


    -> Meiner Meinung nach funktioniert die GUI bereits, jedoch sehe ich außer der Console keine weiteren Elemente.


    Würde mich über Tipps freuen. :)

  • Direkt mittels Tastatur/Maus. Sind angeschlossen, ja.



    Die Console funktioniert auch einwandfrei, jedoch kriege ich die eigentliche GUI nicht zum laufen. An der Config wurde noch nichts herumgebastelt, habe Jessie direkt auf die SD-card geflasht und gebootet.

    Edited once, last by maetho ().

  • Naja, letztes Mal, dass diese Frage kam, wurde versucht die GUI über SSH zu starten... das funktioniert natürlich nicht so ohne weiteres. Daher frage ich.
    Hast du im raspi-config "start to GUI" oder soetwas aktiviert?

  • Ja habe ich auch gelesen. ;)


    Nein im raspi-config habe ich keine Zeile auskommentiert oder ergänzt, sprich hierbei handelt es sich um das originale OS auf der angegebenen Seite.
    Mich wundert es eben, dass die Meldung kommt dass bereits eine GUI läuft (soweit verstehe ich die genannte Fehlermeldung). Jedoch habe ich außer der Console keine weiteren Elemente. Kann zwar zwischen den 4 Desktops hin und her switchen, jedoch sind alle 4 schwarz nur eben aufm ersten ist die Console.


    Ein einfaches "startx" funktioniert eben nicht. (An authentication agent already exists for the given subject. )

  • Hallo maetho,



    Kann zwar zwischen den 4 Desktops hin und her switchen, jedoch sind alle 4 schwarz nur eben aufm ersten ist die Console.


    Wie schaltest Du zwischen den 4 Desktops hin und her?


    Meiner Meinung nach sind das die Desktops, die auch die GUI enthalten - nur dass dort keine Elemente / Panel / Piktogramme / Anwendungsmenü etc. angezeigt werden. Dies hätte dann eine andere Ursache.


    Soweit ich gelesen habe, startet Jessie voreinstellungsgemäß direkt in die GUI.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.


  • Servus,


    mit einem einfachen Rechtsklick und anschließendem auswählen eines Desktops. Das ist korrekt, sämtliche Bedienelemente fehlen, dementsprechend passt die Fehlermeldung schon, jedoch kriege ich eben die Bedienelemente etc nicht zum laufen. Kann mir schwer vorstellen dass die GUI ohne deren gestartet wird?

  • Moin.
    da mitlerweile einige User Probleme haben, Jessie korrekt zu installieren,
    habe ich den Verdacht, dass es mit der Grösse der img-Datei zusammen hängen könnte.


    So habe ich erfolgreich Jessie auf einer Micro-SD-Xard mit 8 GB installiert:
    http://www.forum-raspberrypi.d…tion?pid=178968#pid178968


    Der User hatte auch merkwürdige Probleme beim Installieren.
    Eventuell hat ihm das Update von Win32DiskImager-0.9.5 geholfen.


    Gruss
    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.

  • Hallo,


    vielen Dank Kurti. Ich werde aufjedenfall nochmal alles neu flashen. Ich vermute auch, dass der Fehler da liegt obwohl ich ebenfalls eine 8GB Karte benutze, mit Win32DiskImager-0.9.5 geflashed habe. Aber an irgendetwas muss es ja liegen, und es sieht wirklich danach aus, dass das OS nicht korrekt aufgespielt wurde. Ich melde mich dann nochmal hier, sofern ich erfolgreich war oder eben nicht. ;)


    Gruß

  • Hallo zusammen,


    Kurti: Danke!


    Vor ein paar Tagen habe ich einen Beitrag gelesen, wonach das Jessy-Image für die üblichen Programme, die zum Flashen eines Betriebssystems auf die SD-Karte vewendet werden, zu groß ist. Dem Artikel habe ich aber keine große Bedeutung beigemessen, da ich (noch) nicht mit Jessie arbeite. Sobald ich den Beitrag wieder gefunden habe, setze ich einen Link hier rein. ;)


    So weit ich mich erinnern kann, wurde ein anderes Programm zum Entpacken vorgestellt. Mit diesem funktioniert dann alles Weitere.



    EDIT: Ich wurde fündig dort Beitrag #8 ... von ... trara ... Kurti! :danke_ATDE:


    Wenn dieser Beitrag öfters gefunden wird, dann sollten auch die unzähligen Probleme der Jessie-Nutzer nach einer Neuinstallation der Vergangenheit angehören.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited 3 times, last by Andreas ().

    • Official Post
    Quote

    o weit ich mich erinnern kann, wurde ein anderes Programm zum Entpacken vorgestellt. Mit diesem funktioniert dann alles Weitere.

    nutzt wirklich einer den Windowsentpacker? (offensichtlich ja....aber....) ;). Winrar/7Zip gehören doch seit Jahren auf jedes System

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

    Edited once, last by dbv ().


  • Danke für die Blumen.
    Ich hatte im Internet einen Beitrag gelesen, dass der interne Windows-Entpacker mit 4GB und größer nicht klar kommt.
    Ich setze schon lange 7zip ein.
    Dieser Packer ist Open Source-Software und man kann die Sprache auf 'Deutsch' stellen.
    Ausserdem gibt es außer der Möglichkeit zu installieren eine portable Version .
    Ich bin mit dem Packer sehr zufrieden.


    Gruss
    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.

  • Problem gelöst - liegt wohl wirklich am Windows-Entpacker. Jessie läuft nun ohne Probleme - ebenfalls der USB/Wlan Adapter bereitete keinerlei Probleme bislang.


    Großes Danke an euch!

  • Nach dem Flashen muss die Partition per raspi-config vergrößert werden und ich habe die Erfahrung gemacht, dass wohl ohne Änderung die Standardeinstellung für den Grafikbereich kein Speicher zugewiesen wird (0). Dies kann man ebenfalls in raspi-config ändern.


    Und die SD muss min. 8 GB groß sein.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Es steht doch schon im Thread auf https://www.raspberrypi.org/, in dem über die Bereitstellung von Jessie berichtet wird, dass wegen der Größe des Images man die ZIP-Datei nicht mit dem Windows-Entpacker entpacken könne
    (TGZ wäre da wohl besser gewesen, da versucht es erst keiner mit dem im Windows integrierten Entpacker..)

    Selber denken,
    wie kann man nur?