Lan + wlan gleichzeitig

  • Muss nochmal was fragen
    hab wlan stick am raspberry, der wlan stick ist mit handy verbunden
    lankabel hängt am pc und am raspberry aber gleichzeitig wlan und lan geht nicht :-(
    erst dann wenn ich lankabel entfernen die /etc/network/interfaces ändere dann gehts.
    so habe ich es schon versucht


    auto lo
    iface lo inet loopback


    auto eth0
    iface eth0 inet static
    address 192.168.0.105
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1
    dns-nameservers 8.8.8.8 8.8.4.4



    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp
    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet dhcp
    wpa-ap-scan 1
    wpa-scan-ssid 1
    wpa-ssid "Wlan Name"
    wpa-psk "Passwort"


    nur so funktioniert das nicht :-(
    hoffe hier kann mir jemand helfen

  • Probiere mal den ifplugd zu deaktivieren oder auch ganz zu deinstallieren.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Torvalds, 28.9.2003

    >>> raspiBackup: Sichere Deine Raspberry regelmäßig im laufenden Betrieb <<<

  • Nur mal eine Frage: Funktioniert dein WiFi-Stick nicht out-of-the-box mit Raspbian? Wenn er es tut, musst du nämlich /etc/network/interfaces gar nicht anpassen. Normalerweiße startes du einfach deinen Pi, schließt einen Monitor an (oder halt via Remote-Desktop) und klickst auf das kleine LAN-Symbol in der Taskleiste. Dort solltest du dann die Option "wlan0" haben. Das sollte dein Stick sein. Einfach drauf klicken, WLAN-Passwort eingeben und du bist verbunden. Wenn du dann wieder LAN verwenden willst, klickst du wieder auf das kleine Netzwerk-Symbol und wählst "eth0" an. Dann hast du wieder Internet über Kabel. Komplett ohne Scripten und mit wenigen Klicks.


    Ich hoffe ich habe verstanden, was du willst.
    LG Oskar

  • Der zweite Eintrag von

    Code
    1. auto lo
    2. iface lo inet loopback
    3. iface eth0 inet dhcp


    bem "WLAN"-Teil ist überflüssig.
    Besonders der Eintrag, dass hier dann eth0 doch DHCP machen soll, ist etwas, was das System wohl aus dem Tritt bringt.


    Wenn du zwei Netzwerk-Interfaces gleichzeitig in Betrieb hast, musst du aufpassen, dass du, wenn beide Interfaces in unterschiedlichen Netzen 'hängen', die passenden Routen gesetzt hast.

    Selber denken,
    wie kann man nur?