init.s Script startet nicht automatisch

  • hallo


    im ordner /etc/init.d/ habe ich ein script run.sh
    leider startet das nicht mit dem system


    Bash
    #!/bin/bash
    clear
    cd /home/pi/m3/deployment-archiver
    sudo java -Dfile.encoding=utf8 -.....


    Manuell gehts mit /etc/init.d/run.sh


    Woran kann das liegen?


    Gruss


  • im ordner /etc/init.d/ habe ich ein script run.sh
    leider startet das nicht mit dem system
    Woran kann das liegen?


    Warum sollte es dort starten?


    Das Verzeichnis '/etc/init.d/' ist ein Sammeltopf, in dem die Start/Stop-Scripte liegen.


    Gestartet werden sie, wenn sie mit dem Richtigen Namen in dem Verzeichnis des Runlevels steht, der vom System als 'Zielrunlevel' genommen wird.


    Ist der endgültige Runlevel 2, dann muss in /etc/rc2.d ein Link zur Start-Stop-Datei stehen, der mit dem Parameter "start" aufgerufen werden kann.
    Weitere Parameter sind "stop", der beim herunterfahren genommen wird, "status", der wie "restart" oder "reload" aber nicht vorhanden sein muss.


    Das Start-Stop-Script muss einen sauberen LSB-Header haben, in dem die Runlevel definiert sind.


    ein richtiger "Start-Name" in /et/rc2.d/ wäre "S99run.sh" (Aufrufparameter 'start')
    Wichtig ist hier das große S, ist es klein geschrieben, wird das Script nicht.
    In "/etc/rc5.d" oder "/etc/rc6.d" (5 ist reboot, 6 ist halt), würde das Script "K99run.sh" heißen (K wie 'kill', Aufrufparameter 'stop')



    Ist das bei deinem Script nicht gegeben, funktioniert das hier nicht.

    Selber denken,
    wie kann man nur?