Webserver

  • Hallo !


    Ich habe vor kurze Zeit einen lighttpd Webserver auf meinem Raspy installiert. Dieser läuft auch ausgezeichnet.


    Wenn ich nun jedoch in einem externen netzwerk versuche den server über meine externe ip zu erreichne funktioniert das nicht.


    Es ist aber möglich den Server im Homenetzwerk mit der externen IP zu erreichen.


    Kennt jemand eine Lösung ?

  • Du musst die Ports auf den dein Webserver läuft freigeben (HTTP: 80, HTTPS: 443). Das geschieht im Router. Wie du das bei deinem Router machst, findest du sicherlich bei Google da das bei den meisten Routern immer unterschiedlich ist ;)

  • Firewall blockt oder du hast die ports nicht RICHTIG freigegeben.

  • wenn ich die firewall beim router ausschalte ändert sich auch nichts
    ook und wie überprüfe ich ob ich sie richtig freigegeben habe ?

  • Firewall sollst du ja nicht ausschalten. Welchen Router hast du denn ?

  • Firewall hab ich nur testhalber ausgeschalten


    Mein Router: Wireless-N Home-Router WRT120N von Cisco


    NAT ist aktiviert dyndns jedoch nicht


    Auf dem PI läuft wheezy

  • Hast du dann auch port forwarding eingeschaltet?

  • Hallo blue03,


    Quote

    Wenn ich nun jedoch in einem externen netzwerk versuche den server über meine externe ip zu erreichne funktioniert das nicht.


    Von welchem externen Netzwerk reden wir hier eigentlich? Kann es eventuell sein, dass in diesem ein Proxy mit Filter eingesetzt wird welcher möglicherweise deine Anfrage an eine dynamische IP-Adresse bzw. DynDNS-Adresse bereits blockiert?


    Ansonsten solltest du mal folgende Punkte überprüfen und auch deine Konfiguration hier posten. Mit kurzen Antworten deinerseits fällt es schwer eine vernünftige Hilfestellung zu geben.


    - Erlaubt der Webserver (lighthttpd) auch Zugriffe von IP-Adressen welche nicht in deinem lokalen Netzwerk sind?
    - Was liefert ein "sudo iptables -L -n" auf deinem Raspberry Pi?
    - Wie hast du das Portforwarding auf deinem Router konfiguriert? Screenshots würden hier vielleicht auch hilfreich sein.
    - Welche Fehlermeldung bekommst du genau wenn du auf deine externe Adresse von extern zugreifst?


    Gruß Georg

  • Es ist aber möglich den Server im Homenetzwerk mit der externen IP zu erreichen.


    Achtung: TCP ist da smart genug und benutzt trotzdem die interne IP... Tests mit der externen IP gehen vom internen Netz nur wenn Du z. B. einen externen Proxy benutzt.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Also ich meine mit externen Netzwerk ein Netzwerk, in dem sich der PI nicht befindet. Ich möchte das der PI global erreichbar ist, also das ich die Website von überall aufrufen kann. Ich teste das immer mit dem Internet meines handy (anderer Anbieter).



    Quote


    Was liefert ein "sudo iptables -L -n" auf deinem Raspberry Pi?


    Chain INPUT (policy ACCEPT)
    target prot opt source destination


    Chain FORWARD (policy ACCEPT)
    target prot opt source destination


    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination


    Quote


    - Wie hast du das Portforwarding auf deinem Router konfiguriert? Screenshots würden hier vielleicht auch hilfreich sein.


    ich weis leider nicht wie ich ein bild einfügen kann


    Quote


    Welche Fehlermeldung bekommst du genau wenn du auf deine externe Adresse von extern zugreifst?


    Es kommt einfach eine weise leere seite ohne einer Fehlermeldung


    Ich hoffe nun das diese Antwort hilfreicher ist als meine vorherigen
    sry


    und das hier ist die konfiguration


    server.modules = (
    "mod_fastcgi",
    "mod_access",
    "mod_alias",
    "mod_compress",
    "mod_redirect",
    # "mod_rewrite",
    )


    server.document-root = "/var/www"
    server.upload-dirs = ( "/var/cache/lighttpd/uploads" )
    server.errorlog = "/var/log/lighttpd/error.log"
    server.pid-file = "/var/run/lighttpd.pid"
    server.username = "www-data"
    server.groupname = "www-data"
    server.port = 80



    index-file.names = ( "index.php", "index.html", "index.lighttpd.html" )
    url.access-deny = ( "~", ".inc" )
    static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )


    compress.cache-dir = "/var/cache/lighttpd/compress/"
    compress.filetype = ( "application/javascript", "text/css", "text/html", "text/plain" )


    # default listening port for IPv6 falls back to the IPv4 port
    include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
    include_shell "/usr/share/lighttpd/create-mime.assign.pl"
    include_shell "/usr/share/lighttpd/include-conf-enabled.pl"


    fastcgi.server = ( ".php" => ((
    "bin-path" => "/usr/bin/php5-cgi",
    "socket" => "/tmp/php.socket"
    )))
    include "phpmyadmin.conf"

    Edited once, last by blue03 ().

  • Bei der Portweiterleitung und so weiter müsste eigentlich alles stimmen
    hab das von Leuten aus anderen Foren testen lassen und die meinen das es etwas mit dem lighttpd zu tun haben müsste

  • Hallo blue03,


    Quote

    hab das von Leuten aus anderen Foren testen lassen und die meinen das es etwas mit dem lighttpd zu tun haben müsste


    Das Problem wird also in unterschiedlichen Foren mehrfach analysiert und ein Querverweis existiert zumindest hier noch nicht. Finde ich persönlich nicht hilfreich weil keiner nachvollziehen kann was dir wo anderes geraten wurde und du damit nur die Zeit von Leuten verschwendest die dir weiterhelfen wollen und so mehrfach die gleiche Arbeit machen.
    Wenn die Leute aus dem anderen Forum das Problem bei lighttpd vermuten, dann können die dir sicher auch hier weiterhelfen.


    Da du keine Fehlermeldung bekommst und nur eine leere Webseite angezeigt bekommst, wäre der nächste Schritt herauszufinden wer diese leere Seite liefert.


    Gruß Georg

  • Die kennen sich leider nicht mit dem lighttpd aus


    Dann eben nicht trotzdem danke für die hilfe
    Eigentlich wollte ich nur arbeit abnehmen