Nur 256MB statt 512MB?

  • Hallo,
    Ich habe gestern meinen ersten Pi bekommen.
    Gleich ein bisschen rumgespielt und verschiedene Sachen ausprobiert.
    Heute habe ich mir dann mal Raspcontrol draufgespielt um zu gucken wie gut so ein kleines Monitoring Tool denn sein kann.


    Dann die erste Überraschung.
    Nach der Installation und dem ersten Einloggen wurden mir beim Ram diese Werte angezeigt:

    Quote


    free: 180Mb · used: 35Mb · total: 215Mb


    Fand ich schonmal komisch. Ich hatte mir bei eBay extra Typ B mit 512 MB RAM bestellt.
    Also kurz gegoogled und gelesen, dass man durch den Aufdruch auf dem Chip herausfinden kann welche Version man hat.
    Also Gehäuse aufgemacht und nachgeschaut.
    Wie ich schon gehofft habe, steht auf dem Chip "4G".
    Also sollte es sich ja um die 512MB Version handeln.


    Zur Kontroll auf der Shell nochmal geprüft und wieder zu wenig Speicher angezeigt bekommen.


    free -m -t
    total: 215
    used: 200
    free: 14


    Als Betriebssystem nutze ich "Moebius Linux" (basist auf Raspbian).


    Dass mir im System nur 215MB RAM angezeigt werden trotz 4G Chip finde ich schon reichlich komisch..
    Dass die Werte aus dem System nicht wirklich zu denen aus Raspcontrol passen schieb ich einfach mal auf die Software.. Ich vertraue eh lieber der Shell :P

  • Wie aktuell ist das Moebius Linux? Im Internet und leider auch im Handel auf fertigen SD-Karten gibt es noch viele Betriebssysteme für den Pi mit alter Firmware die die 512er Version noch nicht kennt. Als ich vor 2 Monaten nachgesehen hab betraf das sogar die offizielle Version des Softfloat-Raspbian und da das Datum da immernoch 08.08.12 ist wird sich das nicht geändert haben.

  • Hi,


    das ist in der Tat sonderbar.
    Ich habe ebenfalls einen Pi mit 512 MB. Der meldet Folgendes:


    Code
    pi@raspberrypi ~ $ free -m -t
                 total       used       free     shared    buffers     cached
    Mem:           438        364         74          0         54        191
    -/+ buffers/cache:        117        320
    Swap:           99          0         99
    Total:         538        364        174
    pi@raspberrypi ~ $


    Da ist wohl bei Dir was schiefgelaufen bzw. hat Dich einer übers Ohr gehauen ...


    EDIT: Vermutlich hat orb mal wieder recht ;)
    Aber Du bekommst evtl. den installierten Speicher raus, wenn Du Dir mal die /var/log/dmesg anschaust (es sei denn der Pi erkennt den Speicher auch beim booten nicht):


    oder durch cat /proc/meminfo


    allerdings wieder unter der Prämisse, dass der Pi zu diesem Zeitpunkt den Speicher erkannt hat.




    ciao,
    -ds-

  • 1. Welche Farbe hat die Klinkensteckerbuchse?
    2. Hast du eine zweite SD-Karte um die Aktuelle Version von Raspian zu installieren?
    3. Hat der PI Befestigungslöcher?
    4. Fehlt der USB-Schutz Transistor/Kondensator (War beim ersten Modell noch verbaut bei den neueren ist dort ein Loch für Befestigungsschrauben)?

  • Danke für die Hilfe!
    Lag tatsächlich am System..
    Hab jetzt ein anderes draufgespielt und schon hab ich die 500 MB RAM.

  • Bei meiner zweiten Pi dachte ich auch ich hätte weniger Mem. Dann fand ich raus dass der Videomemorysplit daran Schuld war.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

    Edited once, last by framp ().


  • Bei meiner zweiten Pi dachte ich auch ich hätte weniger Mem. Dann fand ich raus dass der Videomemorysplit daran Schuld war.


    Den hab ich mir schön weit runtergezogen (Video auf 16MB) weil mein Pi eh nur als Server dient.