Raspberry Pi als NAS

  • Hallo Community,
    ich habe mir vor wenigen Tagen ein Raspberry Pi 2 B zugelegt ( http://www.amazon.de/Raspberry-Mainboard-Sockel-Quad-core-Cortex-A7/dp/B00T2U7R7I/ref=sr_1_1?ie=UTF8&qid=1447954784&sr=8-1&keywords=raspberry+pi+2+b (Affiliate-Link) ). Ich wollte jetzt ein NAS bauen. Dazu habe ich mir folgendes Video von SemperVideo angeschaut ( https://www.youtube.com/watch?v=3Tn184NhMRI&index=7&list=PL3-bM7Aq1pUrkA... ). Ich habe dann die folgende Befehle in den Terminal eingegeben:


    sudo -i


    apt-get update apt-get upgrade


    apt-get install ntfs-3g fdisk -l


    mkdir /media/HDD1 mount -t auto /dev/sda1 /media/HDD1


    apt-get install samba samba-common-bin


    cp /etc/samba/smb.conf /etc/samba/smb.conf.orig


    nano /etc/samba/smb.conf


    Bis hierhin verlief alles gut. Er enderte dann in der config datei unter dem punkt "Authentication" #security = user zu security = user. Ich habe diesen Eintrag allerdings nicht und nachdem ich den Rest der Anleitung zuende geführt habe, hatte ich keine Berechtigung um eine Datein zu erstellen. Würde mich über Hilfe freuen!
    LGundefined


  • Bis hierhin verlief alles gut. Er enderte dann in der config datei unter dem punkt "Authentication" #security = user zu security = user. Ich habe diesen Eintrag allerdings nicht [...]



    Ich habe erst neulich auf ein frisches Image (Wheezy) einen Samba Server erstellt und in der "smb.conf" war der Punkt "Authentication" vorhanden. Ich bin mir fast sicher das er in Deiner .conf Datei auch steht, aber oftmals sieht man bei den ganzen Einträgen und Anmerkungen den Wald vor lauter Bäumen nicht.


    Hast Du mal - wenn Du die Datei mit 'nano' geöffnet hast - mit STRG+W die Suche aufgerufen und dort "Authentication" oder "security" eingegeben? Für mehrfaches Suchen einfach nochmal STRG-W drücken und ENTER, dann wird der nächste passende Begriff gesucht.


    So müsstest Du bald auf den Eintrag stoßen:


    Code
    ####### Authentication #######
    
    
    # "security = user" is always a good idea. This will require a Unix account
    # in this server for every user accessing the server. See
    # /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
    # in the samba-doc package for details.
    security = user


    Falls die Suche nichts bringt - was mich wundern würde - dann kannst Du die Zeile "security = user" auch per Hand eintragen - sollte auch funktionieren.


  • Erstmal vielen Dank für die Antwort,
    was vielleicht nicht ganz aus meiner Frage hervorgeht ist, dass ich den Punkt Authentication durchaus habe, unterhalb steht aber nur folgendes:


    Code
    # Server role. Defines in which mode Samba will operate. Possible
    # values are "standalone server", "member server", "classic primary
    # domain controller", "classic backup domain controller", "active
    # directory domain controller".
    #
    # Most people will want "standalone sever" or "member server".
    # Running as "active directory domain controller" will require first
    # running "samba-tool domain provision" to wipe databases and create a
    # new domain.
       server role = standalone server


    ich habe auch ein paar mal security = user darunter geschrieben, aber es funktionierte trotzdem nicht. Wahlweise hab ich auch bei diesen Versuchen das sever role = standalone server rasugenommen. Ich habe auch schon nach securtiy im dokument gesucht. Das Wort steht aber nur im folgenden Kommentar :


    Code
    # File creation mask is set to 0700 for security reasons. If you want to
    # create files with group=rw permissions, set next parameter to 0775.
       create mask = 0700
  • Den von Dir zitierten oberen Text habe ich in meiner .conf gar nicht...


    Arbeitest Du mit dem "Wheezy" Image oder dem neuen "Jessie"? Ich habe da nicht wirklich Ahnung, aber beim Querlesen habe ich öfter von Problemen gelesen mit älteren Tutorials da im neuen "Jessie" einiges anders läuft.


    Solltest Du das aktuelle "Wheezy" nutzen (so wie ich) dann sollte der Semper-Video Kurs funktionieren, denn den habe ich auch als Grundlage für den Aufbau einer NAS in meinen Notizen gespeichert.


    Gehe doch nochmal das Tutorial bzw. die Installationsschritte durch, eventuell hat sich irgendwo ein Fehler eingeschlichen. Ggf. den Samba Server nochmal komplett deinstallieren.


    Was mir noch einfällt:
    Wenn Du alle Schritte im Tutorial gemacht hast dürfte ja auch noch die Sicherheitskopie der .conf Datei da sein! Öffne doch mal die "smb.conf.orig" (oder wie auch immer Du sie genannt hast) und kontrolliere diese einmal nach den besagten Texten.


  • Den von Dir zitierten oberen Text habe ich in meiner .conf gar nicht...


    Arbeitest Du mit dem "Wheezy" Image oder dem neuen "Jessie"?


    Ja ich arbeite mit Jessie. Wahrscheinlich liegt es daran.


    Quote

    Wenn Du alle Schritte im Tutorial gemacht hast dürfte ja auch noch die Sicherheitskopie der .conf Datei da sein! Öffne doch mal die "smb.conf.orig" (oder wie auch immer Du sie genannt hast) und kontrolliere diese einmal nach den besagten Texten.


    Das habe ich schon mal gemacht, ist aber genau dasselbe, da ich ja bis auf security = user und den Ordner Backup nichts geändert/hinzugefügt habe. Vielleicht versuche ich es mal mit Wheezy, falls hier niemanden mehr etwas einfällt. Danke

  • Aus der Kalten fällt mir kein Grund ein, warum es bei der Einrichtung eines NAS Unterschiede zwischen wheezy und jessie geben sollte. Eigentlich funktioniert die Installation nach klassischen Anleitungen die man so im Netz findet: http://www.einplatinencomputer…dateiserver-installieren/


    Bekommst du denn irgendeine konkrete Fehlermeldung oder funktioniert es einfach kommentarlos nicht?


    Gruß

  • Sorry, aber die Banane eignet sich wesentlich besser für NAS
    als der Pi mit seinem Schnecken-Lan.
    Das würde ich mir nicht antun.

  • Ich hatte meinen 2er Pi bis vor Kurzen sowohl als PXE Server, als auch als NAS verwendet, lief hervorragend. Bis auf die Übertragungsgeschwindigkeit ....


    Jetzt habe ich mir ein Synology NAS gegönnt und administriere das Teil über meinen Pi. geht zwar auch direkt auf dem NAS, macht aber über den Pi per SSH und Sharing mehr Spaß.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT