Bekomme C-Media Electronic Audio Controller nicht zum laufen

  • Hallo,


    ich habe folgendes Problem: Ich habe eine externe USB-Soundkarte eingesteckt aber Ton kommt trotzdem nur aus der integrierten Audio-Buchse.
    Mein Problem ist sehr identisch zu diesem Beitrag: http://www.forum-raspberrypi.d…undkarte-nicht-zum-laufen
    Jedoch habe ich pulseaudio nicht installiert was die Probleme in diesem Beitrag verursacht hat.
    Ansonsten sind alle "Symptome" die gleichen.
    Alle Lösungsvorschläge hab ich mittlerweile durch....


    Hat jemand eine Idee an was es noch liegen könnte?


    Viele Grüße
    Tom

    Edited once, last by tomcolaa ().

  • kann es vielleicht sein das Pulseaudio bei Raspbian schon vorinstalliert ist?
    Versuche mal Pulseaudio zu deinstallieren:

    Code
    sudo apt-get purge pulseaudio

    A: Was ist dein dunkelstes Geheimnis?
    B: Das kann ich dir nicht sagen.
    A: sudo was ist dein dunkelstes Geheimnis?

  • Ups wie peinlich :D
    Man merkt ich habe noch nicht so viel mit dem Pi gemacht und steh noch am Anfang.


  • Ändere die Datei /etc/modprobe.d/alsa-base.conf
    so um:
    Aus dem
    options snd-usb-audio index=-2
    machst du das:
    options snd-usb-audio index=0
    Nach der Zeile fügst du einfach das ein:
    options snd_bcm2835 index=1
    speichere die Datei ab und führe einen Reboot durch, danach sollte die Sound Karte funktionieren.

    A: Was ist dein dunkelstes Geheimnis?
    B: Das kann ich dir nicht sagen.
    A: sudo was ist dein dunkelstes Geheimnis?

  • Ja das ist ja das komische weil das hab ich schon versucht. Hab auch schon probiert die zeile options snd-usb-audio auszukommentiern weil das auch vorgeschlagen würde. Hat alles bisher nichts gebracht. Als Sound bleibt ein sanftes rauschen.
    Was auch vllt noch interessant ist zu wissen ist dass das Rauschen etwas lauter wird wenn ich einen Ton abspiele.
    Die Soundkarte ist aber nicht defekt am Pc funktioniert sie gut.

  • Hier ein paar zusätzliche Infos:


    lsusb

    Code
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
    Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
    Bus 001 Device 005: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller


    /etc/modprobe.d/alsa-base.conf


    /etc/asound.conf (hat vorher nicht existiert)

    Code
    pcm.!default {
    type hw
    card 0
    }
    ctl.!default {
    type hw
    card 0
    }
  • Moin,


    hast Du eine Lösung gefunden ?


    Gruss
    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.

    Edited once, last by Kurti ().

  • Nein leider noch nicht.
    Mein Kollege hat gemeint das vermutlich ein Modul fehlt aber ich bin immernoch auf dem Holzweg.
    Was ich noch garnicht erwähnt hatte ist dass wenn ich über Remote auf meinen Pi schalte und dann auf Audio device settings gehe kann ich da meine USB Soundkarte als Default auswählen. Nachdem bestätigen öffne ich die Einstellungen erneut und die USB soundkarte ist nicht mehr default.
    Ich hab keine Ahnung an was das liegen könnte.


    Gruß Tom

  • Führe mal ein "cat /proc/asound/cards" aus, und nimm den Eintrag, der bei dir in den eckigen Klammern steht, und nicht ALSA heißt, und Trage in hinter das "card" in der /etc/asound.conf


    Du hast da im Moment die Ziffer '0':

    Code
    pcm.!default {
    type hw
    card 0
    }
    ctl.!default {
    type hw
    card 0
    }


    Bei mir sind die Ergebnisse:

    Code
    cat /proc/asound/cards
     0 [ALSA           ]: bcm2835 - bcm2835 ALSA
                          bcm2835 ALSA
     1 [MicroII        ]: USB-Audio - Audio Advantage MicroII
                          C-Media INC. Audio Advantage MicroII at usb-3f980000.usb-1.5, full speed


    Ich habe also in der "/etc/asond.conf"

    Code
    pcm.!default {
    type hw
    card MicroII
    }
    
    
    ctl.!default {
    type hw
    card MicroII
    }


    stehen.


    ---
    Mein USB-Sound Dings-Bums hat die USB-ID:

    Code
    Bus 001 Device 005: ID 0d8c:0103 C-Media Electronics, Inc. CM102-A+/102S+ Audio Controller

    Selber denken,
    wie kann man nur?

    Edited once, last by Rasp-Berlin ().