Netzteil stört TV

  • Hallo,
    habe mein RPi2 mir OpenELEC+Kodi und Ambilight laufen.
    Habe dieses 5V 10A Netzteil verbaut.
    Wenn das Netzteil unter Lasst ist, stört es leider den Fernseher. Es kommt dann zu Klötzchenbildung und Tonaussetzern.
    Bevor ich dieses Netzteil einsetzte, kamen mehrere Specknetzteile zum Einsatz (1A Pi, 4A Ambilight, 2,5A USB HUB der den Pi noch mit versorgte). Damals trat besagtes Problem noch nicht auf.
    Um der Zuleitung ist seit Anfang an ein Ferridkern.
    Habe inzwischen auch schon einen Netzfilter integriert, hat auch nichts gebracht.


    Bin ratlos :(
    Kann mir jemand helfen? Gibt es noch andere Möglichkeiten die man versuchen könnte?
    Wäre notfalls auch bereit ein neues Netzteil zu kaufen, wenn es nicht übermäßig teuer ist (< 15€, muss auch nicht unbedingt 10A liefern, 5A sollten eigentlich reichen).


    Danke für eure Antworten!

  • Schaltnetzteile schwingen leider in einem Bereich, der so gut wie alles stört. Mir ist bei einem meiner Netzteile aufgefallen, das die Störungen größer werden, je weniger es belastet wird. Ich hatte lange nach der Ursache gesucht, weil bei mir DLAN (das LAN über Steckdose), WLAN und selbst DECT unmotiviert Störungen zeigten, bis ich mitbekam das es meine Beleuchtung ist, die ich über das Jahr auf LED umgestellt hatte. Ganz schlimm ist es beim abdimmen. Ich suche gerade selbst noch nach Lösungen, mal sehen, was dabei rauskommt.


  • Habe dieses 5V 10A Netzteil verbaut.
    Wenn das Netzteil unter Lasst ist, stört es leider den Fernseher.


    suche dir ein anderes Plätzchen für das Netzteil oder schirme es besser ab, aber dann kann es evtl. unter Vollast seine Abwärme nicht mehr abführen.


    Filter auf der AC und DC Seite wären eine mögliche Ergänzung, aber das beste wäre ein anderer Betriebsort, es reicht doch wenn die DC mit guten dicken Strippen Seile für Halogenlampenspots ab 4mm² an die Stripes oder mehreren dünnen an jede Stripe geführt werden.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)


  • es reicht doch wenn die DC mit guten dicken Strippen Seile für Halogenlampenspots ab 4mm² an die Stripes oder mehreren dünnen an jede Stripe geführt werden.


    Sorry aber den Satz versteh ich nicht ganz :D


    Also die AC Seite sollte mit dem Netzfilter ja eigentlich sowohl eingehende, als auch ausgehende Störungen Filtern oder? Oder Funktioniert die Filterung nur in eine Richtung?
    Demnach würden ja auch die Probleme, die DC-seitig entstanden sein könnten, dort ruasgefiltert, was DC-seitig ja eigentlich keine Filterung mehr nötig machen würde.
    Falls doch, was würde dort dann gemacht werden? Bin ich da beim Stichwort Glättung und Siebung richtig?


    Sagen wir die Probleme werden über die Luft hervorgerufen (magnetisches Feld). Wäre eine Abschirmung mittels Alufolie möglich oder hilft das nur gegen gedankenlesende Aliens? :D
    Was ich vll noch hätte dazu schreiben sollen: Der RasPi ist zusammen mit dem Netzteil in einem kleinen Holzgehäuse verbaut. Ich könnte dieses von innen einfach mit Alufolie oder auch dünnem Blech auskleiden wenn das helfen könnte. Belüftung würde somit ja auch nicht weiter beeinträchtigt werden, als sie es ohnehin schon ist.
    Wäre das also eine sinnvolle Option?


    Standort ändern wird da eher schwieriger weil am TV der einzige Ort ist, wo man etwas sinnvoll abstellen kann.


  • Habe inzwischen auch schon einen Netzfilter integriert, hat auch nichts gebracht.


    Sei mal nicht sauer, aber der Netzfilter, den du da verwendest, taugt nicht... da ist nix wirklich wirksames drin...


    Nimm mal eher sowas wie das hier oder ähnliche Bauformen (ok, die bauen größer, aber die Induktivitäten lassen sich nun mal nicht so schrumpfen).
    Wichtig ist eine (auf dem Filter abgebildete) Serien-Parallelschaltung von RCL Bauelementen (da gibt es verschiedene Aufbauten und - von der Strombelastung abgesehen - verschieden schmal/breitbandige Auslegungen).
    Hilft letztlich nur, die Datenblätter zu studieren...


    Ich habe mit einem ähnlichen Netzfilter (finde jetzt den Link nicht) meinen "Dremel-Light" (billiges Diskountermodell) wirksam entstört: Wenn ich das eingeschaltet hatte, triggerte ein Zimmer weiter eine Master/Slave-Steckdose im 1/10tel Sekundentakt vor sich hin - den an die Slavesteckdosen angeschlossenen Geräten hat das überhaupt mich gefallen :(


    Mfg,
    das Zen
    Automatisch zusammengefügt:
    [hr]


    Sry for vollquote...


    Also Anschließen mit ausreichendem Querschnitt ist ja nun erstmal Grundvorrausetzung, aber das ist nicht der Punkt.


    Netzfilter arbeiten immer unidirektional, denen ist es egal, ob die Störung aus dem Netz oder aus dem Gerät kommt... der in meinem anderen Link gezeigte Netzfilter hat ein LC-Glied, welches als Tiefpass arbeitet: Ströme mit einer höheren Frequenz als die sog. Knickfrequenz werden gedämpft (quasi "kurzgeschlossen").


    Abschirmen mit Alu/dünnem Blech bringt m.M. nach nix ("kann man machen..." - sieht aber toll aus! ;) ) , weil die Störungen sich auf dem Stromversorgung bewegen und die vom RP/NT erzeugte HF nur geringe Leistung hat...


    Mein Rat: ein richtiger Netzfilter auf der AC Seite des Netzteils und gut.


    Mfg, das Zen

  • Deswegen bin ich doch nicht sauer, eher dankbar :D


    Den von dir verlinkten Artikel gibt es leider nicht mehr und auch nicht vergleichbares.
    Hab mal zwei Artikel bei ebay rausgesucht die passen könnten (beide RLC soweit ich das beurteilen kann):
    1. dieser (Datenblatt ist im Artikel verlinkt)
    2. dieser


    Beide sind wohl RLC. Worauf muss ich denn noch achten?

  • Hi - dumme Frage:
    Benutzt Du auch die Erdung (Erde - Gelb/Grünes) Kabel?
    Sind alle Minusleitungen [GND] mit relativ dickem Kabel verbunden?

    Sollte ich "Müll- reden" :blush: - bitte mich (?) "auf die Nuss" hauen. :huh:

  • Noch ne dumme Frage:
    Ist es sicher, dass das Störsignal direkt auf den TV wirkt, und nicht schon in den Raspi streut und dort die Artefakte verursacht?
    Hast du mal Abstand und Lage zum TV verändert?

  • Hallo,
    ja nutze PE. Relativ dick? Naja, ist ein gewöhnlioches Kabel mit Klatgerätestecker, also ja.
    Entfernung zum TV war maximal 1,5m, mehr geht leider nicht - Erbrachte keine Besserung.


    Habe gerade festgestellt, dass ich mich etwas falsch ausgedrückt habe. Das Netzteil stört nicht das Bild des Fernsehers direkt, es stört den Fernsehempfang über DVB-C. Wenn der Pi oder etwas anderes als Quelle verwendet wird ist alles gut. Nur wenn die Quelle DVB-C (interner Tuner) ist, kann es zu problemen kommen. Kann - denn manchmal kommt dies auch gar nicht vor. Manchmal kommt es ab und zu mal zu ein paar Artefakten und ein paar Tonaussetzern, was zwar nervig, aber noch verträglich ist. Manchmal ist es aber auch ganz extrem, dass kaum ein Wort vollständig ohne Tonaussetzer gesprochen wird. Das hört dann abrupt auf, wenn ich den Pi ausschalte.


  • Habe gerade festgestellt, dass ich mich etwas falsch ausgedrückt habe. Das Netzteil stört nicht das Bild des Fernsehers direkt, es stört den Fernsehempfang über DVB-C. Wenn der Pi oder etwas anderes als Quelle verwendet wird ist alles gut. Nur wenn die Quelle DVB-C (interner Tuner) ist, kann es zu problemen kommen. Kann - denn manchmal kommt dies auch gar nicht vor.


    dann versuche es besser zu erklären,


    1. Möglichkeit, die Störung kommt vom aktiven Ambiight weil das am Netzteil Lastwechsel verursacht.
    2. Möglichkeit der PI verursacht diese Störungen auch wenn Ambilight läuft aber die LEDs abgeklemmt sind.


    Ohne genaue Analyse kann keiner helfen, wir sitzen ja nicht an deinem Aufbau.


    Du müsstest schon selber feststellen unter welchen Umständen sich die DVB-C Störungen häufen.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)


  • Hm, der Link auf den Pollin Netzwerkfilter war ja auch nur ein Beispiel...


    Die Filter, die du verlinkt hast, haben alle das gleiche "Problem": Die verbauten Induktivitäten sind zu klein (so um die 1mH), so dass die Filterwirkung erst bei höheren Frequenzen einsetzt (siehe auch Datenblatt).
    Das liegt in der kompakten Bauform der in die Kaltgerätesteckdose integrierten Filter begründet, höhere Induktivitäten brauchen halt Platz...


    Ich habe "in etwa" meinen gefunden (meiner ist von EPCOS, die Daten fast identisch): Link
    Der Filter, den ich verbaut habe, hat ca 18mH / Strang, die Filterwirkung beginnt bei wesentlich niedrigeren Frequenzen (siehe auch Datenblatt).
    Allerdings hat Conrad bei der Beschreibung einen Bock geschossen: Der besagte Netzfilter hat keinen Kaltgeräteanschluss sondern ist beidseitig mit Flachsteckeranschlüssen versehen.
    Über den Preis... naja... schweigen wir lieber... :(


    Letztlich kann man sich sowas auch selber bauen - VORSICHT: Netzspannung!!!
    Hab ich aber auch nicht gemacht, mir war eine schnelle Lösung lieber. Ich habe den Filter in eine stabile Plastikbox eingebaut und kurze Kabel rausgeführt, an einem der Stacker, an dem anderen eine Kupplung. Wo immer ich den jetzt brauche, schalte ich den dazwischen (max. 6A..).


    Mfg, das Zen


  • 1. Möglichkeit, die Störung kommt vom aktiven Ambiight weil das am Netzteil Lastwechsel verursacht.


    Das könnte durchaus hinkommen. Manchmal scheint es tatsächlich so, als träten die Störungen vermehrt auf, wenn es schnelle Bildwechsel hell/dunkel/hell gibt.
    Könnte in diesem Fall DC-seitig ein Kondensator als Puffer helfen?


    Manchmal half es auch schon, mit der Hyperion-App die Farbe auf einen festen Wert zu setzen oder halt auszuschalten.
    In letzter Zeit treten die Störungen aber gehäuft auch dann noch weiterhin auf.



    2. Möglichkeit der PI verursacht diese Störungen auch wenn Ambilight läuft aber die LEDs abgeklemmt sind.


    Wie oben schon geschrieben, kommt in letzter Zeit auch vor. Früher ging es dann meist. Weiß nicht warum das früher ging und jetzt nicht mehr, ob sich seitdem was geändert hat? Ich hab zumindest nichts geändert.






    Der Filter, den ich verbaut habe, hat ca 18mH / Strang, die Filterwirkung beginnt bei wesentlich niedrigeren Frequenzen (siehe auch Datenblatt).


    Ok wenn es nur danach geht hätte ich diese hier gefunden:
    250V/1A 12mH
    und nochmal der gleiche, nur mit 250V/0,5A und 24mH
    Die passen jetzt aber oder? :D

    Induktivität scheint sich ja umgekehrt proportional zur maximalen Strombelastbarkeit zu verhalten. Also lieber nicht all zu viel Puffer bei der Strombelastbarkeit und dafür mehr Induktivität?
    Das Netzteil hat 50W bei 81% Effiziens. Die maximale Leistungsaufnahme dürfte also bei ca. 62W liegen, was bei 230V nur ca 0,27A sind. Dann dürfte die 0,5A Variante ja eigentlich getrost reichen oder doch lieber etwas mehr Puffer und dafür geringere Induktivität?


  • Das sind Netzfilter für die Printmontage, die musst du entweder auf einer Platine installieren oder eben frei irgendwo in einem Gehäuse... wie schon geschrieben: hier ist Netzspannung im Spiel, da sollte man mit umgehen können, also alle spannungsführenden Teile isolieren (Schrumpfschlauch) usw.


    Ja, es besteht durchaus eine Abhängihkeit zw. der max.Strombelastbarkeit und der verbauten Induktivität:
    Die Induktivitäten sind meist ausgeführt als gewickelte Ringkerne. Je größer die Indukt., desto mehr Windungen müssen da auf dem Ringkern untergebracht werden. Da der Ringkern nur endlichen Platz für die Wicklung bietet, wird halt der Querschnitt des Wicklungsdrahts verringert - somit sinkt die Strombelastbarkeit.


    Andererseits (beim Selbstbau) kann man mehrere L's parallel schalten bzw. größere Ringkerne verwenden.


    Entscheidend ist, für welchen Zweck der Filter eingesetzt werden soll bzw. was (ab welcher Frequenz) er wegfiltern soll und ob er schmalbandig oder breitbandig ausgelegt und welche Dämpfung er erreichen soll....
    So ein simples Bauteil ist bei näherer Betrachtung schon etwas komplexer... wenn es richtig funktionieren soll. Die üblicherweise angebotenen Filter in den Kaltgerätesteckdosen sind m.E. ein minimaler Grundfilter..., taugen nur für den MHz-Bereich. Störungen, die z.B. durch Bürstenfeuer von Universalmotoren verursacht werden, werden kaum gedämpft (Störfrequenzen liegen im unteren kHz-Bereich)...


    Wenn dein Netzteil nur 50W hat, ist die 0,5A Variante ausreichend. Schaltnetzteile neigen allerdings zu (transienten) Einschaltstromstößen, welche der Filter aber wegstecken sollte, da diese nur wenige Halbwellen anstehen.
    Sicherer bist du mit der 1A Variante, ich habe mir allerdings die Kennlinien nicht angesehen...


    Mfg, das Zen :)

  • Vielen Dank für die wieder mal sehr ausführliche Antwort!


    Hab mir jetzt nochmal die Datenblätter angeguckt. Dabei fällt auf, dass der oben verlinkte zwar deutlich besser zu sein scheint, als der gegenwärtig verbaute, allerdings z.B. noch nicht an den von dir verlinkten ranzukommen scheint.


    Hier mal als Vergleich:
    [Blocked Image: http://abload.de/img/netzfilterq5zgg.png]
    rechts ist der von mir im letzten Post verlinkte, links ein anderer.
    Ich weiß nicht genau auf welche Kennlinie ich achten muss. Aber wenn ich die Fette angucke, scheint der linke doch durchaus potenter zu sein oder?


    Da die Netzfilter durch ihre Bauform bzw. größe nicht mehr unbedingt dazu geeignet sind, sie einfach in die Zuleitung zu integrieren und für das Gehäuse des RasPis zu groß sind, werde ich das zum Anlass nehmen, mein ganzes Konzept mal zu erneuern. Habe momentan noch die WS2801 in der Version, in der die LEDs einzeln über Kabel verbunden sind verbaut. Diese sind in einem Rahmen aus Kabelkanälen integriert, welcher hinter dem TV an der VESA Halterung befestigt ist.
    Habe mir die WS2801 jetzt als LED-Stripe bestellt, welche ich dann hinten an den TV kleben werde.
    Der RasPi+Netzteil+Netzfilter kommen dann auf eine großzügig große Holzplatte, welche ich hinter den TV an der VESA Halterung befestige. Dort habe ich dann genug Platz alles ordentlich zu verbauen.
    Das Display und Taster werden dann in einer Blende unter dem Fernseher verbaut.
    Aber darum geht es hier ja eigentlich nicht :D
    Also bis die LEDs aus China da sind, belasse ich es erstmal so wie es jetzt ist.

  • du weisst aber immer noch nicht ob es von der Netzseite kommt (230Vac) oder von den Stripes also der Sekundärseite oder von Lastwechsel.

    lasst die PIs & ESPs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Quote from jar

    du weisst aber immer noch nicht ob es von der Netzseite kommt (230Vac) oder von den Stripes also der Sekundärseite oder von Lastwechsel.


    Für all die möglichen Probleme, außer dem Stripe, würde der Netzfilter doch abhilfe schaffen oder? Und das es direkt und nur an den Stripes liegt glaub ich nicht, da es ja zuvor mit "fliegender Verkabelung" problemlos funktioniert hat. Werde aber versuchen, auch das nochmal auszuschließen. Weiß nur noch nicht genau wie ^^


    Quote from Zentris

    Hast du nicht einen 12V Akku (mit ein bischen Kapazität, also so >=5..10Ah), womit du das mal für ein paar Minuten autonom betreiben kannst, um festzustellen, ob es wirklich am NT liegt?
    ... notfalls aus deinem oder Papas Auto ausbauen undefined


    Musste meine letztens austauschen und die alte steht tatsächlich noch im Keller :D
    12V/7Ah Bleiakku hät ich auch noch da.
    Aber warum 12V? Bräuchte ja eigentlich nur 5V. Könnte ne Powerbank nehmen, liefert aber mit 2,4A ein bisschen wenig Strom.
    Wenn ich mich nicht irre, hab ich aber noch einen Stepdown Converter auf 5V, weiß nur nicht wieviel Strom der mitmacht.

  • Einen Step-Down in dieser Größenordnung wird ziemlich schnell sehr heiß, insofern er überhaupt die Stromstärke aushält...Probier die Geschichte mit der Powerbank aus und lass dir rot/schwarz/grüne Muster anzeigen, das ganze möglichst dunkel (damit sollten die 2,4 A locker reichen, hatte schon einige WS2811 über USB versorgt)
    Mehrere größere Stützelkos könnten das Problem lösen, als relativ günstiges alternatives Netzteil könntest du sowas nehmen:
    http://www.amazon.de/Supply-Netzteil-WS2811-WS2812-WS2812B/dp/B00KETLBAU/ref=sr_1_1?ie=UTF8&qid=1449845496&sr=8-1&keywords=5v+10a+netzteil (Affiliate-Link)


    kobold254

  • Ops..., hatte vergessen, dass du ja mit einem 5V Netzteil dabei bist.


    Na wenn du eine alte Batterie im Keller hast: einfach nur 3 Zellen abgreifen (macht 6V, ist immer noch etwas zu viel... )
    Der Stepdown-Regler wird den Strom nicht stemmen... selbst wenn er nur 1V wegregeln muss... aber du könntest (wenn du hast) 1 oder 2 Dioden in Durchlassrichtung schalten (sollten aber schon 10A vertragen und kühlung nicht vergessen - ich habe hier noch alte 25A Einpressdioden aus dem Fahrzeugbau für sowas...).
    Pro Diode fallen so um die 0,7V ab... macht bei zweien 1,4V, fast schon ideal (nachmessen!).


    Aber das ist natürlich schon heftiges hacken...


    Mfg, das Zen

  • Dein Problem ist keine Seltenheit.
    Netzteilstörer arbeiten meist im Bereich ab ca 600KHz ,
    also im MW Bereich und sind diesbezüglich gut über ein entsprechendes Radio akustisch darstellbar. - gleichmäßiges Geräusch
    Ursache ist oft ein defekter Glättungskondensator auf der Sekundärseite - Achtung bei älteren Netzteilen latente Brandgefahr ! Hier den einen oder anderen Euro mehr zu investieren lohnt sich in jedem Fall.


    Ein PWM Störer arbeitet auch in niedrigeren Frequenzen und schwankt vom Geräusch etwas - Lastwechsel, und stört meist nur im Nahbereich bis ca. 1m
    Die Ausbreitung Luft/Kabel/Gerät ist hängt bauartbedingt vom jeweiligen vom Netzteil versorgten Gerät ab. Hier gibt es keine Regel.


    Ein genaues Ergebnis kannst du mit einem Spektrumanalyser mit angepasster Antenne oder Hochspannungstastkopf bekommen.


    br


    :angel:

    Edited once, last by NukNuk ().