opvenvpn Port 1194 nicht erreichbar.

  • Hallo zusammen,


    Ich habe einen raspberrypi 2 mit jessie,
    mein router befindet sich an einem ds lite Anschluss von Unitymedia. Um auf den router zugreifen zu können, habe ich mich bei feste-ip.net registriert und es klappt auch gut.
    Ich kann auf die Fritzbox 6360 cable zugreifen, ssh klappt auch.
    Was nicht klappt, ist der openvpn an port 1194.


    Ich bin der Meinung, dass ich im router alles richtig eingestellt habe (Myfritz-Freigabe) und auch bei feste-ip.
    Der Testbutton auf feste-ip wirft jedoch immer das Ergebnis: Port nicht erreichbar aus.


    Ausgabe von sudo netstat -lnp

    Code
    1. Aktive Internetverbindungen (Nur Server)
    2. Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    3. tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      496/sshd        
    4. tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN      1055/perl      
    5. tcp6       0      0 :::22                   :::*                    LISTEN      496/sshd        
    6. tcp6       0      0 :::80                   :::*                    LISTEN      694/apache2    
    7. udp        0      0 0.0.0.0:1194            0.0.0.0:*                           534/openvpn


    Sieht das nicht so aus, als wenn port 1194 nicht aktiviert ist?
    Tunnelblick gibt stehts an: Warte auf Server-Antwort.


    Liegt es an den iptables? Beim Konfigieren von openvpn habe ich

    Code
    1. sudo iptables -I INPUT -p udp -m udp --dport 1194 -j ACCEPT


    eingegeben, aber sudo iptables -L zeigt mir nur Leere.
    Liegt es an den iptables oder kann es sein, dass der ISP den port 1194 blockt. Habe ich mal gelesen, dass das vorkommt.
    Dann kam mir noch der Gedanke, dass es vielleicht an IPv6 liegt, mit dem raspberrypi 2 arbeitet. Arbeitet die Standardkonfiguration nur mit IPv4?


    Weiß jemand Rat?
    Danke und viele Grüße

  • Na dann muss ich leider passen ...
    Aber vielleicht findet sich z.B. -> rpi444 <- ( der ist sozusagen das personifizierte Netzwerk unter den Benutzern hier ;) ) oder ein anderer Netzwerk-Crack hier ein ...
    In der Zwischenzeit kann es nicht schaden, wenn Du mal nach seinen Beiträgen hier suchst oder die Suchfunktion mit z.B. ipv6 fütterst ...


    cu,
    -ds-

  • Quote

    Du musst OpenVPN für TCP (nicht UDP) konfigurieren. Die Portmapper von feste-ip.net können nur mit TCP-Verbindungen (nicht mit UDP) hantieren/umgehen.


    Ich danke Euch für die Hilfen.
    In der Fritzbox habe ich nun alle Portweiterleitungen auf TCP gesetzt und in openvpn.config und meingeraet.config "proto TCP" geschrieben.
    Die Fehlermeldungen von Tunnelblick werden immer positiver :-)
    TCP-Verbindung herstellen und im log steht:


    [font="Helvetica"]WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.[/font]


    [font="Arial"]Ich muss noch einiges durchlesen und melde mich dann nochmal.
    [/font]


    [font="Arial"]Bis dahin, Gruss[/font]

    Edited once, last by kakipi ().

  • Geschafft :-)


    ich habe mich an feste-ip gewandt und das Problem geschildert. Die Antwort kam recht schnell.
    Es lag daran, dass der Port nicht über IPv6 sondern nur über IPv4 erreichbar war. So kann feste-ip nicht arbeiten.


    Lösung:


    Den Eintrag in /etc/openvpn/openvpn.conf
    proto tcp


    in


    proto tcp6-server


    umgewandelt. Das wars :-)


    Ich danke allen Mitwirkenden

  • Ich bin bei meiner Recherche auf das Thema hier gestossen und möchte mich für den Hinweis bedanken, dass in der server.conf der Eintrag gemäß Post #7 geändert werden muss.

    Dadurch zeigt mir der Verbindungsversuch auf Feste-IP.net nun endlich "Port erreichbar"


    Leider bin ich aber noch nicht ganz fertig mit der EInrichtung, denn jetzt schaffe ich es nicht, dass sich mein Smartphone über die OpenVPN App mit dem Heimnetz verbindet. Muss man hier auch noch die *ovpn Datei für den Client in ähnlicher Art anpassen?

  • Jemus  


    Wie dreamshader schon erwähnt hat, der Thread ist uralt. Du solltest einen neuen eigenen Thread öffnen und kurz beschreiben, welche Rahmenbedingungen bestehen, was Du genau erreichen möchtest, also was am Ende rauskommen soll. Und alles so kurz wie möglich beschreiben, aber so umfassend und eindeutig wie nötig... dann kann man sehen, wie man am besten das Problem lösen kann.