Raspberry Pi GPIO + Relais

  • Hallo Leute,


    dies ist mein erster Beitrag und ich bin absoluter Elektrotechnik-Anfänger. :blush:
    Habe vor kurzen ein Pi geschenkt bekommen und wollte nun ein bisschen mit den GPIOs rumprobieren.
    Dazu habe ich mir ein Relais besorgt mit dem man 230V schalten kann, dieses läuft aber mit 5V.
    Nun meine Frage: ich habe nach etwas Recherche folgendes zusammengeklimpert - (siehe Attachment) - und wollte dies dann mit WiringPi ansprechen. Das grüne Wire würde ich dann an irgendeinen GPIO-Pin anschließen.



    Wird nun also beim Testen das Relais funktionieren oder werde ich mir die Bude abbrennen? :D


    Vielen Dank im Vorraus und Gruß!

  • Hallo,
    mit den GPIOs und den Relais am raspberry pi ist das so eine Sache. Grundsätzlich würde dein Setup so funktionieren, wie du es auf dem Bild gemalt hast.

  • Hallo,
    mit den GPIOs und diesen Relais-karten am Raspberry Pi ist das so eine Sache. Ich habe auch so ein Board gekauft, allerdings die Version mit 8 Relais. Grundsätzlich dachte ich auch, ich könnte es so anschließen, wie Du es auf deinem Bild gemalt hast. Ich habe es ausprobiert und es funktioniert auch so (keine Garantie von mir, falls Du etwas kaputt machst :P). Allerdings habe ich auch in diversen Foren gesucht ob man es so machen kann. Dabei bin ich auf folgenden Beitrag gestoßen:
    http://www.raspberrypi.org/phpBB3/viewtopic.php?f=45&t=30790&sid=25d466461cb5e0ec3f7a54e7fc4e4d47&start=25
    Hier ist quasi beschrieben, dass wenn man beim Anschließen und/oder programmieren der Pins etwas falsch macht, kann man sich seinen Pi zerstören könnte. Aus diesem Grund wird in diesem Beitrag empfohlen das Board über einen Transistor anzusteuern (http://de.wikipedia.org/wiki/Transistor).
    Auf diese Weise trennt man die 5 V von den 3.3 V und es kann nicht mehr viel passieren. Alternativ zu einer kompletten Transistorschaltung kann man auch einen Darlington Array verwenden (http://such001.reichelt.de/?SI…a7f9761773b9d6;ACTION=446)
    Darin sind quasi 8 Transistorstufen verbaut, sodass du insgesamt 8 Relais schalten könntest.
    Wo ich selbst noch unsicher bin ist, ob es langfristig gut ist die Relais über den raspberry mit Strom zu versorgen, da ich nicht weiß, wie viel Strom dieser liefern kann, bevor irgendwas kaputt geht. Aus Sicherheitsgründen habe ich deshalb beschlossen mein Relais board extern mit 5 Volt zu versorgen und es nur über den Pi zu schalten.
    Wie du den ULN2803A richtig anschließt ist hier ganz gut erklärt: http://www.skilltronics.de/versuch/elektronik_pc/uln.html


    Ich hoffe, dass das dir etwas weiter hilft.


    Viele Grüße. Hempel

  • Hallo,


    Da das Bild leider ein wenig verschwommen ist kann ich leider nicht viel erkennen. Aber es sieht so aus, als wäre schon ein Transistor und ein Optokoppler auf der Leiterplatte vorhanden. Wenn meine Vermutung stimmen würde, dann brauchst du keinen zusätzlichen Transistor mehr.


    Mach doch bitte, wenn möglich, noch mal eine Nahaufnahme von der Platine.


    Mfg maxl

  • Hallo Maxl,
    wenn du auf das Bild klickst wird es riesengroß.

    Quote


    Aber es sieht so aus, als wäre schon ein Transistor und ein Optokoppler auf der Leiterplatte vorhanden.


    Ja, die kleine schwarze Kiste ist ein Optokoppler, zumindest, wenn das board genauso aufgebaut ist, wie meins. Insofern ist die Transistor /Darlington Array Variante ein Overkill. Allerdings haben mich die Foreneinträge, die ich gepostet habe leicht verunsichert. Mit der Transistor /Darlington Array Lössung kann man dann sicher sein und für 35 cent als fertiges Bauteil war es mir dieser Overkill wert:-)

  • Ein Darlingtonarray wie der ULB2003 oder ULN2803 ist bei den fertigen Relaisplatinen eher kontraproduktiv. Die Platinen erwarten einen High-Pegel am Eingang, die Treiber schalten aber gegen Masse. Ohne einen zusätzlichen Pullup-Widerstand und umkehren der Ansteuerung (Low wenn das Relais an sein soll) passiert damit garnichts.


    Für den Anschluß am Pi muß man sich die Eingangsbeschaltung der Platine trotzdem ansehen um sicher zu gehen, daß keine 5Volt an die Ausgänge des Pi gelangen. Wenn man vorsichtshalber einen Treiber einsetzen will dann einen der den High-Pegel schaltet wie den UDN2981

  • Also meine Platine erwartet einen low-pegel am Eingang. Da funktioniert das mit dem ULN2803 großartig. Das ist nebenbei dann auch ein weiterer Vorteil von diesem Treiber, weil man dann nicht immer die gpios auf high stehen haben muss, sondern eben die Schaltlogik invertiert und damit das Relais mit einem "high" schalten kann.
    Aber es stimmt, dass ein Datenblatt zu eben diesem Relaisboard was du da hast sicherlich hilfreich wäre, weil man dann nicht rumspekulieren muss.

  • Hallo Leute,
    vielen Dank für die schnellen Antworten!



    Mach doch bitte, wenn möglich, noch mal eine Nahaufnahme von der Platine.


    Voila: - Anhang - Hoffe, sie sind besser!


    Datenblatt/Schaltplan habe ich schon angefragt, wenn ich es bekomme dann poste ich es direkt hier.


    Das mit den Transistoren habe ich mir auch zuerst zumindest theoretisch überlegt, wusste aber da nicht wie ich es realisieren soll. :blush:



    Gruß!

  • Schönen guten Tag,


    die Dinger sind wohl recht oft im Umlauf...
    Ich hab die 4fach Variante.


    nach Anfrage hab ich folgenden Schaltplan bekommen (I298n) der ist mir Irgend wie zu hoch


    Darauf hin hab ich mal eine Stecker gebastelt der Folgende verbindung herrstellt (v1)



    das ganze soll noch um 4 Taster erweitert werden.


    jetzt meine Frage die V1 sollte mir ja nicht den Pi bratten?


    ist es sinnvoll bei den Tastern das ganze doch um eine Transistorschaltung zu erweitern und die IN mit 5v anzusprechen.


    Grüße
    Wolf

  • Ist der L298 für Relais?
    Warum verwendest Du in der Steckerbelegung andere Bezeichnungen als in dem Schaltplan benutzt wurden? So kann man nicht sagen was da passiert.
    Wo willst Du die Taster anschließen bzw was sollen die bewirken?

  • das ist ja mein Problem
    ich habe den Stecker so auf gezeichnet wie die Pins beschriftet sind.
    mit der Aussnahme das VCC über einen Jumper mit JD-VCC gebrückt ist und ich diesen halt nicht nutze sondern JD-VCC direkt mit 5V versorge.


    hab bei Amazon diesen Komentar gelesen
    "Funktioniert einwandfrei.
    Alles klar und sauber beschriftet.
    Verarbeitung ist ebenfalls sehr gut.
    Alles über Optokoppler angesteuert.
    Relais schalten sehr leise.


    Hinweise zur Verwendung
    - man muss den Jumper entfernen
    - an den Pin JD-VDD legt man 5 V (versorgt die Relais)
    - an den Pin VDD legt man 3,3 V (versorgt die Dioden im Optokoppler, Vorwiderstand ist schon drin)
    - die Relais sind Umschalter
    - das Relais zieht an, wenn der Schalteingang (IN1 oder IN2) gegen Masse gezogen wird (GPIO-Pin am Pi auf 0)


    Wer kann das schon für dieses Geld selbst machen."

  • also doch falscher Schaltplan?
    ich zweifel gerade an mir



    Ich habe auch die Taster jetzt mit drin.


    die Relais sollen entweder über den Taster oder über eine Programm befehl geschalten werden.
    nur da kann der Pi die Taster ja selber überwachen


  • Hallo,
    kann jemand die Daten bestätigen?
    Ich habe die gleiche Karte und würde gerne wissen ob das rechte Bild den korrekten Anschluss zeigt.


    Das Schaltbild was ich bekommen habe sieht so aus (Anhang)


    Danke !!!


    UPDATE: Ich habe nun
    +5V an den JD-VCC (3) gelegt
    - an GND (1) gelegt
    externes Netzteil 5V


    Zum Testen
    IN 0 an GPIO17 (Pi)
    VCC an 3.3V (Pi)


    das Relais schaltet bei -> echo "0" > gpio17/value EIN
    das Relais schaltet bei -> echo "1" > gpio17/value AUS



    leider schalten die anderen Relais nicht...
    Die Status leds funktionieren und es liegen auch 3.3V an
    wo liegt mein fehler ?
    reichen die 3.3 V nicht aus ?
    was kann man tun ?
    Bei 5V schalten sie (mit Netzteil getestet)

  • Hallo,
    ich bins nochmal...


    Da die Relaiskarte sich weigert mit 3.3V ordentlich zu schalten, habe ich gedacht ich versuche es mal mit dieser Schaltung (Bild). Aber irgendwie glaube ich stimmt da was nicht. Ich will den Pi ja auch nicht braten :-(. Normal müsste doch an D1 5V anliegen womit ich die Karte schalten könnte oder ?


    Habe ich die falschen Bauteile gewählt ?
    Bin für jeden Tip dankbar!


    Schönen Abend noch.
    Datenblätter:
    http://lo.swek.de/pi/155900-da-01-en-BC337_25.pdf
    http://lo.swek.de/pi/162213-da…_Silizium_Diode_de_en.pdf
    http://lo.swek.de/pi/IMG_7200_beschr.jpg (Bild Aufbau)

    Edited once, last by Swopi ().

  • Auch wenns jetzt nicht arg weiter hilft: was spräche gegen das PiFace ??


    Das Ding ist extra für den Pi gemacht.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic + RedMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite)
    2x Pi Zero 1.3 (B. Lite) / 2x Pi Zero W 1.1 (B. Lite) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster) / Pi 400 (Buster) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT


  • Der Rezensent muss ziemliches Glück gehabt haben mit seinem Teil. Bei mir gingen zwei Kanäle und zwei gingen nicht, wobei das eine Relais davon auf klopfen doch noch anzog. Aber wer will schon immer daneben stehen und dem Relais nachhelfen ;-(


    Dann hab ich mir die Schaltung angesehen, es kann mit 3,3 Volt garnicht sicher schalten. Die Anzeige-LEDs sind mit den Optoppler-LEDs in Serie geschaltet, und da eine LED für ordentlichen Betrieb mindestens 1,8 Volt braucht, sind 3,3 Volt für beide definitiv zu wenig. Selbst wenn die Relais anziehen, sollte man von solcher Betriebsweise Abstand nehmen, denn die winzigen Schalttransistoren gehen dabei nicht in Sättigung und werden deshalb bald wegen Überhitzung ihren Geist aufgeben.


    Doch man kann die Reaiskarte auch ohne Zwischenschaltung am Raspi verwenden, wenn man auf die Anzeige-LEDs verzichtet. Entweder mit einem dünnen Draht überbrücken oder wenn man es schön haben will, die LEDs durch 0-Ohm-SMDs ersetzen. Dann reichen auch die 3,3 Volt für einen sicheren Betrieb.


    Die Optokoppler bewirken übrigens keine galvanische Trennung, da (zumindest in der 4er Version) beide Seiten eine gemeinsame Masse haben.


    Enttäuschend an der Karte ist auch der Platinenentwurf. Die beiden Klemmenblöcke sind zwar im 5,08 Raster, aber nur jede für sich und sind deshalb in einem Hutschienengehäuse nur zur Hälfte passend. Wer solches vorhat, sollte also lieber mehrere 2er-Karten verwenden.

  • Ich hab mal die CE-Spannung an den Transistoren gemessen mit und ohne Anzeige-LED.


    Mit: 1,6 1,8 2,2 1,7 Volt
    Ohne: 0,10 0,11 0,11 0,12 Volt


    Dh, bis fast zur Hälfte der 5 Volt Versorgungspannung erhitzt den Transistor,anstatt das Relais zu betätigen. Mit überbrückten LEDs nahezu volle Spannung am Relais.