Externe HDD Standbyproblem

  • Hallo liebe Community!


    Habe wie der Titel schon sagt ein Problem mit meiner externen Toshiba HDD, 500 GB USB 3.0 welche ich an einem Hub betreibe.


    Als Betriebssystem nutze ich die neueste Version von OpenELEC.


    Zu meinem Problem:
    Meine HDD hat leider eine relativ kurze Standby-Zeit. Sprich nach ein paar Minuten wenn man nicht auf sie zugreift geht sie in den Ruhemodus. Das würde mich noch nicht wirklich stören, das Problem ist jedoch, dass wenn sie wieder aufwacht, mein Raspberry einfriert :|


    Hat jemand eine Idee wie ich die Standbyfunktion deaktivieren könnte? Also wenn sie am Pi angeschlossen ist?


    Danke schonmal! :)

  • Naja, dass der Pi einfriert, wenn die Festplatte wieder aufwacht, sollte eigentlich nicht sein, das Ziel sollte eher sein die Ursache dafür zu finden und zu beheben ;)

  • Also..nach ewigem hin und her, probieren auf einem 2. Pi, Raspbmc und OpenElec und immer dem selben Problem, bin ich einfach zum örtlichen Supermarkt gefahren, hab mir dort eine 1 TB Festplatte geholt und siehe da..alles läuft so wie ichs haben will. Die Platte geht zwar auch in den Standby, schaltet sich aber problemlos wieder ein und nichts friert ein oder bleibt hängen :)


    Scheinbar mag meine Toshiba Platte den Pi nicht..naja..Problem gelöst :) Danke jedenfalls!


  • Also..nach ewigem hin und her, probieren auf einem 2. Pi, Raspbmc und OpenElec und immer dem selben Problem, bin ich einfach zum örtlichen Supermarkt gefahren, hab mir dort eine 1 TB Festplatte geholt und siehe da..alles läuft so wie ichs haben will. Die Platte geht zwar auch in den Standby, schaltet sich aber problemlos wieder ein und nichts friert ein oder bleibt hängen :)


    Scheinbar mag meine Toshiba Platte den Pi nicht..naja..Problem gelöst :) Danke jedenfalls!


    Hi,


    nur mal interessehalber und vielleicht um das hier wenistens einigermassen informativ abzuschliessen:


    ist das wieder eine USB 3.0 Platte?
    nimmst Du denselben Hub?
    ist das jetzt ein aktiver oder passiver Hub?
    USB 2.0 oder 3.0 Hub?


    Danke und cheers,
    -ds-

  • Hey um das ganze vielleicht wieder ein wenig wach zu rütteln, ich will mich da nicht so einfach geschlagen geben.


    Hab den RasPi Version B und eine Toshiba Externe Festplatte (1,5 TB, USB 3.0). Die Platte direkt am Pi sorgt beim Anstecken für einen neustart, weil wohl zu wenig Strom da ist, und auch dann läuft sie eher unrund bis gar nicht.


    Also hab ich einen Hub rangehängt (aktiven Hub, USB 2.0, 2A Stromversorgung). Hier geht die Platte problemlos an, nur die Problematik ist die gleiche wie beim Thread-Ersteller.
    Die Platte geht ziemlich schnell ohne Zugriff in den Standby. Das Problem taucht sowohl bei Raspbian als auch bei RaspBMC auf. Man greift nicht auf die Platte zu oder macht im Film nur mal schnell ne Pinkelpause und wenn man weiterschauen will passiert nichts.


    Die Platte wird noch erkannt, man kann sie jedoch einfach nicht mehr öffnen. Also beim draufklicken läd es und nichts passiert. Ein Unmount-Befehl wird mit "Device in Use" verneint, nur ein Neustart hilft. Kann man da was machen?

  • Danke das war schonmal sehr hilfreich. Nach einiger Studie des man von hdparm hab ich es so verstanden, dass man mit dem Parameter "-S" nur die Zeit ändern kann. Ich hab den Standby jetzt erst einmal komplett deaktiviert mit dem Parameter "-Z":


    "Disable the automatic power-saving function of certain Seagate drives (ST3xxx models?), to prevent them from idling/spinning down at inconvenient times."


    Das scheint funktioniert zu haben... jetzt werde ich mich etwas an den anderen Befehlen versuchen


    EDIT:
    Mhhhh... nahezu alle anderen interessanten Befehle (Standby, Sleep, Status-Check) bringen diese Fehlermeldung und machen nichts:


    "SG_IO: bad/missing sense data, sb[]: f0 00 01 00 50 40 00 0a 00 00 00 00 00 1d 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00"


    any ideas?

  • Hab mir das mal angesehen, vielen Dank dafür.


    Nach der im von dir verlinkten Thread angegebenen Anleitung hab ich es installiert und mir die man durchgelesen. Anschließend bin ich zum Schluss gekommen, mit dem Befehl


    hd-idle -i 0


    das Standy (scheinbar aller) Festplatten komplett zu deaktivieren...


    mal sehen obs hilft.
    Danke

  • okay problem's got big...


    der Standby scheint tatsächlich deaktiviert zu sein (bis jetzt)...


    allerdings wird die Platte jetzt nicht mehr automatisch beim anstecken gemountet... ich muss immer erst "sudo mount /dev/sda1" ausführen.
    Eintragen in die fstab mit Parameter "auto" ist ja nicht so der Knaller, da die Platte nicht unbedingt immer beim booten dransteckt.


    Also hab ich versucht eine Regel ins udev zu schreiben, da kenne ich mich aber überhaupt nicht aus. Hab eine Anleitung von ubuntuusers.de versucht, allerdings bringt das nicht. Die Platte blinkt zwar munter rum beim anstecken, wird aber nicht gemountet, nur mit meinem Befehl...


    Vorschläge?

  • Hab grade durch Zufall gesehen was in der graphischen Oberfläche passiert, wenn ich die Platte anstecke. Sonst greif ich immer per SSH auf den Pi zu und sehe das nicht:


    Folgende Fehlermeldung
    "Error mounting: mount exited with exit code 1: helper failed with: Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at http://tuxera.com/community/ntfs-3g-faq/#unprivileged"


    Danach hab ich nach einiger Internetrecherche gelesen, man soll mal "e2fsck -f /dev/sda1" ausführen. Der Befehl scheint nur für EXT-Platten zu sein, denn hier gibs diese Antwort:
    "e2fsck 1.42.5 (29-Jul-2012)
    ext2fs_open2: Ungültige magische Zahl im Superblock
    e2fsck: Superblock ungültig versuche es mit Backup-Blöcken...
    e2fsck: Ungültige magische Zahl im Superblock beim Versuch, /dev/sda zu öffnen


    SuperBlock ist unlesbar bzw. beschreibt kein gültiges ext2
    Dateisystem. Wenn Gerät gültig ist und ein ext2
    Dateisystem (kein swap oder ufs usw.) enthält, dann ist der SuperBlock
    beschädigt, und sie könnten e2fsck mit einem anderen SuperBlock:
    e2fsck -b 8193 <Gerät>"


    Irgendwelche Hinweise..?. Wie geht denn:
    "rebuild NTFS-3G with integrated FUSE support and make it setuid root."

  • joa meiner Meinung nach dürfte das bei mir in der fstab so passen:



    Code
    UUID=0A7C93D57C93B9C1 /media/TOSHIBA\040EXT ntfs rw,suid,dev,exec,async,users,noauto,permissions 0 0

  • Hallo zusammen,


    habe auch die Toshiba Platte und das selbe Problem.
    Bin mir jetzt nicht sicher ob denn der erste Teil hdparm funktioniert hat, oder nicht?

    If you play the game of thrones, you win or you die!



  • Moin moin,


    normalerweise kann der ein Linux System nur NTFS Partitionen lesen. Mit NTFS-3G ist es seit geraumer Zeit jedoch auch möglich diese zu beschreiben. Jedoch fordert der Treiber NTFS-3G aus Gründen der Sicherheit eine Einbindung durch den root.


    Eine kurze Suche bei der Suchmaschine deiner Wahl nach "mount ntfs-3g as user" sollte dir die nötige Anleitung geben um dies als User zu tun. Alternativ kannst du ntfs-3g neu kompilieren und das Einbinden für den normalen Benutzer aktivieren. Würde ich aber wegen dem schwachen Prozessor nicht auf dem Pi selber machen sondern cross-compiling von einem normalen Linux Rechner.


    Mit e2fsck kannst du, wie vermutet, nur Partitionen des Typ EXT2/3/4 überprüfen. Also in deinem Fall nicht hilfreich.


    Ich hatte in letzter Zeit das selbe Problem und dmesg machte mich immer darauf aufmerksam, dass das Dateisystem von Zeit zu Zeit korrupt wurde. Demnach würde ich einfach die Festplatte mit EXT4 formatieren (FAT32 ist ja mittlerweile keine Option mehr). Falls du die Festplatte von Zeit zu Zeit an einer Windows Rechner anschließen musst, würde ich darauf einfach einen EXT-Treiber installieren.


    Denn somit hast du auf deinem PI die nötige Software um die Festplatte vernünftig zu prüfen und zu warten.


    Zum eigentlichen Problem:


    bei mir hat hdparam -S0 /dev/sda die Lösung für das Problem geliefert.


    MfG


    onkelpit

  • Schade bei mir funktioniert das nicht einfach mit dem hdparm.
    Ich kriege eine ähnliche Meldung wie oben schon mal war. Hab unter den Kommentaren hier aber die Lösung nicht gefunden, oder vlt auch nur nicht verstanden.


    Code
    root@raspbmc:~# hdparm -S242 /dev/sda
    
    
    /dev/sda:
     setting standby to 242 (1 hours)
    SG_IO: bad/missing sense data, sb[]:  f0 00 01 00 50 40 f2 0a 00 00 00 00 00 1d                      00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

    If you play the game of thrones, you win or you die!