Retropi N64 Emulator läuft schlecht und Tastenbelegung ändern

  • Hallo Leute,


    ich bin echt am verzweifeln und habe schon mehrere Threads im Internet durchgeschaut. Zu Beginn möchte ich euch noch mitteilen das ich kein Profi in Sachen Linux bin und anhand den Anleitungen alles bisher gut ändern und fixen konnte. Folgendes Problem habe: 1. Mein N64 Emu läuft ziemlich ruckelig. Den GPU Speicher habe ich erweitert und greife nicht auf den standardmäßig eingestellten N64 Emu. Nach diesen Einstellung konnte ich wenigstens die Spiele starten und es ruckelt jetzt größten Teils nur im Spiel (Beispielsweise bei Mario Kart)


    Problem 2: im N64 Emu klappen nur zwei Tasten (A und B) ich kann weder steuern noch sonst etwas machen bis auf die beiden Knöpfe A und B (Start und Select klappen halt auch noch um aus dem Spiel wieder zu kommen) Wo kann ich die Tastenbelegung einstellen? In RetroArch habe ich bereits alles sauber eingestellt. Ich benutze zwei XBOX 360 Wireless Controller die wunderbar unter NES, SNES und PSX funktionieren.


    Hoffentlich könnt ihr mir weiterhelfen =(

  • Seit der Retropie Version 3.3 ist bereits der richtige N64 Emulator (Mupen64plus ) als Standardemulator eingestellt. Mario Kart läuft bei mir ohne Ruckeln, lediglich der Ton ist nicht der Beste. Am GPU Speicher habe ich nichts verändert.


    Benutzt du diese Retropie Version oder eine neuere, und diesen o.g. Emulator, wird die Controllerbelegung bereits durch die Emulatorstation automatisch vorgenommen.


    Nachtrag:
    Ich verwende einen Raspberry Pi 2 B

    Edited once, last by TommyT ().

  • Das kann ich nicht bestätigen. Nach der aktuellen Installation von Retro Pi (3.4) habe ich ein paar Roms übertragen und es getestet. Es war nicht ruckelfrei spielbar und wie gesagt konnte ich mit dem Controller quasi nicht spielen... Eingestellt habe ich beide Controller (XBOX 360 Wireless) unter RetroArch und halt quasi beim starten von EmulationsStation...


    Ich besitze ebenfalls den Pi 2 Model B

  • Ich kann nur noch mal bestätigen, bei mir laufen z.B. Mario Kart, Diddy Kong Racing und Turok ruckelfrei (... und ich habe nicht übertaktet). Klar aber auch, bei den meisten N-64 Games funktioniert der Raspberry nur sehr rudimentär bis gar nicht, ist halt einfach zu schwach auf der Brust.


    Zur Tastenbelegung: Ja, das habe ich gemeint, dass ab 3.3 mit dem Starten der Emulationstation der Controller und die Tastenbelegung für Mupen64plus mit eingerichtet wird. Ich benutze als Controller einen PS3-Clon (Logitech Cordless Precision), und komme mit der Bedienung klar.

  • Standartmäßig ist ja lr-mupen64plus eingestellt. Durch einen Hinweis im Internet wurde geraten auf mupenplus-gles2n64 zu wechseln da es flüssiger läuft als der standart eingerichtet Emu. Das hatte ein wenig geholfen.


    Hier mal eine Auflistung, welchen benutzt du denn? Wirklich den standart eingestellen Emu?


    1. lr-mupen64plus
    2. mupen64plus-gles2n64
    3. mupen64plus-gles2rice
    4. mupen64plus-GlideN64

  • Bei mir ist mupen64plus-gles2rice als Standard eingestellt. Wie schon gesagt, der Ton ist teilweise unterirdisch.

  • Die Probleme liegen bei dem Emulator selbst. Du kannst unter Google gerne mal mupen64plus speed issues eingeben. Da wirst du relativ schnell fündig. Deswegen wird eine USB Soundkarte nichts bringen.

  • Update am besten mal auf Retropie 3.6 und schau nochmal in die Tastenbelegung

  • Vielleicht ist deine Stromversorgung zu schwach. Der Raspberry pi 2 sollte mindestens 2A kriegen. Da steht auf deinem Netzteil irgendwo "output" drauf.